package/icu: bump version to 67-1
Release notes: http://site.icu-project.org/download/66 http://site.icu-project.org/download/67 Removed patches applied upstream: 0005:4a3a457b38
0006 - 0008:b7facd4874
Reformatted hash file, locally computed tarball hash, upstream does not provide hashes anymore. Updated license hash due to update in copyright years (2019 -> 2020):d95621c57f
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [yann.morin.1998@free.fr: further explain the license hash change] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
ec295dbcc6
commit
2163c4c5dd
@ -1,34 +0,0 @@
|
||||
From 9be0b489a94b57419202c552022f25cb95bfac51 Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Kanavin <alex.kanavin@gmail.com>
|
||||
Date: Wed, 17 Apr 2019 16:41:58 +0200
|
||||
Subject: [PATCH] Fix big-endian build
|
||||
|
||||
Bug-report: https://unicode-org.atlassian.net/browse/ICU-20533
|
||||
Patch taken from: https://bugs.gentoo.org/682170
|
||||
|
||||
Upstream-Status: Pending
|
||||
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
|
||||
|
||||
Downloaded from
|
||||
http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-support/icu/icu/0001-Fix-big-endian-build.patch?h=master
|
||||
|
||||
[Bernd: Fixed path]
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
---
|
||||
data/Makefile.in | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source/data/Makefile.in b/source/data/Makefile.in
|
||||
index 778b6c7..67203e7 100644
|
||||
--- a/source/data/Makefile.in
|
||||
+++ b/source/data/Makefile.in
|
||||
@@ -148,7 +148,8 @@ ICUDATA_ARCHIVE = $(firstword $(wildcard $(srcdir)/in/$(ICUDATA_BASENAME_VERSION
|
||||
# and convert it to the current type.
|
||||
ifneq ($(ICUDATA_ARCHIVE),)
|
||||
ICUDATA_SOURCE_ARCHIVE = $(OUTDIR)/$(ICUDATA_PLATFORM_NAME).dat
|
||||
-$(ICUDATA_SOURCE_ARCHIVE): $(ICUDATA_ARCHIVE) $(OUTDIR)
|
||||
+$(ICUDATA_SOURCE_ARCHIVE): $(ICUDATA_ARCHIVE)
|
||||
+ $(MKINSTALLDIRS) $(OUTDIR)
|
||||
$(INVOKE) $(TOOLBINDIR)/icupkg -t$(ICUDATA_CHAR) $(ICUDATA_ARCHIVE) $(ICUDATA_SOURCE_ARCHIVE)
|
||||
endif
|
||||
else
|
@ -1,46 +0,0 @@
|
||||
From d9d99097a5b28f4204b3a15e82564e50f9e62f5a Mon Sep 17 00:00:00 2001
|
||||
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
Date: Sat, 3 Aug 2019 08:05:35 +0200
|
||||
Subject: [PATCH] ICU-20751 Fix nios2 build
|
||||
|
||||
Nios2 supports double conversion, tested using qemu:
|
||||
|
||||
./main || echo "correct"
|
||||
correct
|
||||
uname -a
|
||||
Linux buildroot 4.19.16 #4 Sat Aug 3 14:46:48 CEST 2019 nios2 GNU/Linux
|
||||
|
||||
Solves build error
|
||||
|
||||
In file included from double-conversion.h:42:0,
|
||||
from number_decimalquantity.cpp:19:
|
||||
double-conversion-utils.h:119:2: error: #error Target architecture was not detected as supported by Double-Conversion.
|
||||
#error Target architecture was not detected as supported by Double-Conversion.
|
||||
|
||||
detected by buildroot autobuilders:
|
||||
http://autobuild.buildroot.net/results/91e/91eaec34708d91f8a05af189243be0b7cabce31b/
|
||||
|
||||
Patch sent upstream: https://github.com/unicode-org/icu/pull/725
|
||||
Bug report: https://unicode-org.atlassian.net/browse/ICU-20751
|
||||
|
||||
[Bernd: Fixed path]
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
---
|
||||
source/i18n/double-conversion-utils.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/source/i18n/double-conversion-utils.h b/source/i18n/double-conversion-utils.h
|
||||
index 1e44fcaa0e..0cf993929f 100644
|
||||
--- a/source/i18n/double-conversion-utils.h
|
||||
+++ b/source/i18n/double-conversion-utils.h
|
||||
@@ -95,6 +95,7 @@ int main(int argc, char** argv) {
|
||||
defined(__ARMEL__) || defined(__avr32__) || defined(_M_ARM) || defined(_M_ARM64) || \
|
||||
defined(__hppa__) || defined(__ia64__) || \
|
||||
defined(__mips__) || \
|
||||
+ defined(__nios2__) || \
|
||||
defined(__powerpc__) || defined(__ppc__) || defined(__ppc64__) || \
|
||||
defined(_POWER) || defined(_ARCH_PPC) || defined(_ARCH_PPC64) || \
|
||||
defined(__sparc__) || defined(__sparc) || defined(__s390__) || \
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 395f063b6af8885cc9d688eeeb44acf9d75c6045 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Thu, 3 Oct 2019 16:31:22 +0200
|
||||
Subject: [PATCH] double-conversion: enable for microblaze
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
source/i18n/double-conversion-utils.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/source/i18n/double-conversion-utils.h b/source/i18n/double-conversion-utils.h
|
||||
index 0cf9939..a00037e 100644
|
||||
--- a/source/i18n/double-conversion-utils.h
|
||||
+++ b/source/i18n/double-conversion-utils.h
|
||||
@@ -104,6 +104,7 @@ int main(int argc, char** argv) {
|
||||
defined(__AARCH64EL__) || defined(__aarch64__) || defined(__AARCH64EB__) || \
|
||||
defined(__riscv) || \
|
||||
defined(__or1k__) || defined(__arc__) || \
|
||||
+ defined(__microblaze__) || \
|
||||
defined(__EMSCRIPTEN__)
|
||||
#define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
|
||||
#elif defined(__mc68000__) || \
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,26 +0,0 @@
|
||||
From f8f37357fa7cc403848d2bafe6152a707ca3a074 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Mon, 28 Oct 2019 21:26:05 +0100
|
||||
Subject: [PATCH] double-conversion: enable for xtensa
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
source/i18n/double-conversion-utils.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source/i18n/double-conversion-utils.h b/source/i18n/double-conversion-utils.h
|
||||
index a00037e..b3100ac 100644
|
||||
--- a/source/i18n/double-conversion-utils.h
|
||||
+++ b/source/i18n/double-conversion-utils.h
|
||||
@@ -104,7 +104,7 @@ int main(int argc, char** argv) {
|
||||
defined(__AARCH64EL__) || defined(__aarch64__) || defined(__AARCH64EB__) || \
|
||||
defined(__riscv) || \
|
||||
defined(__or1k__) || defined(__arc__) || \
|
||||
- defined(__microblaze__) || \
|
||||
+ defined(__microblaze__) || defined(__XTENSA__) || \
|
||||
defined(__EMSCRIPTEN__)
|
||||
#define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
|
||||
#elif defined(__mc68000__) || \
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,4 +1,3 @@
|
||||
# From https://github.com/unicode-org/icu/releases/download/release-65-1/SHASUM512.txt
|
||||
sha512 8f1ef33e1f4abc9a8ee870331c59f01b473d6da1251a19ce403f822f3e3871096f0791855d39c8f20c612fc49cda2c62c06864aa32ddab2dbd186d2b21ce9139 icu4c-65_1-src.tgz
|
||||
# Locally computed
|
||||
sha256 6a18c5fac70d7860b57f5b72b4e2c9a1ba6b3d2741eef7ff9767c5379364f10d LICENSE
|
||||
sha256 94a80cd6f251a53bd2a997f6f1b5ac6653fe791dfab66e1eb0227740fb86d5dc icu4c-67_1-src.tgz
|
||||
sha256 25e21013a7bc2fad735e28c5278a120e4c7f1c327c8c8b9b4df1751748cddbb2 LICENSE
|
||||
|
@ -7,7 +7,7 @@
|
||||
# Git tags (and therefore versions on release-monitoring.org) use the
|
||||
# XX-Y format, but the tarballs are named XX_Y and the containing
|
||||
# directories XX.Y.
|
||||
ICU_VERSION = 65-1
|
||||
ICU_VERSION = 67-1
|
||||
ICU_SOURCE = icu4c-$(subst -,_,$(ICU_VERSION))-src.tgz
|
||||
ICU_SITE = \
|
||||
https://github.com/unicode-org/icu/releases/download/release-$(ICU_VERSION)
|
||||
|
Loading…
Reference in New Issue
Block a user