package/grantlee: fix build with newer cmake
Fixes: - http://autobuild.buildroot.org/results/8cb0c153620be5765c098f05a2440fa1f3e4e2c2 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
1185b0a56e
commit
2130f663ec
27
package/grantlee/0001-Remove-vestigial-ansi-flag.patch
Normal file
27
package/grantlee/0001-Remove-vestigial-ansi-flag.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From c989fcf192d01d26866faf6405a28ba4fdce64c3 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Kelly <steveire@gmail.com>
|
||||
Date: Sun, 21 Jul 2019 16:00:41 +0100
|
||||
Subject: [PATCH] Remove vestigial -ansi flag
|
||||
|
||||
This causes the compiler to not operate in C++11 mode, meaning that
|
||||
headers such as <type_traits> issue errors.
|
||||
[Retrieved from:
|
||||
https://github.com/steveire/grantlee/commit/c989fcf192d01d26866faf6405a28ba4fdce64c3]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6d51110..9172213 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -59,7 +59,7 @@ endif()
|
||||
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
|
||||
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common ")
|
||||
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common ")
|
||||
|
||||
if (CMAKE_BUILD_TYPE MATCHES TestCocoon)
|
||||
# Needed on 64 bit
|
Loading…
Reference in New Issue
Block a user