packages/libwebsockets: add patch that removes duplicate LwsCheckRequirements

Fixes:
  CMake Error at /home/buildroot/autobuild/run/instance-2/output-1/host/mipsel-buildroot-linux-gnu/sysroot/usr/lib/cmake/libwebsockets/libwebsockets-config.cmake:35 (include):
  include could not find load file:

      LwsCheckRequirements
  Call Stack (most recent call first):
    CMakeLists.txt:54 (find_package)

Signed-off-by: Bartosz Bilas <bartosz.bilas@hotmail.com>
Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Bartosz Bilas 2022-04-19 20:47:56 +02:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent b790ff27d5
commit 2097e1ba39

View File

@ -0,0 +1,26 @@
From 99a8b9c4422bed45c8b7412a1e121056f2a6132a Mon Sep 17 00:00:00 2001
From: Andy Green <andy@warmcat.com>
Date: Mon, 7 Feb 2022 14:48:55 +0000
Subject: [PATCH] cmake: remove duplicate LwsCheckRequirements
Signed-off-by: Andy Green <andy@warmcat.com>
Signed-off-by: Bartosz Bilas <bartosz.bilas@hotmail.com>
Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
cmake/libwebsockets-config.cmake.in | 1 -
1 file changed, 1 deletion(-)
diff --git a/cmake/libwebsockets-config.cmake.in b/cmake/libwebsockets-config.cmake.in
index 6247b2cb..8ba97e6f 100644
--- a/cmake/libwebsockets-config.cmake.in
+++ b/cmake/libwebsockets-config.cmake.in
@@ -32,6 +32,5 @@ endforeach()
include(CheckIncludeFile)
include(CheckCSourceCompiles)
-include(LwsCheckRequirements)
set(requirements 1)
--
2.35.3