From 1f92be091b27a56a08c500481db7617f0dc68ed9 Mon Sep 17 00:00:00 2001
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
Date: Sat, 23 Jul 2022 15:42:49 +0200
Subject: [PATCH] package/zfs: fix pam support

The --enable option was added to CONF_ENV instead of CONF_OPTS. For this
defconfig

BR2_arm=y
BR2_TOOLCHAIN_EXTERNAL=y
BR2_LINUX_KERNEL=y
BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG=y
BR2_PACKAGE_ZFS=y
BR2_PACKAGE_LINUX_PAM=y

this yields

/bin/sh: line 1: --enable-pam=yes: command not found

While we're at it, also remove the =yes which we usually don't add.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
(cherry picked from commit 8f79ab8f1e92ff86fa00f4cbfceabde0af3c2e9f)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/zfs/zfs.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package/zfs/zfs.mk b/package/zfs/zfs.mk
index 07ce3295ec..0a6e4a3cfa 100644
--- a/package/zfs/zfs.mk
+++ b/package/zfs/zfs.mk
@@ -52,7 +52,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 ZFS_DEPENDENCIES += linux-pam
-ZFS_CONF_ENV += --enable-pam=yes
+ZFS_CONF_OPTS += --enable-pam
 else
 ZFS_CONF_OPTS += --disable-pam
 endif