wipe: bump to version 2.3.1 and switch to sourceforge
The original version is gone, so switch to sourceforge wipe and bump to version 2.3.1 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
7804b7bda3
commit
1f8442b5c2
@ -4,4 +4,4 @@ config BR2_PACKAGE_WIPE
|
||||
Wipe is a little command for securely erasing files
|
||||
from magnetic media. It compiles under various unix platforms.
|
||||
|
||||
http://lambda-diode.com/software/wipe
|
||||
http://wipe.sourceforge.net
|
||||
|
16
package/wipe/wipe-dont-force-lfs.patch
Normal file
16
package/wipe/wipe-dont-force-lfs.patch
Normal file
@ -0,0 +1,16 @@
|
||||
LARGEFILE support shouldn't be forced into CFLAGS
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
|
||||
diff -Nura wipe-2.3.1/configure.in wipe-2.3.1-lfs/configure.in
|
||||
--- wipe-2.3.1/configure.in 2009-06-15 22:55:11.000000000 -0300
|
||||
+++ wipe-2.3.1-lfs/configure.in 2012-03-05 11:25:30.463221948 -0300
|
||||
@@ -91,7 +91,7 @@
|
||||
test "$with_efence" = "yes" && temp2CFLAGS="$debugCFLAGS" && LIBS="-lefence"
|
||||
|
||||
DEBUG="$debugCFLAGS $fullCFLAGS"
|
||||
-fullCFLAGS="$temp2CFLAGS $fullCFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
|
||||
+fullCFLAGS="$temp2CFLAGS $fullCFLAGS"
|
||||
CFLAGS="$checkCFLAGS -D__USE_BSD -D_BSD_SOURCE -D__USE_POSIX -D_POSIX_SOURCE -D_POSIX_MAPPED_FILES"
|
||||
|
||||
dnl Checks for libraries.
|
@ -4,20 +4,10 @@
|
||||
#
|
||||
#############################################################
|
||||
|
||||
WIPE_VERSION = 0.22
|
||||
WIPE_SITE = http://lambda-diode.com/resources/wipe
|
||||
WIPE_CFLAGS = $(TARGET_CFLAGS) -DHAVE_DEV_URANDOM -DHAVE_OSYNC -DHAVE_STRCASECMP -DHAVE_RANDOM -DSYNC_WAITS_FOR_SYNC -DFIND_DEVICE_SIZE_BY_BLKGETSIZE
|
||||
|
||||
ifeq ($(BR2_LARGEFILE),y)
|
||||
WIPE_CFLAGS += -DSIXTYFOUR
|
||||
endif
|
||||
|
||||
define WIPE_BUILD_CMDS
|
||||
# Fix busted git version logic
|
||||
$(SED) "s/which/!which/" $(@D)/Makefile
|
||||
$(MAKE) -C $(@D) linux CC_LINUX="$(TARGET_CC)" \
|
||||
CCO_LINUX="$(WIPE_CFLAGS)"
|
||||
endef
|
||||
WIPE_VERSION = 2.3.1
|
||||
WIPE_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/wipe
|
||||
WIPE_SOURCE = wipe-$(WIPE_VERSION).tar.bz2
|
||||
WIPE_AUTORECONF = YES
|
||||
|
||||
define WIPE_INSTALL_TARGET_CMDS
|
||||
$(INSTALL) -D $(@D)/wipe $(TARGET_DIR)/usr/bin/wipe
|
||||
@ -29,8 +19,4 @@ define WIPE_UNINSTALL_TARGET_CMDS
|
||||
rm -f $(TARGET_DIR)/usr/share/man/man1/wipe.1
|
||||
endef
|
||||
|
||||
define WIPE_CLEAN_CMDS
|
||||
$(MAKE) -C $(@D) clean
|
||||
endef
|
||||
|
||||
$(eval $(call GENTARGETS))
|
||||
$(eval $(call AUTOTARGETS))
|
||||
|
Loading…
Reference in New Issue
Block a user