package/libsolv: bump to version 0.7.25

Drop patch (already in version)

https://github.com/openSUSE/libsolv/blob/0.7.25/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2023-11-05 22:46:27 +01:00 committed by Thomas Petazzoni
parent c4c555bd57
commit 1eb07c1904
4 changed files with 2 additions and 52 deletions

View File

@ -742,7 +742,6 @@ package/libsigrok/0001-Support-glibmm-2.68.patch Upstream
package/libsigrokdecode/0001-configure-ac-Add-support-for-Python-3-9.patch Upstream
package/libsigrokdecode/0002-configure-Add-python-3-10-support.patch Upstream
package/libsigrokdecode/0003-configure-ac-Use-python3-embed-pc-as-a-fallback.patch Upstream
package/libsolv/0001-Fix-build-without-C.patch Upstream
package/libsoup/0001-meson.build-set-c_std-to-gnu99.patch Upstream
package/libsoxr/0001-Add-Libs.private-for-static-linking.patch Upstream
package/libspatialindex/0001-allow-building-static-libs.patch Upstream

View File

@ -1,49 +0,0 @@
From 5691f58d1f8ce1332b02536e48f1ac5864629c6c Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 12 Feb 2023 15:27:27 +0100
Subject: [PATCH] Fix build without C++
Fix the following build failure without C++:
CMake Error at CMakeLists.txt:1 (PROJECT):
No CMAKE_CXX_COMPILER could be found.
Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.
Fixes:
- http://autobuild.buildroot.org/results/a7f2176d40f156c319754ef5d3b7fd0decfe754f
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/openSUSE/libsolv/pull/520]
---
CMakeLists.txt | 2 +-
ext/CMakeLists.txt | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3541f496..f899c49a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-PROJECT (libsolv)
+PROJECT (libsolv C)
CMAKE_MINIMUM_REQUIRED (VERSION 2.8.5)
diff --git a/ext/CMakeLists.txt b/ext/CMakeLists.txt
index f01c0238..589fa946 100644
--- a/ext/CMakeLists.txt
+++ b/ext/CMakeLists.txt
@@ -103,6 +103,7 @@ IF (ENABLE_CUDFREPO)
ENDIF (ENABLE_CUDFREPO)
IF (ENABLE_HAIKU)
+ enable_language(CXX)
SET (libsolvext_SRCS ${libsolvext_SRCS}
repo_haiku.cpp)
SET (libsolvext_HEADERS ${libsolvext_HEADERS}
--
2.39.0

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 968aef452b5493751fa0168cd58745a77c755e202a43fe8d549d791eb16034d5 libsolv-0.7.22.tar.gz
sha256 b382bba4196b19c36eb34e0ef02546c0b922be601c6f73390c9ab643895b656a libsolv-0.7.25.tar.gz
sha256 57f15acfb29fbef7749779e096a5885c60b716633e34484a21bb717554c0198f LICENSE.BSD

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBSOLV_VERSION = 0.7.22
LIBSOLV_VERSION = 0.7.25
LIBSOLV_SITE = $(call github,openSUSE,libsolv,$(LIBSOLV_VERSION))
LIBSOLV_LICENSE = BSD-3-Clause
LIBSOLV_LICENSE_FILES = LICENSE.BSD