package/suricata: fix pcap static build
Fixes: - no autobuilder failures yet Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
39dde1ffb6
commit
1ce2db1090
@ -0,0 +1,29 @@
|
||||
From 2660123b0c16d7f6a49747711be676c4119561c9 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Wed, 24 Apr 2019 20:35:20 +0200
|
||||
Subject: [PATCH] configure.ac: fix static build with pcap
|
||||
|
||||
pcap can depends on nl-3 so use pkg-config to find these dependencies
|
||||
otherwise all AC_CHECK_LIB calls will fail when building statically
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: not sent yet]
|
||||
---
|
||||
configure.ac | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ee59c9d8e..5ec341231 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1331,6 +1331,7 @@
|
||||
AC_CHECK_HEADERS([pcap.h pcap/pcap.h pcap/bpf.h])
|
||||
|
||||
LIBPCAP=""
|
||||
+ PKG_CHECK_MODULES([PCAP],libpcap,[CPPFLAGS="${CPPFLAGS} ${PCAP_CFLAGS}" LIBS="${LIBS} ${PCAP_LIBS}"],[])
|
||||
AC_CHECK_LIB(${PCAP_LIB_NAME}, pcap_open_live,, LIBPCAP="no")
|
||||
if test "$LIBPCAP" = "no"; then
|
||||
echo
|
||||
--
|
||||
2.20.1
|
||||
|
Loading…
Reference in New Issue
Block a user