package/hiredis: fix build with gcc 4.8
This patch is needed to fix a build failure with hiredis 1.0.0 Fixes: - http://autobuild.buildroot.org/results/f7aa90d6d6750fb8bf46334513df09360a8c1c7f Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
9400e8a4c3
commit
1c8aea467b
28
package/hiredis/0003-Explicitly-set-c99-in-CMake.patch
Normal file
28
package/hiredis/0003-Explicitly-set-c99-in-CMake.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 13a35bdb64615e381c5e1151cdd4e78bba71a6db Mon Sep 17 00:00:00 2001
|
||||
From: michael-grunder <michael.grunder@gmail.com>
|
||||
Date: Fri, 28 Aug 2020 12:35:01 -0700
|
||||
Subject: [PATCH] Explicitly set c99 in CMake
|
||||
|
||||
See #869
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/redis/hiredis/commit/13a35bdb64615e381c5e1151cdd4e78bba71a6db]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 1beccc69a..4cbd438d7 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -22,6 +22,9 @@ MESSAGE("Detected version: ${VERSION}")
|
||||
|
||||
PROJECT(hiredis VERSION "${VERSION}")
|
||||
|
||||
+# Hiredis requires C99
|
||||
+SET(CMAKE_C_STANDARD 99)
|
||||
+
|
||||
SET(ENABLE_EXAMPLES OFF CACHE BOOL "Enable building hiredis examples")
|
||||
|
||||
SET(hiredis_sources
|
Loading…
Reference in New Issue
Block a user