ntp: add ntptime option

Allow the `ntptime` utility to be included on a target.

[Peter: add comment why AUTORECONF is needed]
Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
James Knight 2015-10-14 19:45:33 -04:00 committed by Peter Korsgaard
parent 84120c10f5
commit 1c6629444d
3 changed files with 36 additions and 0 deletions

View File

@ -0,0 +1,27 @@
inline ntp syscalls fallback
Reference:
https://bugs.ntp.org/show_bug.cgi?id=769
Signed-off-by: James Knight <james.knight@rockwellcollins.com>
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -1523,11 +1523,11 @@ AC_CACHE_CHECK(
[ntp_cv_var_ntp_syscalls],
[
ntp_cv_var_ntp_syscalls=no
- case "$ac_cv_func_ntp_adjtime$ac_cv_func_ntp_gettime$ac_cv_func___adjtimex" in
+ case "$ac_cv_func_ntp_adjtime$ac_cv_func_ntp_gettime$ac_cv_func___adjtimex$ac_cv_func_adjtimex" in
yesyes*)
ntp_cv_var_ntp_syscalls=libc
;;
- *yes)
+ *yesyes | *yesno | *noyes)
ntp_cv_var_ntp_syscalls=inline
;;
*)

View File

@ -67,6 +67,12 @@ config BR2_PACKAGE_NTP_NTPSNMPD
help
Install ntpsnmpd NTP SNMP MIB agent.
config BR2_PACKAGE_NTP_NTPTIME
bool "ntptime"
help
The ntptime utility program is used to read and set kernel time
variables.
config BR2_PACKAGE_NTP_NTPTRACE
bool "ntptrace"
depends on BR2_PACKAGE_PERL

View File

@ -17,6 +17,8 @@ NTP_CONF_OPTS = \
--disable-tickadj \
--with-yielding-select=yes \
--disable-local-libevent
# 0002-ntp-syscalls-fallback.patch
NTP_AUTORECONF = YES
ifeq ($(BR2_PACKAGE_OPENSSL),y)
NTP_CONF_OPTS += --with-crypto
@ -46,6 +48,7 @@ NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPDATE) += ntpdate/ntpdate
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPDC) += ntpdc/ntpdc
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPQ) += ntpq/ntpq
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPSNMPD) += ntpsnmpd/ntpsnmpd
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPTIME) += util/ntptime
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPTRACE) += scripts/ntptrace/ntptrace
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_SNTP) += sntp/sntp
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_TICKADJ) += util/tickadj