package/freeswitch: bump version to 1.10.8
Release notes: https://github.com/signalwire/freeswitch/releases/tag/v1.10.8 Removed two patches which are included in upstream release, renumbered remaining patch. Removed libs/apr-util/LICENSE due to upstream removal of bundled apr-util package. Added fix to disable pcap detection, otherwise /usr/bin/pcap-config can be picked-up which breaks building freeswitch. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
6c33056fff
commit
1b8230ab64
@ -1,26 +0,0 @@
|
||||
From 68039d344d8e826e8b403c9cd0284fd07b4495ac Mon Sep 17 00:00:00 2001
|
||||
From: Dragos Oancea <dragos@signalwire.com>
|
||||
Date: Tue, 26 Oct 2021 08:42:58 +0000
|
||||
Subject: [PATCH] [core] fix build SWITCH_BYTE_ORDER == __BIG_ENDIAN
|
||||
|
||||
Downloaded from upstream commit:
|
||||
https://github.com/signalwire/freeswitch/commit/68039d344d8e826e8b403c9cd0284fd07b4495ac
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
---
|
||||
src/switch_rtp.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/switch_rtp.c b/src/switch_rtp.c
|
||||
index 1880bbb19c..843ee81381 100644
|
||||
--- a/src/switch_rtp.c
|
||||
+++ b/src/switch_rtp.c
|
||||
@@ -2155,7 +2155,7 @@ static void switch_send_rtcp_event(switch_rtp_t *rtp_session ,struct switch_rtcp
|
||||
switch_event_add_header_string(event, SWITCH_STACK_BOTTOM, header, value);
|
||||
snprintf(header, sizeof(header), "Source-Lost");
|
||||
#if SWITCH_BYTE_ORDER == __BIG_ENDIAN
|
||||
- tmpLost = report->lost; /* signed 24bit will extended signess to int32_t automatically */
|
||||
+ tmpLost = rtcp_report_block->lost; /* signed 24bit will extended signess to int32_t automatically */
|
||||
#else
|
||||
tmpLost = ntohl(rtcp_report_block->lost)>>8;
|
||||
tmpLost = tmpLost | ((tmpLost & 0x00800000) ? 0xff000000 : 0x00000000); /* ...and signess compensation */
|
@ -1,129 +0,0 @@
|
||||
From a2ce46c6fde38d6ac54a8a2ee1a5b391e2ed2071 Mon Sep 17 00:00:00 2001
|
||||
From: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
Date: Mon, 1 Nov 2021 09:59:09 +0100
|
||||
Subject: [PATCH] [core] fix "--disable-libyuv"
|
||||
|
||||
Recent changes made it impossible to compile freeswitch without libyuv
|
||||
support.
|
||||
|
||||
src/switch_core_video.c: In function 'switch_img_read_from_file':
|
||||
src/switch_core_video.c:3139:4: error: implicit declaration of function 'RAWToI420' [-Werror=implicit-function-declaration]
|
||||
RAWToI420(data, width * 3,
|
||||
^
|
||||
src/switch_core_video.c:3148:4: error: implicit declaration of function 'ABGRToARGB' [-Werror=implicit-function-declaration]
|
||||
ABGRToARGB(data, width * 4, img->planes[SWITCH_PLANE_PACKED], img->stride[SWITCH_PLANE_PACKED], width, height);
|
||||
^
|
||||
|
||||
Fix this my adding/moving the checks for "SWITCH_HAVE_YUV".
|
||||
|
||||
Downloaded from upstream commit:
|
||||
https://github.com/signalwire/freeswitch/commit/a2ce46c6fde38d6ac54a8a2ee1a5b391e2ed2071
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
---
|
||||
src/switch_core_video.c | 12 ++++++++++++
|
||||
tests/unit/switch_core_video.c | 4 ++++
|
||||
2 files changed, 16 insertions(+)
|
||||
|
||||
diff --git a/src/switch_core_video.c b/src/switch_core_video.c
|
||||
index 7dbd685d6ee..0d377f9c3e4 100644
|
||||
--- a/src/switch_core_video.c
|
||||
+++ b/src/switch_core_video.c
|
||||
@@ -3116,6 +3116,7 @@ SWITCH_DECLARE(switch_status_t) switch_img_data_url_png(switch_image_t *img, cha
|
||||
|
||||
SWITCH_DECLARE(switch_image_t *) switch_img_read_from_file(const char* file_name, switch_img_fmt_t img_fmt)
|
||||
{
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
int width = 0, height = 0, channels = 0;
|
||||
int comp = STBI_rgb;
|
||||
unsigned char *data = NULL;
|
||||
@@ -3155,12 +3156,16 @@ SWITCH_DECLARE(switch_image_t *) switch_img_read_from_file(const char* file_name
|
||||
} else if (data) {
|
||||
stbi_image_free(data);
|
||||
}
|
||||
+#endif
|
||||
|
||||
return NULL;
|
||||
}
|
||||
|
||||
SWITCH_DECLARE(switch_status_t) switch_img_write_to_file(switch_image_t *img, const char* file_name, int quality)
|
||||
{
|
||||
+#ifndef SWITCH_HAVE_YUV
|
||||
+ return SWITCH_STATUS_FALSE;
|
||||
+#else
|
||||
int comp = STBI_rgb;
|
||||
unsigned char *data = NULL;
|
||||
const char *ext = strrchr(file_name, '.');
|
||||
@@ -3217,6 +3222,7 @@ SWITCH_DECLARE(switch_status_t) switch_img_write_to_file(switch_image_t *img, co
|
||||
free(data);
|
||||
|
||||
return ret ? SWITCH_STATUS_SUCCESS : SWITCH_STATUS_FALSE;
|
||||
+#endif
|
||||
}
|
||||
|
||||
typedef struct data_url_context_s {
|
||||
@@ -3224,14 +3230,19 @@ typedef struct data_url_context_s {
|
||||
char **urlP;
|
||||
} data_url_context_t;
|
||||
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
static void data_url_write_func(void *context, void *data, int size)
|
||||
{
|
||||
switch_buffer_t *buffer = (switch_buffer_t *)context;
|
||||
switch_buffer_write(buffer, data, size);
|
||||
}
|
||||
+#endif
|
||||
|
||||
SWITCH_DECLARE(switch_status_t) switch_img_data_url(switch_image_t *img, char **urlP, const char *type, int quality)
|
||||
{
|
||||
+#ifndef SWITCH_HAVE_YUV
|
||||
+ return SWITCH_STATUS_FALSE;
|
||||
+#else
|
||||
int comp = STBI_rgb;
|
||||
unsigned char *data = NULL;
|
||||
int stride_in_bytes = 0;
|
||||
@@ -3300,6 +3311,7 @@ SWITCH_DECLARE(switch_status_t) switch_img_data_url(switch_image_t *img, char **
|
||||
switch_buffer_destroy(&buffer);
|
||||
|
||||
return ret ? SWITCH_STATUS_SUCCESS : SWITCH_STATUS_FALSE;
|
||||
+#endif /* SWITCH_HAVE_YUV */
|
||||
}
|
||||
|
||||
|
||||
diff --git a/tests/unit/switch_core_video.c b/tests/unit/switch_core_video.c
|
||||
index 27c96102929..e395db474d5 100644
|
||||
--- a/tests/unit/switch_core_video.c
|
||||
+++ b/tests/unit/switch_core_video.c
|
||||
@@ -48,6 +48,7 @@ FST_CORE_BEGIN("./conf")
|
||||
}
|
||||
FST_TEARDOWN_END()
|
||||
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
FST_TEST_BEGIN(data_url_test)
|
||||
{
|
||||
char *data_url = NULL;
|
||||
@@ -88,6 +89,7 @@ FST_CORE_BEGIN("./conf")
|
||||
unlink(argb_filename);
|
||||
}
|
||||
FST_TEST_END()
|
||||
+#endif /* SWITCH_HAVE_YUV */
|
||||
|
||||
FST_TEST_BEGIN(img_patch)
|
||||
{
|
||||
@@ -239,6 +241,7 @@ FST_CORE_BEGIN("./conf")
|
||||
}
|
||||
FST_TEST_END()
|
||||
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
FST_TEST_BEGIN(stb_data_url)
|
||||
{
|
||||
switch_image_t *img = switch_img_alloc(NULL, SWITCH_IMG_FMT_I420, 120, 60, 1);
|
||||
@@ -321,6 +324,7 @@ FST_CORE_BEGIN("./conf")
|
||||
unlink(jpg_write_filename);
|
||||
}
|
||||
FST_TEST_END()
|
||||
+#endif /* SWITCH_HAVE_YUV */
|
||||
}
|
||||
FST_SUITE_END()
|
||||
}
|
@ -1,10 +1,9 @@
|
||||
# From https://files.freeswitch.org/freeswitch-releases/freeswitch-1.10.7.-release.tar.xz.sha256
|
||||
sha256 0919bddc2ea9cab2e4944314e71637bea9dd4f40d510722a74ea032104594c41 freeswitch-1.10.7.-release.tar.xz
|
||||
# From https://files.freeswitch.org/freeswitch-releases/freeswitch-1.10.8.-release.tar.xz.sha256
|
||||
sha256 1176b26b2f463de2980e5be953f81ced94d23c784452bd41e086d3933a88be5f freeswitch-1.10.8.-release.tar.xz
|
||||
# Locally computed
|
||||
sha256 75c933202f40939cdc3827fce20a1efdaa38291e2b5a65d234eb16e2cffda66a COPYING
|
||||
sha256 c3e3388768dae8bf4edcc4108f95be815b8a05c0b0aef6e4c3d8df81affdfa34 docs/OPENH264_BINARY_LICENSE.txt
|
||||
sha256 e8e26b16da14aa3e6ed5c22c705fdc1f45d6225fca461ea9f7314bcdfdc414c4 libs/apr/LICENSE
|
||||
sha256 1eefb2ea1db0af7729a9d8a27d7c65d8a37ab185393f935b029aac6828ce315a libs/apr-util/LICENSE
|
||||
sha256 8267348d5af1262c11d1a08de2f5afc77457755f1ac658627dd9acf71011d615 libs/libvpx/LICENSE
|
||||
sha256 2b2cc1180c7e6988328ad2033b04b80117419db9c4c584918bbb3cfec7e9364f libs/libyuv/LICENSE
|
||||
sha256 7d72a8aee2c4b1a084200487992a5d86f5df6b535727a14c1874918e99d24600 libs/libzrtp/src/zrtp_legal.c
|
||||
|
@ -4,20 +4,19 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
FREESWITCH_VERSION = 1.10.7
|
||||
FREESWITCH_VERSION = 1.10.8
|
||||
FREESWITCH_SOURCE = freeswitch-$(FREESWITCH_VERSION).-release.tar.xz
|
||||
FREESWITCH_SITE = https://files.freeswitch.org/freeswitch-releases
|
||||
# External modules need headers/libs from staging
|
||||
FREESWITCH_INSTALL_STAGING = YES
|
||||
FREESWITCH_LICENSE = MPL-1.1, \
|
||||
GPL-3.0+ with font exception (fonts), \
|
||||
Apache-2.0 (apr, apr-util), \
|
||||
Apache-2.0 (apr), \
|
||||
BSD-3-Clause (libsrtp)
|
||||
|
||||
FREESWITCH_LICENSE_FILES = \
|
||||
COPYING \
|
||||
libs/apr/LICENSE \
|
||||
libs/apr-util/LICENSE \
|
||||
libs/srtp/LICENSE
|
||||
|
||||
FREESWITCH_CPE_ID_VENDOR = freeswitch
|
||||
@ -50,6 +49,10 @@ FREESWITCH_CONF_ENV += \
|
||||
ac_cv_prog_PHP_CONFIG=false \
|
||||
ac_cv_have_php_config=no
|
||||
|
||||
# disable pcap detection, pcap is an optional dependency for unit tests
|
||||
FREESWITCH_CONF_ENV += \
|
||||
ac_cv_prog_HAVE_PCAP_CONFIG=false
|
||||
|
||||
# copied from freeswitch/configure.ac, line 258+
|
||||
FREESWITCH_CONF_ENV += \
|
||||
ac_cv_file__dev_ptmx=yes \
|
||||
|
Loading…
Reference in New Issue
Block a user