package/python-pynacl: bump to version 1.5.0

Drop patch that is now upstream.

Drop python2 support.

Drop python-six dependency which is no longer needed.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[yann.morin.1998@free.fr: update paramiko python3 dependency comment]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
James Hilliard 2022-01-24 04:37:49 -07:00 committed by Yann E. MORIN
parent 4ac3ae9446
commit 1ad6b39743
5 changed files with 7 additions and 41 deletions

View File

@ -1,7 +1,7 @@
config BR2_PACKAGE_PYTHON_PARAMIKO
bool "python-paramiko"
depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # python-cryptography
depends on BR2_PACKAGE_PYTHON3 # python-bcrypt, python-cryptography
depends on BR2_PACKAGE_PYTHON3 # python-bcrypt, python-cryptography, python-pynacl
select BR2_PACKAGE_PYTHON_BCRYPT # runtime
select BR2_PACKAGE_PYTHON_CRYPTOGRAPHY # runtime
select BR2_PACKAGE_PYTHON_PYNACL # runtime

View File

@ -1,34 +0,0 @@
From 44fb453931c611d4822343debe902cca8e1c8afe Mon Sep 17 00:00:00 2001
From: Scott Kitterman <sklist@kitterman.com>
Date: Tue, 26 May 2020 20:08:16 -0400
Subject: [PATCH] Remove spurious requirement for wheel (#596)
* Remove spurious requirement for wheel
* Put wheel back in pyproject.toml
Co-authored-by: Scott Kitterman <scott@kitterman.com>
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[james.hilliard1@gmail.com: backport from upstream commit
44fb453931c611d4822343debe902cca8e1c8afe]
---
setup.py | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/setup.py b/setup.py
index 9319c1c..d82a7fe 100644
--- a/setup.py
+++ b/setup.py
@@ -35,8 +35,7 @@ except ImportError:
requirements = ["six"]
-setup_requirements = ["setuptools",
- "wheel"]
+setup_requirements = ["setuptools"]
test_requirements = ["pytest>=3.2.1,!=3.3.0",
"hypothesis>=3.27.0"]
docs_requirements = ["sphinx>=1.6.5",
--
2.25.1

View File

@ -1,7 +1,7 @@
config BR2_PACKAGE_PYTHON_PYNACL
bool "python-pynacl"
depends on BR2_PACKAGE_PYTHON3
select BR2_PACKAGE_LIBSODIUM
select BR2_PACKAGE_PYTHON_SIX # runtime
select BR2_PACKAGE_PYTHON_CFFI # runtime
help
Python binding to the Networking and Cryptography (NaCl)

View File

@ -1,5 +1,5 @@
# md5, sha256 from https://pypi.org/pypi/pynacl/json
md5 8c6c57893327a694c72510fb620e4744 PyNaCl-1.4.0.tar.gz
sha256 54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505 PyNaCl-1.4.0.tar.gz
# md5, sha256 from https://pypi.org/pypi/PyNaCl/json
md5 93989045e25f1111452cfdf5e021814d PyNaCl-1.5.0.tar.gz
sha256 8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba PyNaCl-1.5.0.tar.gz
# Locally computed sha256 checksums
sha256 d3174ad63e721d4c9dccb8ad4320848992d314369bc46319720b5802c9153fe9 LICENSE

View File

@ -4,9 +4,9 @@
#
################################################################################
PYTHON_PYNACL_VERSION = 1.4.0
PYTHON_PYNACL_VERSION = 1.5.0
PYTHON_PYNACL_SOURCE = PyNaCl-$(PYTHON_PYNACL_VERSION).tar.gz
PYTHON_PYNACL_SITE = https://files.pythonhosted.org/packages/cf/5a/25aeb636baeceab15c8e57e66b8aa930c011ec1c035f284170cacb05025e
PYTHON_PYNACL_SITE = https://files.pythonhosted.org/packages/a7/22/27582568be639dfe22ddb3902225f91f2f17ceff88ce80e4db396c8986da
PYTHON_PYNACL_LICENSE = Apache-2.0
PYTHON_PYNACL_LICENSE_FILES = LICENSE
PYTHON_PYNACL_SETUP_TYPE = setuptools