package/htpdate: fix static openssl build
Fix the following static build failure with openssl raised since bump to
version 1.3.3 in commit 163509a8e0
:
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sh4-buildroot-linux-uclibc/10.3.0/../../../../sh4-buildroot-linux-uclibc/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/sh4-buildroot-linux-uclibc/sysroot/usr/lib/libssl.a(rec_layer_d1.o): in function `DTLS_RECORD_LAYER_new':
rec_layer_d1.c:(.text+0x124): undefined reference to `CRYPTO_malloc'
Fixes:
- http://autobuild.buildroot.org/results/75ad8515916dfa056b17c97fdd95c7eb4d83a304
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
61797c52f5
commit
1ad05acb1e
@ -0,0 +1,37 @@
|
||||
From 4ba90fedd553c3b06c925fb6ff5245a5dcabace9 Mon Sep 17 00:00:00 2001
|
||||
From: Eddy Vervest <eddy@vervest.org>
|
||||
Date: Sat, 29 Jan 2022 10:58:13 +0100
|
||||
Subject: [PATCH] Allow SSL_LIBS to be configured from environment
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/twekkel/htpdate/commit/4ba90fedd553c3b06c925fb6ff5245a5dcabace9]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
Makefile | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 4796efa..cf077e6 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -2,8 +2,9 @@ prefix = $(DESTDIR)/usr
|
||||
bindir = ${prefix}/sbin
|
||||
mandir = ${prefix}/share/man
|
||||
|
||||
-CC ?= gcc
|
||||
-CFLAGS += -Wall -std=c11 -pedantic -O2
|
||||
+CC ?= gcc
|
||||
+CFLAGS += -Wall -std=c11 -pedantic -O2
|
||||
+SSL_LIBS ?= -lssl
|
||||
|
||||
INSTALL ?= install -c
|
||||
STRIP ?= strip -s
|
||||
@@ -14,7 +15,7 @@ htpdate: htpdate.c
|
||||
$(CC) $(CFLAGS) -o htpdate htpdate.c
|
||||
|
||||
https: htpdate.c
|
||||
- $(CC) $(CFLAGS) -DENABLE_HTTPS -o htpdate htpdate.c -lssl
|
||||
+ $(CC) $(CFLAGS) -DENABLE_HTTPS -o htpdate htpdate.c $(SSL_LIBS)
|
||||
|
||||
install: all
|
||||
$(STRIP) htpdate
|
@ -10,7 +10,9 @@ HTPDATE_LICENSE = GPL-2.0+
|
||||
HTPDATE_LICENSE_FILES = LICENSE
|
||||
|
||||
ifeq ($(BR2_PACKAGE_OPENSSL),y)
|
||||
HTPDATE_BUILD_OPTS = https
|
||||
HTPDATE_BUILD_OPTS = \
|
||||
https \
|
||||
SSL_LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs openssl`"
|
||||
HTPDATE_DEPENDENCIES += openssl host-pkgconf
|
||||
endif
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user