package/sg3_utils: bump to version 1.48

- Drop patches (already in version) and so drop autoreconf
- Update hash of BSD_LICENSE (update in year:
  551657bfbf)

https://github.com/hreinecke/sg3_utils/blob/v1.48/ChangeLog

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2023-09-24 22:08:45 +02:00 committed by Peter Korsgaard
parent c7cd67517c
commit 197d0a4cb2
5 changed files with 3 additions and 82 deletions

View File

@ -1304,8 +1304,6 @@ package/ser2net/S50ser2net Indent Shellcheck Variables
package/setools/0001-Do-not-export-use-setools.InfoFlowAnalysis-and-setoo.patch Upstream
package/setserial/0001-build-system-fix.patch Upstream
package/setserial/0002-tiocghayesesp-build-fix.patch Upstream
package/sg3_utils/0001-src-sg_dd.c-fix-musl-build.patch Upstream
package/sg3_utils/0002-configure.ac-fix-uclibc-ng-build.patch Upstream
package/shadowsocks-libev/0001-configure.ac-use-pkg-config-to-find-netfilter_conntr.patch Upstream
package/shadowsocks-libev/0002-fix-maybe-uninitialized-errors.patch Upstream
package/shadowsocks-libev/0003-lib-Makefile.am-remove-static-from-LDFLAGS.patch Upstream

View File

@ -1,39 +0,0 @@
From c93ad13ecd8ddfbb8bb3e4d5d5ad7f3f2c633db6 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 14 Nov 2021 12:37:16 +0100
Subject: [PATCH] src/sg_dd.c: fix musl build
Fix the following build failure on musl raised since version 1.47 and
https://github.com/doug-gilbert/sg3_utils/commit/f0195003bb0c66ba55084b2f7e0fe982f08c5675:
sg_dd.c: In function 'main':
sg_dd.c:2402:17: error: unknown type name 'uint'; did you mean 'int'?
2402 | uint off;
| ^~~~
| int
Fixes:
- http://autobuild.buildroot.org/results/9ead59ffefefe2a4e3b94a153b3d23231736d882
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/doug-gilbert/sg3_utils/pull/7]
---
src/sg_dd.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/sg_dd.c b/src/sg_dd.c
index 9d05c93..35e2423 100644
--- a/src/sg_dd.c
+++ b/src/sg_dd.c
@@ -2399,7 +2399,7 @@ main(int argc, char * argv[])
res = blocks * blk_sz;
if (iflag.zero && iflag.ff && (blk_sz >= 4)) {
uint32_t pos = (uint32_t)skip;
- uint off;
+ uint32_t off;
for (k = 0, off = 0; k < blocks; ++k, off += blk_sz, ++pos) {
for (j = 0; j < (blk_sz - 3); j += 4)
--
2.33.0

View File

@ -1,36 +0,0 @@
From 1e95d5b8c507a49f6d15d2795dc46d82b4d1ded0 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Tue, 16 Nov 2021 08:41:48 +0100
Subject: [PATCH] configure.ac: fix uclibc-ng build
Fix the following build failure with uclibc-ng raised because SG_IO is
not defined:
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/arm-buildroot-uclinux-uclibcgnueabi/bin/ld.real: sg_dd.o: in function `sg_read_low.constprop.0':
sg_dd.c:(.text+0xc6c): undefined reference to `sg_chk_n_print3'
Fixes:
- http://autobuild.buildroot.org/results/38a0dfc70a21ce574368b7a485deb231f778b3e7
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/doug-gilbert/sg3_utils/pull/8]
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 0a65d94..23378ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,7 @@ case "${host}" in
AC_DEFINE_UNQUOTED(HAVE_NVME, 1, [Found NVMe])
check_for_getrandom
CFLAGS="$CFLAGS -D__USE_MINGW_ANSI_STDIO";;
- *-*-linux-gnu* | *-*-linux*)
+ *-*-linux-gnu* | *-*-linux* | *-*-uclinux-gnu* | *-*-uclinux*)
AC_DEFINE_UNQUOTED(SG_LIB_LINUX, 1, [sg3_utils on linux])
check_for_linux_sg_v4_hdr
check_for_getrandom
--
2.33.0

View File

@ -1,6 +1,6 @@
# Locally calculated from download (no sig, hash)
sha256 ddb0cab85fedd8b0db020f3e3f02f6967a055616bf16ea9d5c7408cde41472b2 sg3_utils-1.47.tar.xz
sha256 d6b9a41690d540e58d1e99c26ac8db37336c849ef6a03f96ea48ca2fe334dbfa sg3_utils-1.48.tar.xz
# Hash for license files
sha256 d212debdb0a5d7754c977f6dc53bb6c88b4ace7ab784ddbccd06bb970adb1a37 COPYING
sha256 8ddd1d82f2be2f5cbd5b5c3b5c2ee94a90d2ca7112958448da74dd78384fd96a BSD_LICENSE
sha256 6b1a1de0b3394002973daaa407b93a1d2c13efd8dd1a32095d6872c36f09ba66 BSD_LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
SG3_UTILS_VERSION = 1.47
SG3_UTILS_VERSION = 1.48
SG3_UTILS_SOURCE = sg3_utils-$(SG3_UTILS_VERSION).tar.xz
SG3_UTILS_SITE = http://sg.danny.cz/sg/p
SG3_UTILS_LICENSE = BSD-2-Clause (library)
@ -13,8 +13,6 @@ ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),y)
SG3_UTILS_LICENSE += , GPL-2.0+ (programs), BSD-2-Clause (programs)
endif
SG3_UTILS_LICENSE_FILES = COPYING BSD_LICENSE
# We're patching configure.ac
SG3_UTILS_AUTORECONF = YES
# install the libsgutils2 library
SG3_UTILS_INSTALL_STAGING = YES