linux-pam: bump to version 1.1.7
And fix build breakage with newer automake versions (mkdir_p deprecation). Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
32b869c324
commit
17e761efc4
17
package/linux-pam/linux-pam-04-mkdir.patch
Normal file
17
package/linux-pam/linux-pam-04-mkdir.patch
Normal file
@ -0,0 +1,17 @@
|
||||
$(mkdir_p) is obsolete for newer automake, use $(MKDIR_P) instead.
|
||||
Upstream should really gettextize with a newer version before packing up.
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
|
||||
diff -Nura Linux-PAM-1.1.7.orig/po/Makefile.in.in Linux-PAM-1.1.7/po/Makefile.in.in
|
||||
--- Linux-PAM-1.1.7.orig/po/Makefile.in.in 2013-09-11 20:45:16.610770002 -0300
|
||||
+++ Linux-PAM-1.1.7/po/Makefile.in.in 2013-09-11 20:45:28.030145316 -0300
|
||||
@@ -31,7 +31,7 @@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
mkinstalldirs = $(SHELL) @install_sh@ -d
|
||||
-mkdir_p = @mkdir_p@
|
||||
+mkdir_p = @MKDIR_P@
|
||||
|
||||
GMSGFMT_ = @GMSGFMT@
|
||||
GMSGFMT_no = @GMSGFMT@
|
@ -1,37 +0,0 @@
|
||||
From: "Dmitry V. Levin" <ldv@altlinux.org>
|
||||
Date: Wed, 10 Oct 2012 18:13:07 +0000
|
||||
Subject: [PATCH] pam_unix: fix build in --enable-selinux mode
|
||||
|
||||
glibc's <sys/wait.h> starting with commit
|
||||
http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=glibc-2.15-231-gd94a467
|
||||
does not include <sys/resource.h> for POSIX 2008 conformance reasons, so
|
||||
when pam is being built with SELinux support enabled, pam_unix_passwd.c
|
||||
uses getrlimit(2) and therefore should include <sys/resource.h> without
|
||||
relying on other headers.
|
||||
|
||||
* modules/pam_unix/pam_unix_passwd.c: Include <sys/resource.h>.
|
||||
|
||||
Reported-by: Guido Trentalancia <guido@trentalancia.com>
|
||||
Reported-by: "Jory A. Pratt" <anarchy@gentoo.org>
|
||||
Reported-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
|
||||
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
|
||||
[This patch is in linux-pam 1.1.6]
|
||||
---
|
||||
modules/pam_unix/pam_unix_passwd.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules/pam_unix/pam_unix_passwd.c b/modules/pam_unix/pam_unix_passwd.c
|
||||
index 9e1302d..94bc3ec 100644
|
||||
--- a/modules/pam_unix/pam_unix_passwd.c
|
||||
+++ b/modules/pam_unix/pam_unix_passwd.c
|
||||
@@ -58,6 +58,7 @@
|
||||
#include <signal.h>
|
||||
#include <errno.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <sys/resource.h>
|
||||
|
||||
#include <security/_pam_macros.h>
|
||||
|
||||
--
|
||||
1.8.2.1
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LINUX_PAM_VERSION = 1.1.6
|
||||
LINUX_PAM_VERSION = 1.1.7
|
||||
LINUX_PAM_SOURCE = Linux-PAM-$(LINUX_PAM_VERSION).tar.bz2
|
||||
LINUX_PAM_SITE = http://linux-pam.org/library/
|
||||
LINUX_PAM_INSTALL_STAGING = YES
|
||||
|
Loading…
Reference in New Issue
Block a user