package/postgis: bump version to 3.3.2

All patches are merged into upstream, so drop them.

https://git.osgeo.org/gitea/postgis/postgis/src/tag/3.3.2/NEWS

Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Maxim Kochetkov 2022-11-13 13:09:14 +03:00 committed by Thomas Petazzoni
parent bc283a7bc8
commit 1718c2ba6a
4 changed files with 2 additions and 68 deletions

View File

@ -1,31 +0,0 @@
From 845c18c1288b7a96592901baadb198f96dd71c46 Mon Sep 17 00:00:00 2001
From: fidomax <adobegitler@gmail.com>
Date: Tue, 26 Jan 2021 09:49:19 +0300
Subject: [PATCH] Disable forced static linking of liblwgeom
In case of shared libs build fails:
ld: cannot find -lgeos_c
ld: attempted static link of dynamic object `/usr/lib/libproj.so'
Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
Fetch from: https://github.com/postgis/postgis/commit/98070faad220e12fcaed9a583a70a37c510b7c6b.patch
---
loader/Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/loader/Makefile.in b/loader/Makefile.in
index 9aebfe07f..9a0c90d3a 100644
--- a/loader/Makefile.in
+++ b/loader/Makefile.in
@@ -44,7 +44,7 @@ ICONV_CFLAGS=@ICONV_CFLAGS@
# liblwgeom
LIBLWGEOM=../liblwgeom/liblwgeom.la
-LDFLAGS += -static $(LIBLWGEOM)
+LDFLAGS += $(LIBLWGEOM)
# GTK includes and libraries
GTK_CFLAGS = @GTK_CFLAGS@ @IGE_MAC_CFLAGS@
--
2.30.0

View File

@ -1,35 +0,0 @@
From 29c33c483e22a4445d870739187d128df0f11f60 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Date: Wed, 27 Jul 2022 15:12:40 +0200
Subject: [PATCH] raster/loader/Makefile.in: do not force static linking
This is similar to commit
https://github.com/postgis/postgis/commit/98070faad220e12fcaed9a583a70a37c510b7c6b,
but applied to raster/loader. It ensures that if only shared variants
of the libraries are available, the link still works. If you force
-static and only shared variants of some of the libraries are
available, the link fails with "d: attempted static link of dynamic
object XYZ".
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Upstream: https://github.com/postgis/postgis/pull/702
---
raster/loader/Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/raster/loader/Makefile.in b/raster/loader/Makefile.in
index 3df47a96f..d0a408333 100644
--- a/raster/loader/Makefile.in
+++ b/raster/loader/Makefile.in
@@ -36,7 +36,7 @@ PGSQL_BINDIR=@PGSQL_BINDIR@
RT_CORE=../rt_core
-LIBLWGEOM_LDFLAGS= -static ../../liblwgeom/liblwgeom.la
+LIBLWGEOM_LDFLAGS= ../../liblwgeom/liblwgeom.la
LIBLWGEOM_CFLAGS=-I../../liblwgeom
LIBGDAL_CFLAGS=@LIBGDAL_CFLAGS@
LIBGDAL_LDFLAGS=@LIBGDAL_LDFLAGS@
--
2.37.1

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 18cf3d013f45b1aa8ed59d78bc707e9e125e250d8f0615396ae9bfe3dd7c3d7c postgis-3.2.2.tar.gz
sha256 9a2a219da005a1730a39d1959a1c7cec619b1efb009b65be80ffc25bad299068 postgis-3.3.2.tar.gz
sha256 55b69f22e1752830dd565852dc7ff242daf289dbd3a6bfede5db43f90d2e28c9 LICENSE.TXT

View File

@ -4,7 +4,7 @@
#
################################################################################
POSTGIS_VERSION = 3.2.2
POSTGIS_VERSION = 3.3.2
POSTGIS_SITE = https://download.osgeo.org/postgis/source
# parallel build issues
POSTGIS_MAKE = $(MAKE1)