sdl: fix directfb configure check
The configure script nicely supports a preconfigured directfb-config (using ac_cv_path_DIRECTFBCONFIG), except for when it checks the directfb version where it simply uses whatever directfb-config is in the path, breaking the build when this isn't available / recent enough. Fix is to use the correct one instead. As SDL doesn't autoreconf cleanly, also patch the generated configure script. Finally move the ac_cv_path_DIRECTFBCONFIG setting under the directfb conditional as it is only needed there. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
37c6e51a15
commit
1655f3c5b7
40
package/sdl/sdl-use-correct-directfb-config.patch
Normal file
40
package/sdl/sdl-use-correct-directfb-config.patch
Normal file
@ -0,0 +1,40 @@
|
||||
[PATCH] configure.in: use correct directfb-config in version check
|
||||
|
||||
The configure script has just checked for the correct directfb-config
|
||||
script, so also use it for the version check instead of whatever
|
||||
might be in the path.
|
||||
|
||||
Also patch the generated configure, as it doesn't cleanly autoreconf.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
configure | 2 +-
|
||||
configure.in | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
Index: SDL-1.2.15/configure.in
|
||||
===================================================================
|
||||
--- SDL-1.2.15.orig/configure.in
|
||||
+++ SDL-1.2.15/configure.in
|
||||
@@ -1276,7 +1276,7 @@
|
||||
else
|
||||
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
|
||||
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
||||
- set -- `directfb-config --version | sed 's/\./ /g'`
|
||||
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
|
||||
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
||||
if test $HAVE_VERSION -ge $NEED_VERSION; then
|
||||
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
|
||||
Index: SDL-1.2.15/configure
|
||||
===================================================================
|
||||
--- SDL-1.2.15.orig/configure
|
||||
+++ SDL-1.2.15/configure
|
||||
@@ -24958,7 +24958,7 @@
|
||||
else
|
||||
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
|
||||
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
||||
- set -- `directfb-config --version | sed 's/\./ /g'`
|
||||
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
|
||||
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
||||
if test $HAVE_VERSION -ge $NEED_VERSION; then
|
||||
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
|
@ -8,7 +8,6 @@ SDL_VERSION = 1.2.15
|
||||
SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
|
||||
SDL_SITE = http://www.libsdl.org/release
|
||||
SDL_INSTALL_STAGING = YES
|
||||
SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
|
||||
|
||||
ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
|
||||
SDL_CONF_OPT+=--enable-video-fbcon=yes
|
||||
@ -19,6 +18,7 @@ endif
|
||||
ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
|
||||
SDL_DEPENDENCIES += directfb
|
||||
SDL_CONF_OPT+=--enable-video-directfb=yes
|
||||
SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
|
||||
else
|
||||
SDL_CONF_OPT=--enable-video-directfb=no
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user