package/libpam-tacplus: bump to version 1.7.0

- Use official tarball
- Drop patch (already in version)
- Add patch to fix build failure
- The site that was used, https://github.com/jeroennijhof/pam_tacplus,
  now redirects to https://github.com/kravietz/pam_tacplus, so used
  this new site

https://github.com/kravietz/pam_tacplus/blob/v1.7.0/ChangeLog

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2023-10-01 17:38:01 +02:00 committed by Thomas Petazzoni
parent de377bd313
commit 160f0e4b5f
6 changed files with 29 additions and 62 deletions

View File

@ -720,7 +720,6 @@ package/liboping/0003-Fix-compile-break-with-GCC-7-buffer-overflow-with-snprintf
package/liboping/0004-Fix-compile-error-on-GCC-7.patch Upstream
package/liboping/0005-src-oping.c-always-use-s-style-format-for-printf-sty.patch Upstream
package/libp11/0001-src-p11_attr.c-fix-build-with-gcc-4.8.patch Upstream
package/libpam-tacplus/0001-Add-an-option-to-disable-Werror.patch Upstream
package/libplatform/0001-cmake-require-c-11-as-the-minimum-standard.patch Upstream
package/libpng/0001-Disable-pngfix-and-png-fix-itxt.patch Upstream
package/libpthsem/0001-fix-build-on-linux-3.x-host.patch Upstream

View File

@ -1,55 +0,0 @@
From 88c78901503d50d0a62d85c96994ca4d67ab61e0 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Fri, 13 Nov 2020 20:50:27 +0100
Subject: [PATCH] Add an option to disable -Werror
Allow the user to disable -Werror to avoid the following build failure
with gcc 4.8:
libtac/lib/magic.c:138:13: error: ignoring return value of 'read', declared with attribute warn_unused_result [-Werror=unused-result]
(void) read(rfd, &seed, sizeof(seed));
^
Fixes:
- http://autobuild.buildroot.org/results/5c17226f12eba104d907693ec37fc101cc6d447f
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Makefile.am | 6 +++++-
configure.ac | 3 +++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 0be3cdb..4a137e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,11 @@
ACLOCAL_AMFLAGS = -I config
AUTOMAKE_OPTIONS = subdir-objects
-AM_CFLAGS = -Wall -Wextra -Werror
+AM_CFLAGS = -Wall -Wextra
+
+if ENABLE_WERROR
+AM_CFLAGS += -Werror
+endif
if TACC
bin_PROGRAMS = tacc
diff --git a/configure.ac b/configure.ac
index d0c5eba..dd8a966 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,9 @@ AC_SUBST(pamdir)
AC_ARG_ENABLE(doc, AS_HELP_STRING([--disable-doc], [do not build docs]))
AM_CONDITIONAL(DOC, test "x$enable_doc" != "xno")
+AC_ARG_ENABLE(werror, AS_HELP_STRING([--disable-werror], [do not build with -Werror]))
+AM_CONDITIONAL(ENABLE_WERROR, test "x$enable_werror" != "xno")
+
dnl --------------------------------------------------------------------
dnl Switch for run-time debugging
AC_ARG_ENABLE(runtime-debugging, [AS_HELP_STRING([--enable-runtime-debugging],
--
2.28.0

View File

@ -0,0 +1,23 @@
From 104044848ffb0a283e1f1bf3466693fa4af450e9 Mon Sep 17 00:00:00 2001
From: Pawel Krawczyk <p+github@krvtz.net>
Date: Mon, 7 Nov 2022 22:10:52 +0000
Subject: [PATCH] Remove conflicting man flag
Upstream: https://github.com/kravietz/pam_tacplus/commit/104044848ffb0a283e1f1bf3466693fa4af450e9
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Makefile.am | 1 -
1 file changed, 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index a481d7a..ef2b92b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,6 @@ bin_PROGRAMS = tacc
tacc_SOURCES = tacc.c
tacc_LDADD = libtac.la $(LTLIBINTL) $(LIB_CRYPTO) $(LIB_GETRANDOM)
tacc_CFLAGS = $(AM_CFLAGS) -I $(top_srcdir)/libtac/include @rt_debug_defines@ -I $(top_srcdir)/lib
-dist_man_MANS = tacc.1
man1_MANS = tacc.1
lib_LTLIBRARIES = libtac.la

View File

@ -6,4 +6,4 @@ config BR2_PACKAGE_LIBPAM_TACPLUS
management) and accounting (session management)performed
using TACACS+ protocol designed by Cisco.
https://github.com/jeroennijhof/pam_tacplus
https://github.com/kravietz/pam_tacplus

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 73961800dc0d5e422751ad4c9f09b1863ab33e381e0bdb2a1d0343dcfc30e44e libpam-tacplus-1.6.1.tar.gz
sha256 cf00e27b687c1fafe4b2cf35e648116e99e9c9832718a0d3b479bcf43370adf4 pam_tacplus-1.7.0.tar.gz
sha256 b2b961f07e97c4fb78074276da304ea36b85dc299aae5efb79080cedaea3d5ac COPYING

View File

@ -4,8 +4,9 @@
#
################################################################################
LIBPAM_TACPLUS_VERSION = 1.6.1
LIBPAM_TACPLUS_SITE = $(call github,jeroennijhof,pam_tacplus,v$(LIBPAM_TACPLUS_VERSION))
LIBPAM_TACPLUS_VERSION = 1.7.0
LIBPAM_TACPLUS_SOURCE = pam_tacplus-$(LIBPAM_TACPLUS_VERSION).tar.gz
LIBPAM_TACPLUS_SITE = https://github.com/kravietz/pam_tacplus/releases/download/v$(LIBPAM_TACPLUS_VERSION)
LIBPAM_TACPLUS_LICENSE = GPL-2.0+
LIBPAM_TACPLUS_LICENSE_FILES = COPYING
LIBPAM_TACPLUS_CPE_ID_VENDOR = pam_tacplus_project
@ -13,8 +14,7 @@ LIBPAM_TACPLUS_CPE_ID_PRODUCT = pam_tacplus
LIBPAM_TACPLUS_DEPENDENCIES = \
linux-pam \
$(if $(BR2_PACKAGE_OPENSSL),openssl)
# Fetching from github, we need to generate the configure script
# 0001-Add-an-option-to-disable-Werror.patch
# We're patching Makefile.am
LIBPAM_TACPLUS_AUTORECONF = YES
LIBPAM_TACPLUS_INSTALL_STAGING = YES
LIBPAM_TACPLUS_CONF_ENV = \