libtirpc: fix compilation error of rpcgen
When compiling libtirpc, without RPC support available on the host machine, the build of the rpcgen host program because it cannot find the netconfig.h and rpc/types.h headers. Instead of relying on the system-provided ones, let's use the ones included in the libtirpc source code by patching the rpcgen build logic. Signed-off-by: Dagg Stompler <daggs@gmx.com> [Thomas: reword commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
ee8309e287
commit
1521836c4e
@ -83,7 +83,7 @@ index 0000000..2277b6f
|
||||
--- /dev/null
|
||||
+++ b/rpcgen/Makefile.am
|
||||
@@ -0,0 +1,22 @@
|
||||
+COMPILE = $(CC_FOR_BUILD) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
+COMPILE = $(CC_FOR_BUILD) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) -I../tirpc $(AM_CPPFLAGS) \
|
||||
+ $(CPPFLAGS_FOR_BUILD) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD)
|
||||
+LINK = $(CC_FOR_BUILD) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD) $(AM_LDFLAGS) $(LDFLAGS_FOR_BUILD) -o $@
|
||||
+
|
||||
|
Loading…
Reference in New Issue
Block a user