package/ngrep: fix build with libnet
Use pkg-config to find libnet and avoid the following build failure
raised since commit 100ba8351c
if
libnet-config is found on the host:
/home/autobuild/autobuild/instance-4/output-1/host/bin/mips64el-buildroot-linux-gnu-gcc -s -o ngrep ngrep.o tcpkill.o -lpcap -lnet -lpcre -L/usr/lib -lnet
mips64el-buildroot-linux-gnu-gcc: ERROR: unsafe header/library path used in cross-compilation: '-L/usr/lib'
While at it, format Upstream tag of other patches
Fixes:
- http://autobuild.buildroot.org/results/05c916162b9c1027cf53f1699a1f5653151098ed
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
fb6163cf96
commit
14c0c37eaf
@ -897,9 +897,6 @@ package/nginx/0008-src-os-unix-ngx_linux_config.h-only-include-dlfcn.h-.patch Up
|
|||||||
package/nginx/0009-auto-os-linux-fix-build-with-libxcrypt.patch Upstream
|
package/nginx/0009-auto-os-linux-fix-build-with-libxcrypt.patch Upstream
|
||||||
package/nginx/0010-Allow-forcing-of-endianness-for-cross-compilation.patch Upstream
|
package/nginx/0010-Allow-forcing-of-endianness-for-cross-compilation.patch Upstream
|
||||||
package/nginx/S50nginx Indent Variables
|
package/nginx/S50nginx Indent Variables
|
||||||
package/ngrep/0001-Fix-typo-in-configure-in-when-testing-for-use_pcre.patch Upstream
|
|
||||||
package/ngrep/0002-Check-for-libnet_init-in-configure-in.patch Upstream
|
|
||||||
package/ngrep/0003-fix-disable-tcpkill.patch Upstream
|
|
||||||
package/nilfs-utils/0001-nilfs_cleanerd-link-dynamically.patch Upstream
|
package/nilfs-utils/0001-nilfs_cleanerd-link-dynamically.patch Upstream
|
||||||
package/nmap/0001-libdnet-wrapper-configure.patch Upstream
|
package/nmap/0001-libdnet-wrapper-configure.patch Upstream
|
||||||
package/nodejs/nodejs-src/0001-add-qemu-wrapper-support.patch Upstream
|
package/nodejs/nodejs-src/0001-add-qemu-wrapper-support.patch Upstream
|
||||||
|
@ -4,8 +4,7 @@ Date: Mon, 1 Jan 2018 18:00:34 +0100
|
|||||||
Subject: [PATCH] Fix typo in configure.in when testing for use_pcre
|
Subject: [PATCH] Fix typo in configure.in when testing for use_pcre
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
[Retrieved from:
|
Upstream: https://github.com/jpr5/ngrep/commit/b8b1e9751e1d074af0dd77c2554c1b25fd8f7abe
|
||||||
https://github.com/jpr5/ngrep/commit/b8b1e9751e1d074af0dd77c2554c1b25fd8f7abe]
|
|
||||||
---
|
---
|
||||||
configure.in | 2 +-
|
configure.in | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
@ -7,8 +7,7 @@ libnet_init_packet was the old libnet 1.0 function which is now long
|
|||||||
deprecated.
|
deprecated.
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
[Retrieved from:
|
Upstream: https://github.com/jpr5/ngrep/commit/0a51c8bc62c7b49b8d67a360daa6b1957256f4f5
|
||||||
https://github.com/jpr5/ngrep/commit/0a51c8bc62c7b49b8d67a360daa6b1957256f4f5]
|
|
||||||
---
|
---
|
||||||
configure.in | 2 +-
|
configure.in | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
@ -9,7 +9,7 @@ found on the system.
|
|||||||
To fix this, move AC_CHECK_LIB to found libnet outside AC_ARG_ENABLE
|
To fix this, move AC_CHECK_LIB to found libnet outside AC_ARG_ENABLE
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
[Upstream status: https://github.com/jpr5/ngrep/pull/15]
|
Upstream: https://github.com/jpr5/ngrep/pull/15
|
||||||
---
|
---
|
||||||
configure.in | 6 ++----
|
configure.in | 6 ++----
|
||||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||||
|
@ -0,0 +1,38 @@
|
|||||||
|
From 4788988827bf4c0d996d3e1e3b6ac52a23b97941 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
|
Date: Tue, 9 Jan 2024 21:15:47 +0100
|
||||||
|
Subject: [PATCH] configure.in: use pkg-config to find libnet
|
||||||
|
|
||||||
|
libnet-config is deprecated:
|
||||||
|
https://github.com/libnet/libnet/commit/1ec4a6e7d1d23811f0a14ecb51e46489a0175727
|
||||||
|
|
||||||
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
|
Upstream: unsent (upstream seems dead, no commit since 5 years
|
||||||
|
---
|
||||||
|
configure.in | 6 ++++--
|
||||||
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
index 7c3dd43..882ff86 100644
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -176,12 +176,14 @@ AC_ARG_ENABLE(tcpkill,
|
||||||
|
[ use_tcpkill="$enableval" ],
|
||||||
|
[ use_tcpkill="no" ])
|
||||||
|
|
||||||
|
+PKG_PROG_PKG_CONFIG
|
||||||
|
if test $use_tcpkill = yes; then
|
||||||
|
AC_CHECK_LIB(net, libnet_init,,echo !!! error: tcpkill feature enabled but no libnet found; exit)
|
||||||
|
USE_TCPKILL="1"
|
||||||
|
EXTRA_OBJS="$EXTRA_OBJS tcpkill.o"
|
||||||
|
- EXTRA_DEFINES="$EXTRA_DEFINES $(libnet-config --defines)"
|
||||||
|
- EXTRA_LIBS="$EXTRA_LIBS $(libnet-config --libs)"
|
||||||
|
+ PKG_CHECK_MODULES(LIBNET, libnet)
|
||||||
|
+ EXTRA_DEFINES="$EXTRA_DEFINES $LIBNET_CFLAGS"
|
||||||
|
+ EXTRA_LIBS="$EXTRA_LIBS $LIBNET_LIBS"
|
||||||
|
else
|
||||||
|
USE_TCPKILL="0"
|
||||||
|
fi
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -22,7 +22,7 @@ NGREP_CONF_OPTS = \
|
|||||||
--disable-dropprivs \
|
--disable-dropprivs \
|
||||||
--disable-pcap-restart
|
--disable-pcap-restart
|
||||||
|
|
||||||
NGREP_DEPENDENCIES = libpcap pcre
|
NGREP_DEPENDENCIES = host-pkgconf libpcap pcre
|
||||||
|
|
||||||
ifeq ($(BR2_PACKAGE_LIBNET),y)
|
ifeq ($(BR2_PACKAGE_LIBNET),y)
|
||||||
NGREP_DEPENDENCIES += libnet
|
NGREP_DEPENDENCIES += libnet
|
||||||
|
Loading…
Reference in New Issue
Block a user