Add a parallel compilation fix for fontconfig

This patch adds a patch to fix bug
https://bugs.freedesktop.org/show_bug.cgi?id=16464 affecting parallel
compilation of fontconfig.

The patch is the one proposed in the bugzilla entry, available at
https://bugs.freedesktop.org/attachment.cgi?id=17294.

Without this patch, the compilation (at BR2_JLEVEL > 1) of fontconfig
sometimes fails with:

In file included from fc-case.c:25:
../src/fcint.h:118:21: error: fcalias.h: No such file or directory

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2008-11-11 19:38:10 +00:00
parent b741302a01
commit 14520e6fa3
2 changed files with 27 additions and 1 deletions

View File

@ -0,0 +1,26 @@
---
fc-case/Makefile.am | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Index: fontconfig-2.6.0/fc-case/Makefile.am
===================================================================
--- fontconfig-2.6.0.orig/fc-case/Makefile.am
+++ fontconfig-2.6.0/fc-case/Makefile.am
@@ -36,6 +36,8 @@
noinst_MANS=fc-case.man
+noinst_HEADERS=$(TARG)
+
fc_case_SRCS= \
fc-case.c \
fccaseint.h \
@@ -52,7 +54,7 @@
ALIAS_FILES = fcalias.h fcaliastail.h
-BUILT_SOURCES = $(ALIAS_FILES) $(TARG)
+BUILT_SOURCES = $(ALIAS_FILES)
$(ALIAS_FILES):
touch $(ALIAS_FILES)

View File

@ -6,7 +6,7 @@
FONTCONFIG_VERSION = 2.6.0
FONTCONFIG_SOURCE = fontconfig-$(FONTCONFIG_VERSION).tar.gz
FONTCONFIG_SITE = http://fontconfig.org/release
FONTCONFIG_AUTORECONF = NO
FONTCONFIG_AUTORECONF = YES
FONTCONFIG_INSTALL_STAGING = YES
FONTCONFIG_INSTALL_TARGET = YES