doxygen: bump version to 1.8.14

Patches are now upstream - remove both.

Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Bartosz Golaszewski 2018-11-17 15:25:12 +01:00 committed by Peter Korsgaard
parent b2b7c9aa86
commit 14142b3d0c
4 changed files with 2 additions and 90 deletions

View File

@ -1,30 +0,0 @@
From 0f02761a158a5e9ddbd5801682482af8986dbc35 Mon Sep 17 00:00:00 2001
From: albert-github <albert.tests@gmail.com>
Date: Wed, 4 Jan 2017 12:24:55 +0100
Subject: [PATCH] Bug 776791 - [1.8.13 Regression] Segfault building the
breathe docs
Protected against NULL pointer of variable al
[Romain: backport from upstream]
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
src/xmlgen.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/xmlgen.cpp b/src/xmlgen.cpp
index fe95c7a..70e198a 100644
--- a/src/xmlgen.cpp
+++ b/src/xmlgen.cpp
@@ -620,7 +620,7 @@ static void generateXMLForMember(MemberDef *md,FTextStream &ti,FTextStream &t,De
if (md->isInline()) t << "yes"; else t << "no";
t << "\"";
- if (al->refQualifier!=RefQualifierNone)
+ if (al!=0 && al->refQualifier!=RefQualifierNone)
{
t << " refqual=\"";
if (al->refQualifier==RefQualifierLValue) t << "lvalue"; else t << "rvalue";
--
2.9.4

View File

@ -1,58 +0,0 @@
From f9a3aa72c2bf15726bcdafd140fd21f790de555d Mon Sep 17 00:00:00 2001
From: Bartosz Golaszewski <brgl@bgdev.pl>
Date: Wed, 21 Jun 2017 14:32:25 +0200
Subject: [PATCH] build: fix the way lang_cfg.h is generated
This header is generated by running cmake/lang_cfg.cmake and
redirecting its stderr. If any warning is emitted by this script, it
ends up in the generated header and breaks the build.
To avoid such problems: pass the path to the header as an argument to
the cmake script and use the cmake 'file' command instead of 'message'.
We can't even use message(STATUS...) as - although it prints to stdout
as opposed to other types of messages - it prepends all output with
a double hyphen.
Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
cmake/lang_cfg.cmake | 10 +++++-----
src/CMakeLists.txt | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/cmake/lang_cfg.cmake b/cmake/lang_cfg.cmake
index c57d3ed..86c2d9a 100644
--- a/cmake/lang_cfg.cmake
+++ b/cmake/lang_cfg.cmake
@@ -1,10 +1,10 @@
-if(${CMAKE_ARGC} GREATER 1)
- if ("${CMAKE_ARGV3}" STREQUAL "ENONLY")
- message("#define ENGLISH_ONLY")
+if(${CMAKE_ARGC} GREATER 2)
+ if ("${CMAKE_ARGV4}" STREQUAL "ENONLY")
+ file(APPEND ${CMAKE_ARGV3} " #define ENGLISH_ONLY")
else()
math(EXPR UPTO ${CMAKE_ARGC}-1)
- foreach(i RANGE 3 ${UPTO})
- message("#define LANG_${CMAKE_ARGV${i}}")
+ foreach(i RANGE 4 ${UPTO})
+ file(APPEND ${CMAKE_ARGV3} " #define LANG_${CMAKE_ARGV${i}}")
endforeach()
endif()
endif()
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 08c8439..dcf4ef8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -73,7 +73,7 @@ set_source_files_properties(${GENERATED_SRC}/ce_parse.h PROPERTIES GENERATED 1)
# lang_cfg.h
add_custom_command(
COMMENT "Generating ${GENERATED_SRC}/lang_cfg.h"
- COMMAND ${CMAKE_COMMAND} -P ${CMAKE_SOURCE_DIR}/cmake/lang_cfg.cmake ${LANG_CODES} 2> ${GENERATED_SRC}/lang_cfg.h
+ COMMAND ${CMAKE_COMMAND} -P ${CMAKE_SOURCE_DIR}/cmake/lang_cfg.cmake ${GENERATED_SRC}/lang_cfg.h ${LANG_CODES}
DEPENDS ${LANGUAGE_FILES}
OUTPUT ${GENERATED_SRC}/lang_cfg.h
)
--
2.9.3

View File

@ -1,2 +1,2 @@
# Computed locally
sha256 af667887bd7a87dc0dbf9ac8d86c96b552dfb8ca9c790ed1cbffaa6131573f6b doxygen-1.8.13.src.tar.gz
sha256 d1757e02755ef6f56fd45f1f4398598b920381948d6fcfa58f5ca6aa56f59d4d doxygen-1.8.14.src.tar.gz

View File

@ -4,7 +4,7 @@
#
################################################################################
DOXYGEN_VERSION = 1.8.13
DOXYGEN_VERSION = 1.8.14
DOXYGEN_SOURCE = doxygen-$(DOXYGEN_VERSION).src.tar.gz
DOXYGEN_SITE = http://ftp.stack.nl/pub/users/dimitri
DOXYGEN_LICENSE = GPL-2.0