package/faketime: bump to version 0.9.8
- Remove first patch (already in version) - Remove second patch (not needed since merge of https://github.com/wolfcw/libfaketime/pull/161) - Add hash for license file Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
ec29cbd2dd
commit
14044441f0
@ -1,32 +0,0 @@
|
||||
From e85a157b51b1276c91c736d8624d9f3e876e9189 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Rammhold <andreas@rammhold.de>
|
||||
Date: Tue, 20 Dec 2016 19:25:32 +0100
|
||||
Subject: [PATCH] Disable the non-null compare warning/error.
|
||||
|
||||
We rely on the provided local library definitions for the hooked
|
||||
functions which in some cases (GCC >6) carry a non-null-attribute flag
|
||||
which causes compile errors on `!= NULL` checks.
|
||||
|
||||
[Romain: rebase on 0.9.6]
|
||||
(cherry picked from commit 47e958b753fc15098a2b7d0e9ef26b83ee255874)
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
src/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index 51634b0..bbbd476 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -67,7 +67,7 @@ INSTALL ?= install
|
||||
PREFIX ?= /usr/local
|
||||
LIBDIRNAME ?= /lib/faketime
|
||||
|
||||
-CFLAGS += -std=gnu99 -Wall -Wextra -Werror -DFAKE_STAT -DFAKE_SLEEP -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS -fPIC -DPREFIX='"'$(PREFIX)'"' -DLIBDIRNAME='"'$(LIBDIRNAME)'"'
|
||||
+CFLAGS += -std=gnu99 -Wall -Wextra -Werror -Wno-nonnull-compare -DFAKE_STAT -DFAKE_SLEEP -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS -fPIC -DPREFIX='"'$(PREFIX)'"' -DLIBDIRNAME='"'$(LIBDIRNAME)'"'
|
||||
LIB_LDFLAGS += -shared
|
||||
LDFLAGS += -Wl,--version-script=libfaketime.map -lpthread
|
||||
LDADD += -ldl -lm -lrt
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,32 +0,0 @@
|
||||
From bcde6e6f34c3cf78a254315c5caa530db91802fb Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Date: Thu, 17 May 2018 23:41:03 +0200
|
||||
Subject: [PATCH] src/Makefile: disable -Werror
|
||||
|
||||
gcc 8.x has enabled additional warnings that break the build due to
|
||||
-Werror, so let's drop -Werror for now. A set of patches has been
|
||||
submitted upstream (https://github.com/wolfcw/libfaketime/pull/161) to
|
||||
properly fix the gcc 8.x issues, but in the mean time, disabling
|
||||
-Werror is a simpler option.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
---
|
||||
src/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index bbbd476..6b0d2cd 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -67,7 +67,7 @@ INSTALL ?= install
|
||||
PREFIX ?= /usr/local
|
||||
LIBDIRNAME ?= /lib/faketime
|
||||
|
||||
-CFLAGS += -std=gnu99 -Wall -Wextra -Werror -Wno-nonnull-compare -DFAKE_STAT -DFAKE_SLEEP -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS -fPIC -DPREFIX='"'$(PREFIX)'"' -DLIBDIRNAME='"'$(LIBDIRNAME)'"'
|
||||
+CFLAGS += -std=gnu99 -Wall -Wextra -Wno-nonnull-compare -DFAKE_STAT -DFAKE_SLEEP -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS -fPIC -DPREFIX='"'$(PREFIX)'"' -DLIBDIRNAME='"'$(LIBDIRNAME)'"'
|
||||
LIB_LDFLAGS += -shared
|
||||
LDFLAGS += -Wl,--version-script=libfaketime.map -lpthread
|
||||
LDADD += -ldl -lm -lrt
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,2 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 56bc32006f4c5b021ff648cc1fd458c5316f40aadfd2031879229a234189b031 faketime-0.9.6.tar.gz
|
||||
sha256 06288237cd5890eca148489e5b904ed852ed0ffa8424bfb479342f4daa8442a3 faketime-0.9.8.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
FAKETIME_VERSION = 0.9.6
|
||||
FAKETIME_VERSION = 0.9.8
|
||||
FAKETIME_SITE = $(call github,wolfcw,libfaketime,v$(FAKETIME_VERSION))
|
||||
FAKETIME_LICENSE = GPL-2.0
|
||||
FAKETIME_LICENSE_FILES = COPYING
|
||||
|
Loading…
Reference in New Issue
Block a user