package/hackrf: bump to version 2021.03.1
Drop patch (already in version) https://github.com/greatscottgadgets/hackrf/releases/tag/v2021.03.1 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
5bbbf1ba58
commit
13e75d18e5
@ -1,37 +0,0 @@
|
||||
From 8b0a8b2be8cf2e4a76c03d3bcdf99bff5025ba22 Mon Sep 17 00:00:00 2001
|
||||
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
|
||||
Date: Sat, 31 Mar 2018 22:50:37 +0200
|
||||
Subject: [PATCH] Don't require a C++ compiler
|
||||
|
||||
By default, CMake assumes that the project is using both C and C++. By
|
||||
explicitly passing 'C' as argument of the project() macro, we tell CMake
|
||||
that only C is used, which prevents CMake from erroring out if a C++
|
||||
compiler doesn't exist.
|
||||
|
||||
Upstream status: https://github.com/mossmann/hackrf/pull/469
|
||||
|
||||
This patch differs from upstream because:
|
||||
- project name upstream has been changed into HackRF;
|
||||
- in Buildroot, we are only interested in host, not firmware.
|
||||
|
||||
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
|
||||
---
|
||||
host/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
|
||||
index 874163f..d9cbe31 100644
|
||||
--- a/host/CMakeLists.txt
|
||||
+++ b/host/CMakeLists.txt
|
||||
@@ -1,7 +1,7 @@
|
||||
#top dir cmake project for libhackrf + tools
|
||||
|
||||
cmake_minimum_required(VERSION 2.8)
|
||||
-project (hackrf_all)
|
||||
+project (hackrf_all C)
|
||||
|
||||
add_subdirectory(libhackrf)
|
||||
add_subdirectory(hackrf-tools)
|
||||
--
|
||||
2.16.3
|
||||
|
@ -0,0 +1,34 @@
|
||||
From 3e32f46c7948f6b26476558905995ebec9b01760 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Fri, 15 Oct 2021 23:36:54 +0200
|
||||
Subject: [PATCH] cmake/modules/FindFFTW.cmake: fix build without fftw3
|
||||
|
||||
Build on Linux fails if libfftw3 is not available since commit
|
||||
https://github.com/greatscottgadgets/hackrf/commit/a8c1fc92e9fa10843cb4aafd68c52f9903ebd05d
|
||||
which replaced
|
||||
pkg_check_modules(FFTW REQUIRED fftw3f)
|
||||
by
|
||||
find_package(FFTW REQUIRED)
|
||||
|
||||
Fix this build failure by updating FindFFTW.cmake to check for fftw3f
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Retrieved from:
|
||||
https://github.com/greatscottgadgets/hackrf/commit/3e32f46c7948f6b26476558905995ebec9b01760]
|
||||
---
|
||||
host/cmake/modules/FindFFTW.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/host/cmake/modules/FindFFTW.cmake b/host/cmake/modules/FindFFTW.cmake
|
||||
index b9f3bfb81..802db4f5b 100644
|
||||
--- a/host/cmake/modules/FindFFTW.cmake
|
||||
+++ b/host/cmake/modules/FindFFTW.cmake
|
||||
@@ -16,7 +16,7 @@ IF (WIN32)
|
||||
include_directories(${FFTW_INCLUDES})
|
||||
find_library (FFTW_LIBRARIES NAMES ${FFTW_LIBRARIES})
|
||||
ELSE(WIN32)
|
||||
-find_library (FFTW_LIBRARIES NAMES fftw3)
|
||||
+find_library (FFTW_LIBRARIES NAMES fftw3f)
|
||||
ENDIF(WIN32)
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 a89badc09a1d2fa18367b3b2c974580ad5f6ce93aaa4e54557dc3d013c029d14 hackrf-2018.01.1.tar.xz
|
||||
sha256 a43e5080c11efdfe69ddebcc35a02b018e30e820de0e0ebdc7948cf7b0cd93a3 hackrf-2021.03.1.tar.xz
|
||||
sha256 49b60a6288f90f49074228cc1fae0fb16871ba36b756013abdf7c2fc92f01fad COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
HACKRF_VERSION = 2018.01.1
|
||||
HACKRF_VERSION = 2021.03.1
|
||||
HACKRF_SITE = https://github.com/mossmann/hackrf/releases/download/v$(HACKRF_VERSION)
|
||||
HACKRF_SOURCE = hackrf-$(HACKRF_VERSION).tar.xz
|
||||
HACKRF_LICENSE = GPL-2.0+, BSD-3-Clause
|
||||
|
Loading…
Reference in New Issue
Block a user