package/python-automat: bump to version 22.10.0
Current python-automat version 20.2.0 no longer work with Python 3.11
updated in commit 738500c296
.
Running package runtime test with command:
support/testing/run-tests \
-d dl \
-o output_folder \
tests.package.test_python_automat.TestPythonPy3Automat
Fails with output:
Traceback (most recent call last):
File "/root/sample_python_automat.py", line 27, in <module>
led.turn_on()
^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/automat/_methodical.py", line 232, in __get__
File "/usr/lib/python3.11/site-packages/automat/_introspection.py", line 43, in decorator
File "/usr/lib/python3.11/site-packages/automat/_introspection.py", line 35, in copyfunction
File "/usr/lib/python3.11/site-packages/automat/_introspection.py", line 23, in copycode
TypeError: code() argument 13 must be str, not int
This commit fixes this issue by updating the package to the latest
version.
Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
96b9a589ea
commit
12c430f880
@ -0,0 +1,28 @@
|
||||
From d04d51d62a23370869ad466fa95b7d4ec2e0fa6e Mon Sep 17 00:00:00 2001
|
||||
From: Julien Olivain <ju.o@free.fr>
|
||||
Date: Mon, 14 Nov 2022 22:30:33 +0100
|
||||
Subject: [PATCH] Remove uneeded dependency to "wheel"
|
||||
|
||||
Attempting to build Automat in Buildroot fails while trying
|
||||
to check for this undeeded dependency.
|
||||
|
||||
Signed-off-by: Julien Olivain <ju.o@free.fr>
|
||||
---
|
||||
setup.py | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index c2f9816..afa8012 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -15,7 +15,6 @@ setup(
|
||||
packages=find_packages(exclude=[]),
|
||||
package_dir={'automat': 'automat'},
|
||||
setup_requires=[
|
||||
- 'wheel',
|
||||
'setuptools-scm',
|
||||
],
|
||||
install_requires=[
|
||||
--
|
||||
2.38.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# md5, sha256 from https://pypi.org/pypi/automat/json
|
||||
md5 d6cef9886b037b8857bfbc686f3ae30a Automat-20.2.0.tar.gz
|
||||
sha256 7979803c74610e11ef0c0d68a2942b152df52da55336e0c9d58daf1831cbdf33 Automat-20.2.0.tar.gz
|
||||
md5 b8064994239aabb172748f984489ce75 Automat-22.10.0.tar.gz
|
||||
sha256 e56beb84edad19dcc11d30e8d9b895f75deeb5ef5e96b84a467066b3b84bb04e Automat-22.10.0.tar.gz
|
||||
# Locally computed sha256 checksums
|
||||
sha256 b2201301678d0a937d938543827ca1360712eb34e23de8ee3f3bfffbd4c0e376 LICENSE
|
||||
|
@ -4,9 +4,9 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PYTHON_AUTOMAT_VERSION = 20.2.0
|
||||
PYTHON_AUTOMAT_VERSION = 22.10.0
|
||||
PYTHON_AUTOMAT_SOURCE = Automat-$(PYTHON_AUTOMAT_VERSION).tar.gz
|
||||
PYTHON_AUTOMAT_SITE = https://files.pythonhosted.org/packages/80/c5/82c63bad570f4ef745cc5c2f0713c8eddcd07153b4bee7f72a8dc9f9384b
|
||||
PYTHON_AUTOMAT_SITE = https://files.pythonhosted.org/packages/7a/7b/9c3d26d8a0416eefbc0428f168241b32657ca260fb7ef507596ff5c2f6c4
|
||||
PYTHON_AUTOMAT_SETUP_TYPE = setuptools
|
||||
PYTHON_AUTOMAT_LICENSE = MIT
|
||||
PYTHON_AUTOMAT_LICENSE_FILES = LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user