package/libgee: bump to version 0.20.5

Drop patch (already in version) and so autoreconf

https://gitlab.gnome.org/GNOME/libgee/-/blob/0.20.5/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2022-02-14 11:29:59 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 2baaf5bcd7
commit 10780e8d6d
3 changed files with 3 additions and 45 deletions

View File

@ -1,40 +0,0 @@
From d771e8ddb5e40f234459966e46880d10f34aaa1a Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sat, 20 Nov 2021 23:57:33 +0100
Subject: [PATCH] gee/Makefile.am: include Makefile.introspection
Include Makefile.introspection instead of using a custom rule which will
result in the following build failure when cross-compiling on buildroot
because of missing --includedir:
/home/giuliobenetti/autobuild/run/instance-1/output-1/host/bin/../riscv32-buildroot-linux-gnu/sysroot/usr/bin/g-ir-compiler -l `/usr/bin/sed -nE "s/^dlname='([A-Za-z0-9.+-]+)'/\1/p" libgee-0.8.la` -o Gee-0.8.typelib Gee-0.8.gir libgee-0.8.la
Could not find GIR file 'GObject-2.0.gir'; check XDG_DATA_DIRS or use --includedir
error parsing file Gee-0.8.gir: Failed to parse included gir GObject-2.0
Fixes:
- http://autobuild.buildroot.org/results/884faa0f84c8dc43ed1ca6cde9caf21c731a4b35
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status:
https://gitlab.gnome.org/GNOME/libgee/-/merge_requests/8]
---
gee/Makefile.am | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/gee/Makefile.am b/gee/Makefile.am
index 5634bcb..e0d950e 100644
--- a/gee/Makefile.am
+++ b/gee/Makefile.am
@@ -167,7 +167,8 @@ INTROSPECTION_COMPILER_ARGS= \
-l $(libgee_dlname)
Gee-0.8.gir: libgee_0_8_la_vala.stamp
Gee-0.8.typelib: Gee-0.8.gir libgee-0.8.la
- @INTROSPECTION_COMPILER@ $(INTROSPECTION_COMPILER_ARGS) -o $@ $^
+
+-include $(INTROSPECTION_MAKEFILE)
endif
MOSTLYCLEANFILES = \
--
2.33.0

View File

@ -1,5 +1,5 @@
# From http://ftp.acc.umu.se/pub/gnome/sources/libgee/0.20/libgee-0.20.4.sha256sum
sha256 524c1bf390f9cdda4fbd9a47b269980dc64ab5280f0801b53bc69d782c72de0e libgee-0.20.4.tar.xz
# From http://ftp.acc.umu.se/pub/gnome/sources/libgee/0.20/libgee-0.20.5.sha256sum
sha256 31863a8957d5a727f9067495cabf0a0889fa5d3d44626e54094331188d5c1518 libgee-0.20.5.tar.xz
# Hash for license file:
sha256 5df07007198989c622f5d41de8d703e7bef3d0e79d62e24332ee739a452af62a COPYING

View File

@ -5,7 +5,7 @@
################################################################################
LIBGEE_VERSION_MAJOR = 0.20
LIBGEE_VERSION = $(LIBGEE_VERSION_MAJOR).4
LIBGEE_VERSION = $(LIBGEE_VERSION_MAJOR).5
LIBGEE_SITE = http://ftp.gnome.org/pub/gnome/sources/libgee/$(LIBGEE_VERSION_MAJOR)
LIBGEE_SOURCE = libgee-$(LIBGEE_VERSION).tar.xz
LIBGEE_DEPENDENCIES = host-pkgconf host-vala libglib2
@ -13,8 +13,6 @@ LIBGEE_INSTALL_STAGING = YES
LIBGEE_LICENSE = LGPL-2.1+
LIBGEE_LICENSE_FILES = COPYING
LIBGEE_CPE_ID_VENDOR = gnome
# We're patching gee/Makefile.am
LIBGEE_AUTORECONF = YES
ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
LIBGEE_CONF_OPTS += --enable-introspection