add support for fetching latest config.{sub,guess} files from config cvs

This commit is contained in:
Mike Frysinger 2005-08-04 22:42:34 +00:00
parent 1a48268a55
commit 105c3483b5
22 changed files with 5231 additions and 0 deletions

View File

@ -0,0 +1,5 @@
.cvsignore
README.buildroot
gnuconfig.mk
patches
.svn

View File

@ -0,0 +1,14 @@
D/doc////
D/lib////
D/m4////
D/patches////
D/po////
D/scripts////
D/src////
D/tests////
D/testsuite////
/ChangeLog/1.335/Thu Aug 4 14:15:16 2005//
/Makefile/1.6/Thu Aug 4 14:15:16 2005//
/config.guess/1.334/Thu Aug 4 14:15:16 2005//
/config.sub/1.330/Thu Aug 4 14:15:16 2005//
/uname/1.4/Thu Aug 4 14:15:16 2005//

View File

@ -0,0 +1 @@
config

View File

@ -0,0 +1 @@
:ext:anoncvs@savannah.gnu.org:/cvsroot/config

1684
package/gnuconfig/ChangeLog Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,15 @@
UPLOAD=ftp://ftp-upload.gnu.org/incoming/ftp/
all:
@echo "Type 'make upload' to upload to the GNU FTP server."
upload:
gpg --detach-sign config.guess
gpg --detach-sign config.sub
echo "directory: config" | gpg --clearsign > config.guess.directive.asc
cp config.guess.directive.asc config.sub.directive.asc
ftp -a -u $(UPLOAD) config.{guess,sub}{,.sig,.directive.asc}
rm config.{guess,sub}{.sig,.directive.asc}
check:
cd testsuite && (sh config-sub.sh; sh config-guess.sh) && rm uname

View File

@ -0,0 +1,16 @@
--- ABOUT ---
This isnt a real package, it just exists to easily update the
config.sub / config.guess files in packages to the latest version
(since many bundled ones don't support the latest possible targets)
--- HOWTO ---
To use, just add this to your unpack rule in the package.mk:
$(CONFIG_UPDATE) $(PACKAGE_DIR)/
--- UPDATE ---
This is a CVS checkout of the config project, so just run `cvs up`
to get the latest config.sub / config.guess files.
A few local customizations are used to support uClibc so you may
have to make sure they're still needed. The patches are broken
out in the patches/ dir to keep things simple.

1484
package/gnuconfig/config.guess vendored Executable file

File diff suppressed because it is too large Load Diff

1597
package/gnuconfig/config.sub vendored Executable file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,3 @@
# See README.buildroot
CONFIG_UPDATE = cp package/gnuconfig/config.sub package/gnuconfig/config.guess

View File

@ -0,0 +1,165 @@
Index: config.guess
===================================================================
RCS file: /cvsroot/config/config/config.guess,v
retrieving revision 1.334
diff -u -p -r1.334 config.guess
--- config.guess
+++ config.guess
@@ -138,6 +138,23 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` |
UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
+if [ "${UNAME_SYSTEM}" = "Linux" ] ; then
+ eval $set_cc_for_build
+ cat << EOF > $dummy.c
+ #include <features.h>
+ #ifdef __UCLIBC__
+ # ifdef __UCLIBC_CONFIG_VERSION__
+ LIBC=uclibc __UCLIBC_CONFIG_VERSION__
+ # else
+ LIBC=uclibc
+ # endif
+ #else
+ LIBC=gnu
+ #endif
+EOF
+ eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep LIBC= | sed -e 's: ::g'`
+fi
+
# Note: order is significant - the case branches are not exclusive.
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
@@ -815,25 +832,25 @@ EOF
echo ${UNAME_MACHINE}-pc-minix
exit ;;
arm*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
cris:Linux:*:*)
- echo cris-axis-linux-gnu
+ echo cris-axis-linux-${LIBC}
exit ;;
crisv32:Linux:*:*)
- echo crisv32-axis-linux-gnu
+ echo crisv32-axis-linux-${LIBC}
exit ;;
frv:Linux:*:*)
- echo frv-unknown-linux-gnu
+ echo frv-unknown-linux-${LIBC}
exit ;;
ia64:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
m32r*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
m68*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
mips:Linux:*:*)
eval $set_cc_for_build
@@ -852,7 +869,7 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
mips64:Linux:*:*)
eval $set_cc_for_build
@@ -871,16 +888,16 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
or32:Linux:*:*)
- echo or32-unknown-linux-gnu
+ echo or32-unknown-linux-${LIBC}
exit ;;
ppc:Linux:*:*)
- echo powerpc-unknown-linux-gnu
+ echo powerpc-unknown-linux-${LIBC}
exit ;;
ppc64:Linux:*:*)
- echo powerpc64-unknown-linux-gnu
+ echo powerpc64-unknown-linux-${LIBC}
exit ;;
alpha:Linux:*:*)
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
@@ -893,34 +910,34 @@ EOF
EV68*) UNAME_MACHINE=alphaev68 ;;
esac
objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
- if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
- echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
+ if test "$?" = 0 ; then LIBC="gnulibc1" ; fi
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
parisc:Linux:*:* | hppa:Linux:*:*)
# Look for CPU level
case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
- PA7*) echo hppa1.1-unknown-linux-gnu ;;
- PA8*) echo hppa2.0-unknown-linux-gnu ;;
- *) echo hppa-unknown-linux-gnu ;;
+ PA7*) echo hppa1.1-unknown-linux-${LIBC} ;;
+ PA8*) echo hppa2.0-unknown-linux-${LIBC} ;;
+ *) echo hppa-unknown-linux-${LIBC} ;;
esac
exit ;;
parisc64:Linux:*:* | hppa64:Linux:*:*)
- echo hppa64-unknown-linux-gnu
+ echo hppa64-unknown-linux-${LIBC}
exit ;;
s390:Linux:*:* | s390x:Linux:*:*)
echo ${UNAME_MACHINE}-ibm-linux
exit ;;
sh64*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
sh*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
sparc:Linux:*:* | sparc64:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
x86_64:Linux:*:*)
- echo x86_64-unknown-linux-gnu
+ echo x86_64-unknown-linux-${LIBC}
exit ;;
i*86:Linux:*:*)
# The BFD linker knows what the default object file format is, so
@@ -935,20 +952,21 @@ EOF
p'`
case "$ld_supported_targets" in
elf32-i386)
- TENTATIVE="${UNAME_MACHINE}-pc-linux-gnu"
+ TENTATIVE="${UNAME_MACHINE}-pc-linux-${LIBC}"
;;
a.out-i386-linux)
- echo "${UNAME_MACHINE}-pc-linux-gnuaout"
+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}aout"
exit ;;
coff-i386)
- echo "${UNAME_MACHINE}-pc-linux-gnucoff"
+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}coff"
exit ;;
"")
# Either a pre-BFD a.out linker (linux-gnuoldld) or
# one that does not give us useful --help.
- echo "${UNAME_MACHINE}-pc-linux-gnuoldld"
+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}oldld"
exit ;;
esac
+ if [ "$LIBC" != "gnu" ] ; then echo "$TENTATIVE" && exit 0 ; fi
# Determine whether the default compiler is a.out or elf
eval $set_cc_for_build
sed 's/^ //' << EOF >$dummy.c

View File

@ -0,0 +1,50 @@
Index: config.sub
===================================================================
RCS file: /cvsroot/config/config/config.sub,v
retrieving revision 1.330
diff -u -p -r1.330 config.sub
--- config.sub
+++ config.sub
@@ -234,7 +234,7 @@ case $basic_machine in
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
| bfin \
| c4x | clipper \
- | d10v | d30v | dlx | dsp16xx \
+ | d10v | d30v | dlx | dsp16xx | dvp \
| fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
@@ -678,6 +678,24 @@ case $basic_machine in
basic_machine=m68k-atari
os=-mint
;;
+ mipsEE* | ee | ps2)
+ basic_machine=mips64r5900el-scei
+ case $os in
+ -linux*)
+ ;;
+ *)
+ os=-elf
+ ;;
+ esac
+ ;;
+ iop)
+ basic_machine=mipsel-scei
+ os=-irx
+ ;;
+ dvp)
+ basic_machine=dvp-scei
+ os=-elf
+ ;;
mips3*-*)
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
;;
@@ -1188,7 +1206,7 @@ case $os in
| -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
- | -skyos* | -haiku*)
+ | -skyos* | -haiku* | -irx*)
# Remember, each alternative MUST END IN *, to match a version number.
;;
-qnx*)

View File

@ -0,0 +1 @@
uname

View File

@ -0,0 +1,7 @@
/config-guess.data/1.15/Thu Aug 4 14:15:16 2005//
/config-guess.sh/1.4/Thu Aug 4 14:15:16 2005//
/config-sub.data/1.23/Thu Aug 4 14:15:16 2005//
/config-sub.sh/1.2/Thu Aug 4 14:15:16 2005//
/uname.in/1.1/Thu Aug 4 14:15:16 2005//
/.cvsignore/1.1/Thu Aug 4 22:41:55 2005//
D

View File

@ -0,0 +1 @@
config/testsuite

View File

@ -0,0 +1 @@
:ext:anoncvs@savannah.gnu.org:/cvsroot/config

View File

@ -0,0 +1,14 @@
crisv32 2.6.6 Linux ignored crisv32-axis-linux-gnu
frv 2.4.24 Linux ignored frv-unknown-linux-gnu
3 2.3.3 XENIX SysV i386-pc-xenix
2064 ignored z/VM ignored s390-ibm-zvmoe
amd64 1.5.12(0.116/4/2) CYGWIN_NT-5.2 ignored x86_64-unknown-cygwin
crayx1 2.5.20 UNICOS/mp ignored craynv-cray-unicosmp2.5.X
NSE-N 1.0 NONSTOP_KERNEL ignored nse-tandem-nsk1.0
i386 ignored VOS ignored i386-stratus-vos
arm ignored RISCOS ignored arm-unknown-riscos
arm ignored riscos ignored arm-unknown-riscos
i586 5.0.0 skyos ignored i586-pc-skyos5.0.0
i786-pc ignored windows32 ignored i786-pc-mingw32
or32 ignored Linux ignored or32-unknown-linux-gnu
x86_64 1.5.18(0.132/4/2) CYGWIN_NT-5.2 ignored x86_64-unknown-cygwin

View File

@ -0,0 +1,47 @@
#!/bin/sh
#
# Copyright 2004, 2005 Free Software Foundation, Inc.
# Contributed by Ben Elliston <bje@gnu.org>.
#
# This test reads 5-tuples from config-guess.data: the components of
# the simulated uname(1) output and the expected GNU system triplet.
verbose=false
export PATH=`pwd`:$PATH
IFS=" " # tab
function run_config_guess ()
{
rc=0
while read machine release system version triplet ; do
sed \
-e "s,@MACHINE@,$machine," \
-e "s,@RELEASE@,$release," \
-e "s,@SYSTEM@,$system," \
-e "s,@VERSION@,$version," < uname.in > uname
chmod +x uname
output=`sh ../config.guess 2>/dev/null`
if test $? != 0 ; then
echo "FAIL: unable to guess $machine:$release:$system:$version"
rc=1
continue
fi
if test $output != $triplet ; then
echo "FAIL: $output (expected $triplet)"
rc=1
continue
fi
$verbose && echo "PASS: $triplet"
done
return $rc
}
sed 's/ */ /g' < config-guess.data | run_config_guess
rc=$?
if test $rc -eq 0 ; then
$verbose || echo "PASS: config.guess checks"
else
test $rc -eq 1 && echo "Unexpected failures."
fi
exit $rc

View File

@ -0,0 +1,72 @@
arm-coff arm-unknown-coff
arm-elf arm-unknown-elf
sun3 m68k-sun-sunos4.1.1
sun4 sparc-sun-sunos4.1.1
ibm i370-ibm-aix
i386-os2 i386-pc-os2
os400 powerpc-ibm-os400
mmix mmix-knuth-mmixware
mmix-elf mmix-knuth-elf
i386-linux i386-pc-linux-gnu
i386-netbsd i386-pc-netbsd
i386-openbsd i386-pc-openbsd
i386-freebsd i386-pc-freebsd
i386-elf i386-pc-elf
i486-elf i486-pc-elf
i586-elf i586-pc-elf
i686-elf i686-pc-elf
i786-elf i786-pc-elf
amd64-unknown-freebsd5.2 x86_64-unknown-freebsd5.2
cris-linux cris-axis-linux-gnu
crisv32-linux crisv32-axis-linux-gnu
frv-linux frv-unknown-linux-gnu
djgpp i586-pc-msdosdjgpp
s390-ibm-zvmoe s390-ibm-zvmoe
xscale xscale-unknown-none
xscaleeb xscaleeb-unknown-none
xscaleel xscaleel-unknown-none
xbox i686-pc-mingw32
maxq maxq-unknown-none
maxq-elf maxq-unknown-elf
amd64-cygwin x86_64-pc-cygwin
x86_64-cygwin x86_64-pc-cygwin
sparc64-linux sparc64-unknown-linux-gnu
sparc64b-linux sparc64b-unknown-linux-gnu
bfin-elf bfin-unknown-elf
bfin bfin-unknown-none
arm-riscos arm-unknown-riscos
arm-unknown-riscos arm-unknown-riscos
i586-skyos i586-pc-skyos
m32c m32c-unknown-none
m32c-elf m32c-unknown-elf
ms1 ms1-unknown-none
ms1-elf ms1-unknown-elf
mips64vr5900-elf mips64vr5900-unknown-elf
mips64vr5900el-elf mips64vr5900el-unknown-elf
mips64vr5900 mips64vr5900-unknown-elf
mips64vr5900el mips64vr5900el-unknown-elf
sh64 sh64-unknown-none
sh64-elf sh64-unknown-elf
openrisc-linux or32-unknown-linux-gnu
or32-linux or32-unknown-linux-gnu
sh-elf sh-unknown-elf
sh1-elf sh1-unknown-elf
sh2-elf sh2-unknown-elf
sh3-elf sh3-unknown-elf
sh4-elf sh4-unknown-elf
sh2a-elf sh2a-unknown-elf
sh4a-elf sh4a-unknown-elf
sh2e-elf sh2e-unknown-elf
sh3e-elf sh3e-unknown-elf
sh3eb-elf sh3eb-unknown-elf
sh4eb-elf sh4eb-unknown-elf
shbe-elf shbe-unknown-elf
shle-elf shle-unknown-elf
sh1le-elf sh1le-unknown-elf
sh2le-elf sh2le-unknown-elf
sh3le-elf sh3le-unknown-elf
sh4le-elf sh4le-unknown-elf
sh3ele-elf sh3ele-unknown-elf
i386-haiku i386-pc-haiku
sparc-haiku sparc-unknown-haiku
powerpc-haiku powerpc-unknown-haiku

View File

@ -0,0 +1,35 @@
#!/bin/sh
#
# Copyright 2004, 2005 Free Software Foundation, Inc.
# Contributed by Ben Elliston <bje@gnu.org>.
#
# This test reads pairs from config-sub.data: an alias and its
# canonical triplet. The config.sub scripts is invoked and the test
# checks that the alias expands to the expected canonical triplet.
verbose=false
function run_config_sub ()
{
rc=0
while read alias canonical ; do
output=`sh ../config.sub $alias`
if test $output != $canonical ; then
echo "FAIL: $alias -> $output, but expected $canonical"
rc=1
else
$verbose && echo "PASS: $alias"
fi
done < config-sub.data
return $rc
}
run_config_sub
rc=$?
if test $rc -eq 0 ; then
$verbose || echo "PASS: config.sub checks"
else
test $rc -eq 1 && echo "Unexpected failures."
fi
exit $rc

View File

@ -0,0 +1,9 @@
#!/bin/sh
# uname(1) simulator, inspired by Pavel Roskin.
[ $# -ne 1 ] && exec sh $0 -s
[ $1 = -m ] && echo "@MACHINE@" && exit 0
[ $1 = -r ] && echo "@RELEASE@" && exit 0
[ $1 = -s ] && echo "@SYSTEM@" && exit 0
[ $1 = -v ] && echo "@VERSION@" && exit 0
[ $1 = -p ] && echo "Pentium III(TM)-ISA/PCI"

9
package/gnuconfig/uname Executable file
View File

@ -0,0 +1,9 @@
#!/bin/sh
# uname(1) simulator, inspired by Pavel Roskin.
[ $# -ne 1 ] && exec sh $0 -s
[ $1 = -m ] && echo 4400
[ $1 = -r ] && echo 4.0
[ $1 = -s ] && echo iainfo2
[ $1 = -v ] && echo 3.0
[ $1 = -p ] && echo "Pentium III(TM)-ISA/PCI"