package/poke: bump to version 2.1
Tested locally with poke testsuite on aarch64 with Qemu: === poke Summary === # of expected passes 6320 # of unsupported tests 7 Build tested with test-pkg: https://gitlab.com/kubu93/buildroot/-/pipelines/466516470 See: http://www.jemarch.net/poke-2.0-relnotes.html http://www.jemarch.net/poke-2.1-relnotes.html Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
948050c0f9
commit
0fc614345f
@ -1,4 +1,4 @@
|
||||
From b35dadae6371c3727cac46ae5bd348b66aa411fc Mon Sep 17 00:00:00 2001
|
||||
From 51fb81264323f01a86dd0bdeaf1c7a044a9cb6dc Mon Sep 17 00:00:00 2001
|
||||
From: Romain Naour <romain.naour@gmail.com>
|
||||
Date: Fri, 30 Apr 2021 15:43:59 +0200
|
||||
Subject: [PATCH] configure.ac: HELP2MAN replace ':' by 'true' when
|
||||
@ -17,10 +17,10 @@ Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 2c6f1aef..9c4c9be2 100644
|
||||
index a1943b57..c633f719 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -74,7 +74,7 @@ gl_LIBTEXTSTYLE_OPTIONAL([0.20.5])
|
||||
@@ -90,7 +90,7 @@ gl_LIBTEXTSTYLE_OPTIONAL([0.20.5])
|
||||
if test $cross_compiling = no; then
|
||||
AM_MISSING_PROG(HELP2MAN, help2man)
|
||||
else
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a0594387565e1e6b4a8a8ba04ad13b135cc1f0b5 Mon Sep 17 00:00:00 2001
|
||||
From 236b019b83228d2e37fa07635fb6864ed7dc5fad Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Thu, 1 Apr 2021 07:49:46 +0200
|
||||
Subject: [PATCH] lib/getrandom.c: fix build with uclibc < 1.0.35
|
||||
@ -15,7 +15,7 @@ In file included from ./sys/random.h:40,
|
||||
/tmp/instance-0/output-1/host/x86_64-buildroot-linux-uclibc/sysroot/usr/include/sys/random.h:8:1: note: 'size_t' is defined in header '<stddef.h>'; did you forget to '#include <stddef.h>'?
|
||||
7 | #include <features.h>
|
||||
+++ |+#include <stddef.h>
|
||||
8 |
|
||||
8 |
|
||||
|
||||
This patch is not upstreamable as it is only a workaround for
|
||||
uclibc < 1.0.35, upstream uclibc has been patched with
|
||||
@ -26,47 +26,47 @@ Fixes:
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
jitter/gnulib-local/getrandom.c | 1 +
|
||||
gl/getrandom.c | 1 +
|
||||
gl-libpoke/getrandom.c | 1 +
|
||||
gl/getrandom.c | 1 +
|
||||
jitter/gnulib-local/getrandom.c | 1 +
|
||||
3 files changed, 3 insertions(+)
|
||||
|
||||
diff --git a/jitter/gnulib-local/getrandom.c b/jitter/gnulib-local/getrandom.c
|
||||
index 41212fb32..0ad3f9648 100644
|
||||
--- a/jitter/gnulib-local/getrandom.c
|
||||
+++ b/jitter/gnulib-local/getrandom.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <sys/random.h>
|
||||
|
||||
#include <errno.h>
|
||||
diff --git a/gl/getrandom.c b/gl/getrandom.c
|
||||
index 41212fb32..0ad3f9648 100644
|
||||
--- a/gl/getrandom.c
|
||||
+++ b/gl/getrandom.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <sys/random.h>
|
||||
|
||||
#include <errno.h>
|
||||
diff --git a/gl-libpoke/getrandom.c b/gl-libpoke/getrandom.c
|
||||
index 41212fb32..0ad3f9648 100644
|
||||
index e146873..3948d8d 100644
|
||||
--- a/gl-libpoke/getrandom.c
|
||||
+++ b/gl-libpoke/getrandom.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <sys/random.h>
|
||||
|
||||
#include <errno.h>
|
||||
diff --git a/gl/getrandom.c b/gl/getrandom.c
|
||||
index e146873..3948d8d 100644
|
||||
--- a/gl/getrandom.c
|
||||
+++ b/gl/getrandom.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <sys/random.h>
|
||||
|
||||
#include <errno.h>
|
||||
diff --git a/jitter/gnulib-local/getrandom.c b/jitter/gnulib-local/getrandom.c
|
||||
index e146873..3948d8d 100644
|
||||
--- a/jitter/gnulib-local/getrandom.c
|
||||
+++ b/jitter/gnulib-local/getrandom.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <sys/random.h>
|
||||
|
||||
#include <errno.h>
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
# Locally calculated
|
||||
sha256 ce054df29560c921230132703ee449fe130b6e25ab03aa6cc796bb401506aa24 poke-1.4.tar.gz
|
||||
sha256 cd528e6c1bbc540c3b629c2b4f36b784b30a026b005a38b99283422599442670 poke-2.1.tar.gz
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 jitter/COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
POKE_VERSION = 1.4
|
||||
POKE_VERSION = 2.1
|
||||
POKE_SITE = $(BR2_GNU_MIRROR)/poke
|
||||
# gnulib license is a mix/mess of public-domain and various GPL and LGPL versions.
|
||||
POKE_LICENSE = GPL-3.0+, GPL-3.0+ (jitter), gnulib license (gnulib)
|
||||
|
Loading…
Reference in New Issue
Block a user