package/zlib-ng: bump version to 2.1.3

Removed all patches because they are included in this release.

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Bernd Kuhls 2023-07-09 11:24:56 +02:00 committed by Thomas Petazzoni
parent 353c06849b
commit 0df456ea6e
5 changed files with 2 additions and 172 deletions

View File

@ -1,27 +0,0 @@
From 677f56825f7080403e18e57ffe8177f3df290f20 Mon Sep 17 00:00:00 2001
From: Nathan Moinvaziri <nathan@nathanm.com>
Date: Sun, 23 Jan 2022 12:59:01 -0800
Subject: [PATCH] Use static keyword for vec_sumsu to prevent undefined
reference error when g++ linking.
Signed-off-by: Joel Stanley <joel@jms.id.au>
---
arch/power/adler32_power8.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/power/adler32_power8.c b/arch/power/adler32_power8.c
index 029aa3a84c57..fc4086322efc 100644
--- a/arch/power/adler32_power8.c
+++ b/arch/power/adler32_power8.c
@@ -44,7 +44,7 @@
#include "adler32_p.h"
/* Vector across sum unsigned int (saturate). */
-inline vector unsigned int vec_sumsu(vector unsigned int __a, vector unsigned int __b) {
+static inline vector unsigned int vec_sumsu(vector unsigned int __a, vector unsigned int __b) {
__b = vec_sld(__a, __a, 8);
__b = vec_add(__b, __a);
__a = vec_sld(__b, __b, 4);
--
2.35.1

View File

@ -1,53 +0,0 @@
From 9fcc446306f27eb253545540ce28403874b899fa Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Fri, 27 May 2022 23:25:21 +0200
Subject: [PATCH] CMakeLists.txt: fix version in zlib.pc when building
statically
When building statically (i.e. with BUILD_SHARED_LIBS=OFF),
ZLIB_FULL_VERSION is not set resulting in an empty version in zlib.pc
and the following build failure with transmission:
checking for ZLIB... configure: error: Package requirements (zlib >= 1.2.3) were not met:
Package dependency requirement 'zlib >= 1.2.3' could not be satisfied.
Package 'zlib' has version '', required version is '>= 1.2.3'
Fixes:
- http://autobuild.buildroot.org/results/b3b882482f517726e5c780ba4c37818bd379df82
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/zlib-ng/zlib-ng/pull/1278]
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a62a95e..6a26d59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,8 +150,10 @@ if(ZLIB_COMPAT)
add_definitions(-DZLIB_COMPAT)
set(WITH_GZFILEOP ON)
set(SUFFIX "")
+ set(ZLIB_FULL_VERSION ${ZLIB_HEADER_VERSION}.zlib-ng)
else()
set(SUFFIX "-ng")
+ set(ZLIB_FULL_VERSION ${ZLIBNG_HEADER_VERSION})
endif()
if(WITH_GZFILEOP)
@@ -1068,10 +1070,8 @@ if(NOT DEFINED BUILD_SHARED_LIBS OR BUILD_SHARED_LIBS)
set_target_properties(zlib PROPERTIES DEFINE_SYMBOL ZLIB_DLL)
if(ZLIB_COMPAT)
- set(ZLIB_FULL_VERSION ${ZLIB_HEADER_VERSION}.zlib-ng)
set_target_properties(zlib PROPERTIES SOVERSION 1)
else()
- set(ZLIB_FULL_VERSION ${ZLIBNG_HEADER_VERSION})
set_target_properties(zlib PROPERTIES SOVERSION 2)
endif()
--
2.35.1

View File

@ -1,90 +0,0 @@
From e1baa6b439c06f3d0e6be3e381cc746ffb55aee1 Mon Sep 17 00:00:00 2001
From: Mika Lindqvist <postmaster@raasu.org>
Date: Wed, 13 Apr 2022 01:22:29 +0300
Subject: [PATCH] Check that sys/auxv.h exists at configure time and add
preprocessor define for it. * Protect including sys/auxv.h in all relevant
files with the new preprocessor define * Test for both existence of both
sys/auxv.h and getauxval() with both cmake and configure
[Ben Hutchings: Backport to 2.0.6:
- Drop the s390 changes
- Change some filenames]
Backported from: e1baa6b439c06f3d0e6be3e381cc746ffb55aee1
Signed-off-by: Ben Hutchings <ben.hutchings@mind.be>
---
CMakeLists.txt | 4 ++++
arch/arm/armfeature.c | 2 +-
arch/power/power.c | 5 ++++-
configure | 13 +++++++++++++
4 files changed, 22 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0dd196130..e4e4b7332 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -338,6 +338,10 @@ endif()
#
# Check for standard/system includes
#
+check_include_file(sys/auxv.h HAVE_SYS_AUXV_H)
+if(HAVE_SYS_AUXV_H)
+ add_definitions(-DHAVE_SYS_AUXV_H)
+endif()
check_include_file(sys/sdt.h HAVE_SYS_SDT_H)
if(HAVE_SYS_SDT_H)
add_definitions(-DHAVE_SYS_SDT_H)
diff --git a/arch/arm/arm_features.c b/arch/arm/arm_features.c
index 195c94992..f6b67687f 100644
--- a/arch/arm/armfeature.c
+++ b/arch/arm/armfeature.c
@@ -1,6 +1,6 @@
#include "../../zutil.h"
-#if defined(__linux__)
+#if defined(__linux__) && defined(HAVE_SYS_AUXV_H)
# include <sys/auxv.h>
# ifdef ARM_ASM_HWCAP
# include <asm/hwcap.h>
diff --git a/arch/power/power_features.c b/arch/power/power_features.c
index 9186b40d8..65599d9a7 100644
--- a/arch/power/power.c
+++ b/arch/power/power.c
@@ -1,9 +1,12 @@
/* POWER feature check
* Copyright (C) 2020 Matheus Castanho <msc@linux.ibm.com>, IBM
+ * Copyright (C) 2021-2022 Mika T. Lindqvist <postmaster@raasu.org>
* For conditions of distribution and use, see copyright notice in zlib.h
*/
-#include <sys/auxv.h>
+#ifdef HAVE_SYS_AUXV_H
+# include <sys/auxv.h>
+#endif
#include "../../zutil.h"
Z_INTERNAL int power_cpu_has_arch_2_07;
diff --git a/configure b/configure
index aed1909cc..a357e1c8a 100755
--- a/configure
+++ b/configure
@@ -776,6 +776,19 @@ else
echo "Checking for strerror... No." | tee -a configure.log
fi
+# check for getauxval() for architecture feature detection at run-time
+cat > $test.c <<EOF
+#include <sys/auxv.h>
+int main() { return getauxval(0); }
+EOF
+if try $CC $CFLAGS -o $test $test.c $LDSHAREDLIBC; then
+ echo "Checking for getauxval() in sys/auxv.h... Yes." | tee -a configure.log
+ CFLAGS="${CFLAGS} -DHAVE_SYS_AUXV_H"
+ SFLAGS="${SFLAGS} -DHAVE_SYS_AUXV_H"
+else
+ echo "Checking for getauxval() in sys/auxv.h... No." | tee -a configure.log
+fi
+
# We need to remove zconf.h from source directory if building outside of it
if [ "$SRCDIR" != "$BUILDDIR" ]; then
rm -f $SRCDIR/zconf${SUFFIX}.h

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 8258b75a72303b661a238047cb348203d88d9dddf85d480ed885f375916fcab6 zlib-ng-2.0.6.tar.gz
sha256 d20e55f89d71991c59f1c5ad1ef944815e5850526c0d9cd8e504eaed5b24491a zlib-ng-2.1.3.tar.gz
sha256 d3c80be055d94d798eaa786116e84fa0b010bc11420b5d2060d978ea77845436 LICENSE.md

View File

@ -4,7 +4,7 @@
#
################################################################################
ZLIB_NG_VERSION = 2.0.6
ZLIB_NG_VERSION = 2.1.3
ZLIB_NG_SITE = $(call github,zlib-ng,zlib-ng,$(ZLIB_NG_VERSION))
ZLIB_NG_LICENSE = Zlib
ZLIB_NG_LICENSE_FILES = LICENSE.md