package/php: bump version to 8.1.7
Rebased patches when needed. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
434375849c
commit
0ddfece7f7
@ -9,6 +9,8 @@ Terminate them with extreme prejudice.
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
||||
[aduskett@gmail.com: Update for 7.3.0]
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
[Bernd: rebased for 8.1.7]
|
||||
---
|
||||
build/php.m4 | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
@ -17,7 +19,7 @@ diff --git a/build/php.m4 b/build/php.m4
|
||||
index e91ef988..9586c490 100644
|
||||
--- a/build/php.m4
|
||||
+++ b/build/php.m4
|
||||
@@ -1568,8 +1568,6 @@ dnl PHP_CHECK_FUNC_LIB
|
||||
@@ -1580,8 +1580,6 @@ dnl PHP_CHECK_FUNC_LIB
|
||||
dnl
|
||||
AC_DEFUN([PHP_CHECK_FUNC_LIB],[
|
||||
ifelse($2,,:,[
|
||||
@ -26,7 +28,7 @@ index e91ef988..9586c490 100644
|
||||
unset found
|
||||
AC_CHECK_LIB($2, $1, [found=yes], [
|
||||
AC_CHECK_LIB($2, __$1, [found=yes], [found=no])
|
||||
@@ -1601,8 +1599,6 @@ dnl and as a fall back in the specified library. Defines HAVE_func and
|
||||
@@ -1616,8 +1616,6 @@ dnl and as a fall back in the specified library. Defines HAVE_func and
|
||||
dnl HAVE_library if found and adds the library to LIBS.
|
||||
dnl
|
||||
AC_DEFUN([PHP_CHECK_FUNC],[
|
||||
|
@ -16,7 +16,7 @@ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
||||
[aduskett@gmail.com: Update for 8.0.7]
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
[Bernd: rebased for 7.4.10 & 7.4.13]
|
||||
[Bernd: rebased for 7.4.10, 7.4.13 & 8.1.7]
|
||||
---
|
||||
build/php.m4 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
@ -25,7 +25,7 @@ diff --git a/build/php.m4 b/build/php.m4
|
||||
index 9586c490..8b3d47ed 100644
|
||||
--- a/build/php.m4
|
||||
+++ b/build/php.m4
|
||||
@@ -1937,7 +1937,7 @@ AC_DEFUN([PHP_SETUP_ICONV], [
|
||||
@@ -1976,7 +1976,7 @@ AC_DEFUN([PHP_SETUP_ICONV], [
|
||||
dnl Check external libs for iconv funcs.
|
||||
if test "$found_iconv" = "no"; then
|
||||
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
||||
[Aduskett: update for 8.0.7]
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
[Bernd: rebased for 7.4.10 & 7.4.13]
|
||||
[Bernd: rebased for 7.4.10, 7.4.13 & 8.1.7]
|
||||
---
|
||||
configure.ac | 9 ++-------
|
||||
1 file changed, 2 insertions(+), 7 deletions(-)
|
||||
@ -22,7 +22,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 0dfab302..6026fb66 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1423,13 +1423,8 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
|
||||
@@ -1566,13 +1566,8 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
|
||||
CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
|
||||
CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"
|
||||
|
||||
|
@ -13,6 +13,8 @@ CFLAGS when opcache is enabled:
|
||||
-DHAVE_SHM_MMAP_FILE
|
||||
|
||||
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
[Bernd: rebased for 8.1.7]
|
||||
---
|
||||
ext/opcache/config.m4 | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
@ -21,8 +23,8 @@ diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
|
||||
index 5492fd92..10c150ff 100644
|
||||
--- a/ext/opcache/config.m4
|
||||
+++ b/ext/opcache/config.m4
|
||||
@@ -339,10 +339,6 @@ int main() {
|
||||
PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
|
||||
@@ -331,10 +331,6 @@ int main() {
|
||||
|
||||
PHP_ADD_EXTENSION_DEP(opcache, pcre)
|
||||
|
||||
- if test "$have_shm_ipc" != "yes" && test "$have_shm_mmap_posix" != "yes" && test "$have_shm_mmap_anon" != "yes"; then
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://www.php.net/downloads.php
|
||||
sha256 973fec765336ee01f47536a5db1c2eee98df9d34a41522b7b6c760159bf0a77b php-8.0.20.tar.xz
|
||||
sha256 f042322f1b5a9f7c2decb84b7086ef676896c2f7178739b9672afafa964ed0e5 php-8.1.7.tar.xz
|
||||
|
||||
# License file
|
||||
sha256 a188db807d711536f71e27b7d36879d63480f7994dc18adc08e624b3c5430fff LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PHP_VERSION = 8.0.20
|
||||
PHP_VERSION = 8.1.7
|
||||
PHP_SITE = https://www.php.net/distributions
|
||||
PHP_SOURCE = php-$(PHP_VERSION).tar.xz
|
||||
PHP_INSTALL_STAGING = YES
|
||||
|
Loading…
Reference in New Issue
Block a user