package/libwebsockets: bump to version 4.3.3
Drop first patch (already in version) https://github.com/warmcat/libwebsockets/compare/v4.3.2...v4.3.3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
6c5981d1a1
commit
0d6e5ca41f
@ -727,7 +727,6 @@ package/libvpx/0001-vpx_mem-vpx_mem.h-Fix-compilation-with-uClibc.patch Upstream
|
||||
package/libwebsock/0001-Switch-to-use-pkg-config-to-detect-libevent-and-open.patch Upstream
|
||||
package/libwebsock/0002-fix-ssl.patch Upstream
|
||||
package/libwebsock/0003-fix-incorrect-inline.patch Upstream
|
||||
package/libwebsockets/0001-lib-tls-CMakeLists.txt-fix-build-without-threads.patch Upstream
|
||||
package/libyuv/0001-i386-sse2.patch Upstream
|
||||
package/lighttpd/0001-Modify-the-default-lighttpd-configuration-file-to-ha.patch Upstream
|
||||
package/lighttpd/S50lighttpd EmptyLastLine Indent Shellcheck Variables
|
||||
|
@ -1,47 +0,0 @@
|
||||
From c83cf48b9095a6914a0844bec4439763bb0c9138 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sat, 28 May 2022 23:15:40 +0200
|
||||
Subject: [PATCH] lib/tls/CMakeLists.txt: fix build without threads
|
||||
|
||||
openssl can be built without threads resulting in the following build
|
||||
failure:
|
||||
|
||||
-- Looking for HMAC_CTX_new
|
||||
-- Looking for HMAC_CTX_new - not found
|
||||
|
||||
[...]
|
||||
|
||||
In file included from /home/buildroot/autobuild/instance-0/output-1/build/libwebsockets-4.3.1/include/libwebsockets.h:661,
|
||||
from /home/buildroot/autobuild/instance-0/output-1/build/libwebsockets-4.3.1/lib/core/./private-lib-core.h:140,
|
||||
from /home/buildroot/autobuild/instance-0/output-1/build/libwebsockets-4.3.1/lib/plat/unix/unix-misc.c:28:
|
||||
/home/buildroot/autobuild/instance-0/output-1/build/libwebsockets-4.3.1/include/libwebsockets/lws-genhash.h:85:18: error: field 'ctx' has incomplete type
|
||||
85 | HMAC_CTX ctx;
|
||||
| ^~~
|
||||
|
||||
To fix this build failure, don't unconditionally add pthread if openssl
|
||||
has been found through pkg-config as openssl.pc will contain the
|
||||
appropriate dependencies (i.e. -lpthread but also -lz or -latomic)
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/2ae9e3249b6fcc9e6c30e7783e264fc6599e61df
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Retrieved from:
|
||||
https://github.com/warmcat/libwebsockets/commit/c83cf48b9095a6914a0844bec4439763bb0c9138]
|
||||
---
|
||||
lib/tls/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/tls/CMakeLists.txt b/lib/tls/CMakeLists.txt
|
||||
index 559be9abb..a2b78c252 100644
|
||||
--- a/lib/tls/CMakeLists.txt
|
||||
+++ b/lib/tls/CMakeLists.txt
|
||||
@@ -311,7 +311,7 @@ endif()
|
||||
if (UNIX AND NOT (${CMAKE_SYSTEM_NAME} MATCHES "QNX"))
|
||||
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${CMAKE_DL_LIBS})
|
||||
endif()
|
||||
-if ((CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX) AND NOT (${CMAKE_SYSTEM_NAME} MATCHES "QNX"))
|
||||
+if ((CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX) AND NOT ((${CMAKE_SYSTEM_NAME} MATCHES "QNX") OR PC_OPENSSL_FOUND))
|
||||
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} pthread)
|
||||
endif()
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed:
|
||||
sha256 6a85a1bccf25acc7e8e5383e4934c9b32a102880d1e4c37c70b27ae2a42406e1 libwebsockets-4.3.2.tar.gz
|
||||
sha256 6fd33527b410a37ebc91bb64ca51bdabab12b076bc99d153d7c5dd405e4bdf90 libwebsockets-4.3.3.tar.gz
|
||||
sha256 2b5dd8030691f3d1870a040f085c37e45d9ab9c684a7f1284f5f379c1e829b28 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBWEBSOCKETS_VERSION = 4.3.2
|
||||
LIBWEBSOCKETS_VERSION = 4.3.3
|
||||
LIBWEBSOCKETS_SITE = $(call github,warmcat,libwebsockets,v$(LIBWEBSOCKETS_VERSION))
|
||||
LIBWEBSOCKETS_LICENSE = MIT with exceptions
|
||||
LIBWEBSOCKETS_LICENSE_FILES = LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user