diff --git a/Config.in.legacy b/Config.in.legacy
index 1f57671893..445cab749c 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -101,6 +101,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2015.05"
 
+config BR2_PACKAGE_GTK2_THEME_HICOLOR
+	bool "hicolor (default theme) is a duplicate"
+	select BR2_LEGACY
+	select BR2_PACKAGE_HICOLOR_ICON_THEME
+	help
+	  The option was just a duplicate of hicolor icon theme.
+
 config BR2_PACKAGE_VALGRIND_PTRCHECK
 	bool "valgrind's PTRCheck was renamed to SGCheck"
 	select BR2_LEGACY
diff --git a/package/Config.in b/package/Config.in
index 8cd0cb1b4a..74ec00abb2 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -709,7 +709,6 @@ menu "Graphics"
 	source "package/giblib/Config.in"
 	source "package/giflib/Config.in"
 	source "package/gtk2-engines/Config.in"
-	source "package/gtk2-themes/Config.in"
 	source "package/harfbuzz/Config.in"
 	source "package/hicolor-icon-theme/Config.in"
 	source "package/imlib2/Config.in"
diff --git a/package/gtk2-themes/Config.in b/package/gtk2-themes/Config.in
deleted file mode 100644
index ac212b898b..0000000000
--- a/package/gtk2-themes/Config.in
+++ /dev/null
@@ -1,6 +0,0 @@
-menu "GTK Themes"
-depends on BR2_PACKAGE_LIBGTK2
-
-source "package/gtk2-themes/gtk2-theme-hicolor/Config.in"
-
-endmenu
diff --git a/package/gtk2-themes/gtk2-theme-hicolor/Config.in b/package/gtk2-themes/gtk2-theme-hicolor/Config.in
deleted file mode 100644
index 144f1d8656..0000000000
--- a/package/gtk2-themes/gtk2-theme-hicolor/Config.in
+++ /dev/null
@@ -1,2 +0,0 @@
-config BR2_PACKAGE_GTK2_THEME_HICOLOR
-	bool "hicolor (default theme)"
diff --git a/package/gtk2-themes/gtk2-theme-hicolor/gtk2-theme-hicolor.mk b/package/gtk2-themes/gtk2-theme-hicolor/gtk2-theme-hicolor.mk
deleted file mode 100644
index 84df23f024..0000000000
--- a/package/gtk2-themes/gtk2-theme-hicolor/gtk2-theme-hicolor.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-################################################################################
-#
-# gtk2-theme-hicolor
-#
-################################################################################
-
-GTK2_THEME_HICOLOR_VERSION = 0.10
-GTK2_THEME_HICOLOR_SOURCE = hicolor-icon-theme-$(GTK2_THEME_HICOLOR_VERSION).tar.gz
-GTK2_THEME_HICOLOR_SITE = http://icon-theme.freedesktop.org/releases
-GTK2_THEME_HICOLOR_DEPENDENCIES = libgtk2
-GTK2_THEME_HICOLOR_LICENSE = GPLv2
-GTK2_THEME_HICOLOR_LICENSE_FILES = COPYING
-
-$(eval $(autotools-package))
diff --git a/package/gtk2-themes/gtk2-themes.mk b/package/gtk2-themes/gtk2-themes.mk
deleted file mode 100644
index fc66698a1d..0000000000
--- a/package/gtk2-themes/gtk2-themes.mk
+++ /dev/null
@@ -1 +0,0 @@
-include $(sort $(wildcard package/gtk2-themes/*/*.mk))