package/dhcpcd: bump to version 9.4.0
Drop patch (already in version) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
d637d3cf06
commit
0d2bfb42a5
@ -1,36 +0,0 @@
|
||||
From 13e475d9847bf7d6a6af62397f67eb269e27613e Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Mon, 13 Jul 2020 10:43:51 +0200
|
||||
Subject: [PATCH] src/dhcpcd.c: fix build without fork
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://github.com/rsmarples/dhcpcd/pull/17]
|
||||
---
|
||||
src/dhcpcd.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/dhcpcd.c b/src/dhcpcd.c
|
||||
index ee585aa4..b597a5c0 100644
|
||||
--- a/src/dhcpcd.c
|
||||
+++ b/src/dhcpcd.c
|
||||
@@ -336,7 +336,7 @@ dhcpcd_daemonise(struct dhcpcd_ctx *ctx)
|
||||
#ifdef THERE_IS_NO_FORK
|
||||
eloop_timeout_delete(ctx->eloop, handle_exit_timeout, ctx);
|
||||
errno = ENOSYS;
|
||||
- return 0;
|
||||
+ return;
|
||||
#else
|
||||
int i;
|
||||
unsigned int logopts = loggetopts();
|
||||
@@ -2211,7 +2211,7 @@ printpidfile:
|
||||
ps_init(&ctx);
|
||||
#endif
|
||||
|
||||
-#ifdef USE_SIGNALS
|
||||
+#if defined(USE_SIGNALS) && !defined(THERE_IS_NO_FORK)
|
||||
if (pipe(sigpipe) == -1) {
|
||||
logerr("pipe");
|
||||
goto exit_failure;
|
||||
--
|
||||
2.27.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
# sha256 from ftp://roy.marples.name/pub/dhcpcd/dhcpcd-9.1.4.tar.xz.distinfo
|
||||
sha256 5fe133e5497d8af6d26bd6e6b8dd48ab12d124d6cc4cefe6de6536ff97f76820 dhcpcd-9.1.4.tar.xz
|
||||
# sha256 from ftp://roy.marples.name/pub/dhcpcd/dhcpcd-9.4.0.tar.xz.distinfo
|
||||
sha256 41a69297f380bf15ee8f94f73154f8c2bca7157a087c0d5aca8de000ba1d4513 dhcpcd-9.4.0.tar.xz
|
||||
# Locally calculated
|
||||
sha256 9cce1077bad23544349788ec750ec6e5aee106fc437fd6b5d73c0d8510426578 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
DHCPCD_VERSION = 9.1.4
|
||||
DHCPCD_VERSION = 9.4.0
|
||||
DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.xz
|
||||
DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd
|
||||
DHCPCD_DEPENDENCIES = host-pkgconf
|
||||
|
Loading…
Reference in New Issue
Block a user