diff --git a/scripts/pkg-stats b/scripts/pkg-stats
index 01af89de09..7bb292830b 100755
--- a/scripts/pkg-stats
+++ b/scripts/pkg-stats
@@ -51,8 +51,10 @@ tr.correct td {
Id |
Package |
+Patch count |
AUTOTARGETS |
GENTARGETS |
+CMAKETARGETS |
manual |
Actions |
@@ -63,22 +65,24 @@ tr.correct td {
target |
host |
target |
+host |
+target |
"
convert_to_generic_target=0
convert_to_generic_host=0
convert_to_autotools=0
+total_patch_count=0
cnt=1
for i in $(find package/ -name '*.mk') ; do
- if test $i = "package/mtd/mtd.mk" -o \
+ if test \
$i = "package/java/java.mk" -o \
- $i = "package/database/database.mk" -o \
- $i = "package/editors/editors.mk" -o \
$i = "package/games/games.mk" -o \
$i = "package/multimedia/multimedia.mk" -o \
$i = "package/customize/customize.mk" -o \
$i = "package/gnuconfig/gnuconfig.mk" -o \
+ $i = "package/matchbox/matchbox.mk" -o \
$i = "package/x11r7/x11r7.mk" ; then
echo "skipping $i" 1>&2
continue
@@ -88,6 +92,8 @@ for i in $(find package/ -name '*.mk') ; do
is_auto_host=0
is_auto_target=0
+ is_cmake_host=0
+ is_cmake_target=0
is_pkg_target=0
is_pkg_host=0
is_manual_target=0
@@ -109,6 +115,14 @@ for i in $(find package/ -name '*.mk') ; do
is_pkg_target=1
fi
+ if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ is_cmake_host=1
+ fi
+
+ if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ is_cmake_target=1
+ fi
+
pkg=$(basename $i)
pkg=${pkg%.mk}
@@ -116,7 +130,7 @@ for i in $(find package/ -name '*.mk') ; do
is_manual_host=1
fi
- if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 ; then
+ if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 -a $is_cmake_target -eq 0; then
is_manual_target=1
fi
@@ -151,6 +165,22 @@ for i in $(find package/ -name '*.mk') ; do
echo "$cnt | "
echo "$i | "
+ package_dir=$(dirname $i)
+ patch_count=$(find ${package_dir} -name '*.patch' | wc -l)
+ total_patch_count=$(($total_patch_count+$patch_count))
+
+ if test $patch_count -lt 1 ; then
+ patch_count_color="#00ff00"
+ elif test $patch_count -lt 5 ; then
+ patch_count_color="#ffc600"
+ else
+ patch_count_color="#ff0000"
+ fi
+
+ echo ""
+ echo $patch_count
+ echo " | "
+
echo ""
if [ $is_auto_host -eq 1 ] ; then
echo "YES"
@@ -183,6 +213,22 @@ for i in $(find package/ -name '*.mk') ; do
fi
echo " | "
+ echo ""
+ if [ $is_cmake_host -eq 1 ] ; then
+ echo "YES"
+ else
+ echo "NO"
+ fi
+ echo " | "
+
+ echo ""
+ if [ $is_cmake_target -eq 1 ] ; then
+ echo "YES"
+ else
+ echo "NO"
+ fi
+ echo " | "
+
echo ""
if [ $is_manual_host -eq 1 ] ; then
echo "YES"
@@ -228,6 +274,10 @@ echo " | Packages to convert to host autotools | "
echo "$convert_to_host_autotools | "
echo ""
echo ""
+echo "Number of patches in all packages | "
+echo "$total_patch_count | "
+echo "
"
+echo ""
echo "TOTAL | "
echo "$cnt | "
echo "
"