fakeroot: bump version, cleanup package

LFS patch is now upstream, and we don't support building fakeroot for the
target anyway.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Peter Korsgaard 2012-04-05 20:20:05 +02:00
parent f526c4d23c
commit 0c8244251e
3 changed files with 3 additions and 49 deletions

View File

@ -1,20 +0,0 @@
--- fakeroot/Makefile.am.orig 2006-04-19 11:50:35.000000000 -0600
+++ fakeroot/Makefile.am 2006-04-19 11:50:59.000000000 -0600
@@ -1,5 +1,5 @@
AUTOMAKE_OPTIONS=foreign
-SUBDIRS=scripts doc test
+SUBDIRS=scripts test
noinst_LTLIBRARIES = libcommunicate.la
libcommunicate_la_SOURCES = communicate.c
--- fakeroot/Makefile.in.orig 2006-04-19 11:50:43.000000000 -0600
+++ fakeroot/Makefile.in 2006-04-19 11:51:21.000000000 -0600
@@ -230,7 +230,7 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = scripts doc test
+SUBDIRS = scripts test
noinst_LTLIBRARIES = libcommunicate.la
libcommunicate_la_SOURCES = communicate.c
lib_LTLIBRARIES = libfakeroot.la

View File

@ -1,14 +0,0 @@
diff -urN fakeroot-1.9.3.orig/communicate.h fakeroot-1.9.3/communicate.h
--- fakeroot-1.9.3.orig/communicate.h 2008-03-11 09:42:05.000000000 -0400
+++ fakeroot-1.9.3/communicate.h 2008-03-11 10:58:10.000000000 -0400
@@ -35,7 +35,9 @@
#endif
/* Then decide whether we do or do not use the stat64 support */
-#if (defined(sun) && !defined(__SunOS_5_5_1) && !defined(_LP64)) || __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1)
+#if (defined(sun) && !defined(__SunOS_5_5_1) && !defined(_LP64)) \
+ || (!defined __UCLIBC__ && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1))) \
+ || (defined __UCLIBC__ && defined UCLIBC_HAS_LFS)
# define STAT64_SUPPORT
#else
# warning Not using stat64 support

View File

@ -3,20 +3,8 @@
# fakeroot
#
#############################################################
FAKEROOT_VERSION:=1.9.5
FAKEROOT_SOURCE:=fakeroot_$(FAKEROOT_VERSION).tar.gz
FAKEROOT_SITE:=http://snapshot.debian.org/archive/debian/20080427T000000Z/pool/main/f/fakeroot/
FAKEROOT_VERSION = 1.18.2
FAKEROOT_SOURCE = fakeroot_$(FAKEROOT_VERSION).orig.tar.bz2
FAKEROOT_SITE = http://snapshot.debian.org/archive/debian/20111201T093630Z/pool/main/f/fakeroot/
define FAKEROOT_PATCH_FAKEROOT_IN
# If using busybox getopt, make it be quiet.
$(SED) "s,getopt --version,getopt --version 2>/dev/null," \
$(@D)/scripts/fakeroot.in
endef
FAKEROOT_POST_PATCH_HOOKS += FAKEROOT_PATCH_FAKEROOT_IN
# The package for the target cannot be selected (build problems when
# largefile is enabled), but is needed for the host package to work
# due to deficiencies in the package infrastructure.
$(eval $(call AUTOTARGETS))
$(eval $(call AUTOTARGETS,host))