package/rtl8723ds: bump to 2022-12-01 version to fix build issue
Drop local patch that has been upstreamed. Fixes: http://autobuild.buildroot.net/results/fa2/fa2482674d789e7674dc0d83c5f54393beed4d70/ Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
1ad6bc2f58
commit
0c6d4d7be8
@ -1,39 +0,0 @@
|
|||||||
From 769a1943cb409f89f3c91208294a89b09bf47b86 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
|
||||||
Date: Wed, 16 Nov 2022 16:08:21 +0100
|
|
||||||
Subject: [PATCH] Makefile: move 'EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)' at the
|
|
||||||
end of EXTRA_FLAGS assignment
|
|
||||||
|
|
||||||
At the moment USER_EXTRA_CFLAGS can't override local Makfile EXTRA_CFLAGS
|
|
||||||
since it's assigned at the beginning of the Makefile. For example it's not
|
|
||||||
possible to undefine the hardcoded CONFIG_LITTLE_ENDIAN and this doesn't
|
|
||||||
allow to build these modules for big endian architectures. So let's move
|
|
||||||
the assignment of USER_EXTRA_CFLAGS to EXTRA_CFLAGS after the last
|
|
||||||
EXTRA_CFLAGS assignment.
|
|
||||||
|
|
||||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
|
||||||
---
|
|
||||||
Makefile | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index aa57f85..3d91574 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -1,4 +1,3 @@
|
|
||||||
-EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
|
|
||||||
EXTRA_CFLAGS += -O1
|
|
||||||
#EXTRA_CFLAGS += -O3
|
|
||||||
#EXTRA_CFLAGS += -Wall
|
|
||||||
@@ -1738,6 +1737,8 @@ ifneq ($(USER_MODULE_NAME),)
|
|
||||||
MODULE_NAME := $(USER_MODULE_NAME)
|
|
||||||
endif
|
|
||||||
|
|
||||||
+EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
|
|
||||||
+
|
|
||||||
ifneq ($(KERNELRELEASE),)
|
|
||||||
|
|
||||||
rtk_core := core/rtw_cmd.o \
|
|
||||||
--
|
|
||||||
2.34.1
|
|
||||||
|
|
@ -1,2 +1,2 @@
|
|||||||
# Locally computed
|
# Locally computed
|
||||||
sha256 691040a85d838f8d8d7da0f2ed460f1ea5f6734c40dc73770ba7e260b6cda9cc rtl8723ds-5ab2d3f3858dc4c833013c47a79faa05b10198f6.tar.gz
|
sha256 97f3ebc5d977ba35d10c9c06e6817e4a00458727b651b56fc00c207c05a61995 rtl8723ds-a638cc8639015b8b9390af3350fab0366b6c87e7.tar.gz
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
RTL8723DS_VERSION = 5ab2d3f3858dc4c833013c47a79faa05b10198f6
|
RTL8723DS_VERSION = a638cc8639015b8b9390af3350fab0366b6c87e7
|
||||||
RTL8723DS_SITE = $(call github,lwfinger,rtl8723ds,$(RTL8723DS_VERSION))
|
RTL8723DS_SITE = $(call github,lwfinger,rtl8723ds,$(RTL8723DS_VERSION))
|
||||||
RTL8723DS_LICENSE = GPL-2.0
|
RTL8723DS_LICENSE = GPL-2.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user