libmemcached: disable libtest
This allows libmemcached to be enabled for musl and uClibc as well. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
ad4a90617c
commit
0be26ad401
@ -2,7 +2,6 @@ config BR2_PACKAGE_LIBMEMCACHED
|
|||||||
bool "libmemcached"
|
bool "libmemcached"
|
||||||
depends on BR2_INSTALL_LIBSTDCPP
|
depends on BR2_INSTALL_LIBSTDCPP
|
||||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||||
depends on BR2_TOOLCHAIN_USES_GLIBC # posix spawn, va_list breakage
|
|
||||||
help
|
help
|
||||||
libMemcached is an open source C/C++ client library and tools
|
libMemcached is an open source C/C++ client library and tools
|
||||||
for the memcached server.
|
for the memcached server.
|
||||||
@ -11,6 +10,5 @@ config BR2_PACKAGE_LIBMEMCACHED
|
|||||||
|
|
||||||
http://libmemcached.org/libMemcached.html
|
http://libmemcached.org/libMemcached.html
|
||||||
|
|
||||||
comment "libmemcached needs a (e)glibc toolchain w/ C++, threads"
|
comment "libmemcached needs a toolchain w/ C++, threads"
|
||||||
depends on !BR2_TOOLCHAIN_USES_GLIBC \
|
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
|
||||||
|| !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
|
|
||||||
|
@ -4,9 +4,26 @@ with extra dependencies.
|
|||||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||||
|
|
||||||
diff -Nura libmemcached-1.0.18.orig/Makefile.am libmemcached-1.0.18/Makefile.am
|
diff -Nura libmemcached-1.0.18.orig/Makefile.am libmemcached-1.0.18/Makefile.am
|
||||||
--- libmemcached-1.0.18.orig/Makefile.am 2014-07-19 08:43:15.127031040 -0300
|
--- libmemcached-1.0.18.orig/Makefile.am 2014-07-19 09:24:45.246418899 -0300
|
||||||
+++ libmemcached-1.0.18/Makefile.am 2014-07-19 08:48:11.327068987 -0300
|
+++ libmemcached-1.0.18/Makefile.am 2014-07-19 09:25:12.701349345 -0300
|
||||||
@@ -76,7 +76,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
|
# vim:ft=automake
|
||||||
|
|
||||||
|
-ACLOCAL_AMFLAGS= -I m4 -I libtest/m4
|
||||||
|
+ACLOCAL_AMFLAGS= -I m4
|
||||||
|
AM_YFLAGS= -d
|
||||||
|
|
||||||
|
# includes append to these:
|
||||||
|
@@ -45,8 +45,6 @@
|
||||||
|
include libmemcached-1.0/include.am
|
||||||
|
else
|
||||||
|
|
||||||
|
-include libtest/include.am
|
||||||
|
-
|
||||||
|
include libhashkit-1.0/include.am
|
||||||
|
include libmemcached-1.0/include.am
|
||||||
|
|
||||||
|
@@ -76,7 +74,6 @@
|
||||||
include libmemcachedinternal/util/include.am
|
include libmemcachedinternal/util/include.am
|
||||||
include rpm/include.mk
|
include rpm/include.mk
|
||||||
include support/include.am
|
include support/include.am
|
||||||
@ -14,3 +31,12 @@ diff -Nura libmemcached-1.0.18.orig/Makefile.am libmemcached-1.0.18/Makefile.am
|
|||||||
include util/include.am
|
include util/include.am
|
||||||
include win32/include.am
|
include win32/include.am
|
||||||
|
|
||||||
|
@@ -103,7 +100,7 @@
|
||||||
|
@echo "Files that need to be either removed or checked in:"
|
||||||
|
@bzr unknowns
|
||||||
|
|
||||||
|
-clean-local: clean-libtest-check clean-docs-check clean-rpm
|
||||||
|
+clean-local: clean-docs-check clean-rpm
|
||||||
|
|
||||||
|
|
||||||
|
lcov: lcov-clean check
|
||||||
|
@ -2,7 +2,6 @@ config BR2_PACKAGE_PHP_MEMCACHED
|
|||||||
bool "php-memcached"
|
bool "php-memcached"
|
||||||
depends on BR2_INSTALL_LIBSTDCPP # libmemcached
|
depends on BR2_INSTALL_LIBSTDCPP # libmemcached
|
||||||
depends on BR2_TOOLCHAIN_HAS_THREADS # libmemcached
|
depends on BR2_TOOLCHAIN_HAS_THREADS # libmemcached
|
||||||
depends on BR2_TOOLCHAIN_USES_GLIBC # libmemcached
|
|
||||||
select BR2_PACKAGE_PHP_EXT_SESSION
|
select BR2_PACKAGE_PHP_EXT_SESSION
|
||||||
select BR2_PACKAGE_LIBMEMCACHED
|
select BR2_PACKAGE_LIBMEMCACHED
|
||||||
select BR2_PACKAGE_ZLIB
|
select BR2_PACKAGE_ZLIB
|
||||||
@ -12,6 +11,5 @@ config BR2_PACKAGE_PHP_MEMCACHED
|
|||||||
|
|
||||||
http://pecl.php.net/package/memcached
|
http://pecl.php.net/package/memcached
|
||||||
|
|
||||||
comment "php-memcached needs a (e)glibc toolchain w/ C++, threads"
|
comment "php-memcached needs a toolchain w/ C++, threads"
|
||||||
depends on !BR2_TOOLCHAIN_USES_GLIBC \
|
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
|
||||||
|| !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
|
|
||||||
|
Loading…
Reference in New Issue
Block a user