liburcu: Add support for aarch64

Bring over a patch from OpenEmbedded to treat aarch64 like arm in the build
process, which allows the build to succeed.

Signed-off-by: Ben Shelton <benjamin.h.shelton@intel.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Ben Shelton 2015-09-15 09:35:18 -05:00 committed by Thomas Petazzoni
parent 8a38963e26
commit 0ae594247b
3 changed files with 24 additions and 2 deletions

View File

@ -0,0 +1,21 @@
libucru: recognize aarch64
Make the same as "arm" internally.
Upstream-Status: Pending
Signed-off-by: joe.slater@windriver.com
[moved to buildroot from openembedded-core]
Signed-off-by: Ben Shelton <benjamin.h.shelton@intel.com>
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,7 @@ AS_CASE([$host_cpu],
[alpha*], [ARCHTYPE="alpha"],
[ia64], [ARCHTYPE="gcc"],
[arm*], [ARCHTYPE="arm"],
+ [aarch64], [ARCHTYPE="arm"],
[mips*], [ARCHTYPE="mips"],
[tile*], [ARCHTYPE="gcc"],
[ARCHTYPE="unknown"]

View File

@ -1,6 +1,6 @@
config BR2_PACKAGE_LIBURCU config BR2_PACKAGE_LIBURCU
bool "liburcu" bool "liburcu"
depends on BR2_arm || BR2_armeb || BR2_i386 || BR2_powerpc || BR2_x86_64 depends on BR2_arm || BR2_armeb || BR2_aarch64 || BR2_i386 || BR2_powerpc || BR2_x86_64
depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_58854 # liburcu/gcc-4.8.x bug depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_58854 # liburcu/gcc-4.8.x bug
depends on BR2_TOOLCHAIN_HAS_THREADS depends on BR2_TOOLCHAIN_HAS_THREADS
help help
@ -18,7 +18,7 @@ config BR2_PACKAGE_LIBURCU
http://lttng.org/urcu http://lttng.org/urcu
comment "liburcu needs a toolchain w/ threads" comment "liburcu needs a toolchain w/ threads"
depends on BR2_arm || BR2_armeb || BR2_i386 || BR2_powerpc || BR2_x86_64 depends on BR2_arm || BR2_armeb || BR2_aarch64 || BR2_i386 || BR2_powerpc || BR2_x86_64
depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_58854 # liburcu/gcc-4.8.x bug depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_58854 # liburcu/gcc-4.8.x bug
depends on !BR2_TOOLCHAIN_HAS_THREADS depends on !BR2_TOOLCHAIN_HAS_THREADS

View File

@ -10,6 +10,7 @@ LIBURCU_SOURCE = userspace-rcu-$(LIBURCU_VERSION).tar.bz2
LIBURCU_LICENSE = LGPLv2.1+ for the library; MIT-like license for few source files listed in LICENSE; GPLv2+ for test; GPLv3 for few *.m4 files LIBURCU_LICENSE = LGPLv2.1+ for the library; MIT-like license for few source files listed in LICENSE; GPLv2+ for test; GPLv3 for few *.m4 files
LIBURCU_LICENSE_FILES = lgpl-2.1.txt lgpl-relicensing.txt gpl-2.0.txt LICENSE LIBURCU_LICENSE_FILES = lgpl-2.1.txt lgpl-relicensing.txt gpl-2.0.txt LICENSE
LIBURCU_AUTORECONF = YES
LIBURCU_INSTALL_STAGING = YES LIBURCU_INSTALL_STAGING = YES
$(eval $(autotools-package)) $(eval $(autotools-package))