diff --git a/CHANGES b/CHANGES index 67305f9c21..e93d1116a7 100644 --- a/CHANGES +++ b/CHANGES @@ -21,6 +21,7 @@ #765: Add buildroot branding to gcc #767: Bump iw package to 0.9.18 #773: [SECURITY] Update bind to 9.5.2-P1 + #795: Minor edits to fix typos, grammar, spelling, usage in documen... 2009.11, Released December 1st, 2009: diff --git a/docs/buildroot.html b/docs/buildroot.html index c4f191a355..0d254b6195 100644 --- a/docs/buildroot.html +++ b/docs/buildroot.html @@ -46,17 +46,17 @@

About Buildroot

-

Buildroot is a set of Makefiles and patches that allow to +

Buildroot is a set of Makefiles and patches that allows you to easily generate a cross-compilation toolchain, a root filesystem and a Linux kernel image for your target. Buildroot can be used - for either one, two or all of these options, independently.

+ for one, two or all of these options, independently.

Buildroot is useful mainly for people working with embedded systems. Embedded systems often use processors that are not the regular x86 - processors everyone is used to have on his PC. It can be PowerPC + processors everyone is used to having in his PC. They can be PowerPC processors, MIPS processors, ARM processors, etc.

-

A compilation toolchain is the set of tools that allows to +

A compilation toolchain is the set of tools that allows you to compile code for your system. It consists of a compiler (in our case, gcc), binary utils like assembler and linker (in our case, binutils) and a C standard library (for @@ -64,55 +64,57 @@ Libc, uClibc or dietlibc). The system installed on your development station certainly already has a - compilation toolchain that you can use to compile application that + compilation toolchain that you can use to compile an application that runs on your system. If you're using a PC, your compilation - toolchain runs on an x86 processor and generates code for a x86 + toolchain runs on an x86 processor and generates code for an x86 processor. Under most Linux systems, the compilation toolchain - uses the GNU libc as C standard library. This compilation - toolchain is called the "host compilation toolchain", and more - generally, the machine on which it is running, and on which you're - working is called the "host system". The compilation toolchain + uses the GNU libc (glibc) as the C standard library. This compilation + toolchain is called the "host compilation toolchain". + The machine on which it is running, and on which you're + working, is called the "host system". The compilation toolchain is provided by your distribution, and Buildroot has nothing to do - with it.

+ with it (other than using it to build a cross-compilation toolchain + and other tools that are run on the development host).

As said above, the compilation toolchain that comes with your system - runs and generates code for the processor of your host system. As your + runs on and generates code for the processor in your host system. As your embedded system has a different processor, you need a cross-compilation - toolchain: it's a compilation toolchain that runs on your host system but - that generates code for your target system (and target processor). For + toolchain — a compilation toolchain that runs on your host system but + generates code for your target system (and target processor). For example, if your host system uses x86 and your target system uses ARM, the - regular compilation toolchain of your host runs on x86 and generates code + regular compilation toolchain on your host runs on x86 and generates code for x86, while the cross-compilation toolchain runs on x86 and generates code for ARM.

-

Even if your embedded system uses a x86 processor, you might interested - in Buildroot, for two reasons:

+

Even if your embedded system uses an x86 processor, you might be interested + in Buildroot for two reasons:

You might wonder why such a tool is needed when you can compile - gcc, binutils, uClibc and all the tools by hand. - Of course, doing so is possible. But dealing with all configure options, - with all problems of every gcc or binutils - version it very time-consuming and uninteresting. Buildroot automates this - process through the use of Makefiles, and has a collection of patches for + gcc, binutils, uClibc and all + the other tools by hand. + Of course doing so is possible. But, dealing with all of the configure options + and problems of every gcc or binutils + version is very time-consuming and uninteresting. Buildroot automates this + process through the use of Makefiles and has a collection of patches for each gcc and binutils version to make them work on most architectures.

Moreover, Buildroot provides an infrastructure for reproducing - the build process of your embedded root filesystem. Being able to + the build process of your kernel, cross-toolchain, and embedded root filesystem. Being able to reproduce the build process will be useful when a component needs - to be patched or updated, or when another person is supposed to + to be patched or updated or when another person is supposed to take over the project.

Obtaining Buildroot

@@ -129,12 +131,12 @@ and previous snapshots are also available at http://buildroot.net/downloads/snapshots/.

-

To download Buildroot using Git, you can simply follow - the rules described on the "Accessing Git"-page (To download Buildroot using Git you can simply follow + the rules described on the "Accessing Git" page (http://buildroot.net/git.html) of the Buildroot website (http://buildroot.net), and download - buildroot from Git. For the impatient, here's a quick + "http://buildroot.net">http://buildroot.net). + For the impatient, here's a quick recipe:

@@ -144,10 +146,10 @@
     

Using Buildroot

Buildroot has a nice configuration tool similar to the one you can find - in the Linux Kernel (http://www.kernel.org/) or in Busybox (http://www.busybox.org/). Note that - you can build everything as a normal user. There is no need to be root to + you can (and should) build everything as a normal user. There is no need to be root to configure and use Buildroot. The first step is to run the configuration assistant:

@@ -161,15 +163,20 @@ $ make xconfig
-

to run the Qt3-based configurator. On Debian-like systems, the +

to run the Qt3-based configurator.

+ +

Both of these "make" commands will need to build a configuration + utility, so you may need to install "development" packages for + relevent libraries used by the configuration utilities. + On Debian-like systems, the libncurses5-dev package is required to use the menuconfig interface, and the libqt3-mt-dev is required to use the xconfig interface.

-

For each entry of the configuration tool, you can find associated help +

For each menu entry in the configuration tool, you can find associated help that describes the purpose of the entry.

-

Once everything is configured, the configuration tool has generated a +

Once everything is configured, the configuration tool generates a .config file that contains the description of your configuration. It will be used by the Makefiles to do what's needed.

@@ -179,11 +186,18 @@
  $ make
 
- -

This command will download, configure and compile all the - selected tools, and finally generate a toolchain, a root - filesystem image and a kernel image (or only one of these - elements, depending on the configuration).

+

This command will generally perform the following steps:

+ +

Some of the above steps might not be performed if they are not + selected in the Buildroot configuration. +

Buildroot output is stored in a single directory, output/. This directory contains several @@ -194,19 +208,19 @@

  • images/ where all the images (kernel image, bootloader and root filesystem images) are stored.
  • -
  • build/ where all the components are built - (tools needed to run Buildroot on the host and packages compiled +
  • build/ where all the components except for the + cross-compilation toolchain are built + (this includes tools needed to run Buildroot on the host and packages compiled for the target). The build/ directory contains one - subdirectory for each of these components. The toolchain - components are however built in a separate directory.
  • + subdirectory for each of these components.
  • staging/ which contains a hierarchy similar to a root filesystem hierarchy. This directory contains the - installation of cross-compilation toolchain and all the + installation of the cross-compilation toolchain and all the userspace packages selected for the target. However, this directory is not intended to be the root filesystem for the target: it contains a lot of development files, unstripped - binaries and libraries, that make it far too big for an embedded + binaries and libraries that make it far too big for an embedded system.
  • target/ which contains almost the root @@ -214,18 +228,19 @@ the device files in /dev/ (Buildroot can't create them because Buildroot doesn't run as root and does not want to run as root). Therefore, this directory should not be used on - your target but instead you should use one of the images + your target. Instead, you should use one of the images built in the images/ directory. If you need an - extracted image of the root filesystem, for booting over NFS, + extracted image of the root filesystem for booting over NFS, then use the tarball image generated in images/ and extract it as root.
    Compared to staging/, - target/ contains only the necessary files to run - the libraries and applications: all the development files + target/ contains only the files and libraries needed + to run the selected target applications: the development files (headers, etc.) are not present.
  • host/ contains the installation of tools compiled for the host that are needed for the proper execution - of Buildroot.
  • + of Buildroot except for the cross-compilation toolchain which is + installed under staging/.
  • toolchain/ contains the build directories for the various components of the cross-compilation toolchain.
  • @@ -235,9 +250,9 @@

    Offline builds

    -

    If you intend to do an offline-build and just want to download +

    If you intend to do an offline build and just want to download all sources that you previously selected in the configurator - (menuconfig or xconfig) then issue:

    + (menuconfig or xconfig), then issue:

      $ make source
     
    @@ -249,31 +264,31 @@

    Buildroot supports building out of tree with a syntax similar to the Linux kernel. To use it, add O=<directory> to the - make command line, E.G.:

    + make command line:

      $ make O=/tmp/build
     
    -

    And all the output files will be located under +

    All the output files will be located under /tmp/build.

    Environment variables

    -

    Buildroot optionally honors some environment variables that are passed - to make :

    +

    Buildroot also honors some environment variables when they are passed + to make:

    @@ -773,8 +775,8 @@ according to your cross-compiling toolchain.

    To generate external toolchains, we recommend using Crosstool-NG. -It allows to generate toolchains based on uClibc, glibc -and eglibc for a wide range of architectures, and has good +It allows generating toolchains based on uClibc, glibc +and eglibc for a wide range of architectures and has good community support.

    Extending Buildroot with @@ -791,9 +793,9 @@ community support.

    Config.in file

    Then, create a file named Config.in. This file - will contain the portion of options description related to our + will contain the option descriptions related to our foo software that will be used and displayed in the - configuration tool. It should basically contain :

    + configuration tool. It should basically contain:

     config BR2_PACKAGE_FOO
    @@ -817,24 +819,24 @@ source "package/procps/Config.in"
        Generally all packages should live directly in the
        package directory to make it easier to find them.
        

    -

    The real Makefile

    +

    The real Makefile

    Finally, here's the hardest part. Create a file named - foo.mk. It will contain the Makefile rules that + foo.mk. It will contain the Makefile rules that are in charge of downloading, configuring, compiling and installing the software.

    -

    Two types of Makefiles can be written :

    +

    Two types of Makefiles can be written :

    • Makefiles for autotools-based (autoconf, automake, etc.) - softwares, are very easy to write thanks to the infrastructure + software are very easy to write thanks to the infrastructure available in package/Makefile.autotools.in.
    • Makefiles for other types of packages are a little bit more complex to write.
    -

    First, let's see how to write a Makefile for an +

    First, let's see how to write a Makefile for an autotools-based package, with an example :

    @@ -854,9 +856,9 @@ source "package/procps/Config.in"
     

    On line 6, we declare the version of - the package. On line 7 and 7 and 8, we declare the name of the tarball and the - location of the tarball on the Web. Buildroot will automatically + location of the tarball on the web. Buildroot will automatically download the tarball from this location.

    On line 9, we tell Buildroot to install @@ -869,18 +871,18 @@ source "package/procps/Config.in"

    On line 10, we tell Buildroot to also install the application to the target directory. This directory contains what will become the root filesystem running on the - target. Usually, we try not to install the documentation, and to - install stripped versions of the binary. By default, packages are + target. Usually, we try to install stripped binaries and + to not install the documentation. By default, packages are installed in this location using the make install-strip command.

    On line 11, we tell Buildroot to pass - a custom configure option, that will be passed to the - ./configure script before configuring and building + a custom configure option to the + ./configure script when configuring the the package.

    On line 12, we declare our - dependencies, so that they are built before the build process of + dependencies so that they are built before the build process of our package starts.

    Finally, on line line 13, we invoke @@ -958,92 +960,93 @@ source "package/procps/Config.in"

    -

    First of all, this Makefile example works for a single - binary software. For other software such as libraries or more - complex stuff with multiple binaries, it should be adapted. Look at +

    First of all, this Makefile example works for a package which comprises a single + binary executable. For other software, such as libraries or more + complex stuff with multiple binaries, it must be adapted. For examples look at the other *.mk files in the package directory.

    At lines 6-11, a couple of useful variables are - defined :

    + defined:

    -

    Lines 13-14 defines a target that downloads the +

    Lines 13-14 define a target that downloads the tarball from the remote site to the download directory (DL_DIR).

    -

    Lines 16-18 defines a target and associated rules +

    Lines 16-18 define a target and associated rules that uncompress the downloaded tarball. As you can see, this target - depends on the tarball file, so that the previous target (line + depends on the tarball file so that the previous target (lines 13-14) is called before executing the rules of the current target. Uncompressing is followed by touching a hidden file - to mark the software has having been uncompressed. This trick is - used everywhere in Buildroot Makefile to split steps + to mark the software as having been uncompressed. This trick is + used everywhere in a Buildroot Makefile to split steps (download, uncompress, configure, compile, install) while still having correct dependencies.

    -

    Lines 20-31 defines a target and associated rules - that configures the software. It depends on the previous target (the +

    Lines 20-31 define a target and associated rules + that configure the software. It depends on the previous target (the hidden .source file) so that we are sure the software has - been uncompressed. In order to configure it, it basically runs the + been uncompressed. In order to configure the package, it basically runs the well-known ./configure script. As we may be doing cross-compilation, target, host and build arguments are given. The prefix is also set to /usr, not because the software will be installed in - /usr on your host system, but in the target + /usr on your host system, but because the software will + bin installed in /usr on the target filesystem. Finally it creates a .configured file to mark the software as configured.

    -

    Lines 33-34 defines a target and a rule that - compiles the software. This target will create the binary file in the - compilation directory, and depends on the software being already +

    Lines 33-34 define a target and a rule that + compile the software. This target will create the binary file in the + compilation directory and depends on the software being already configured (hence the reference to the .configured file). It basically runs make inside the source directory.

    -

    Lines 36-38 defines a target and associated rules - that install the software inside the target filesystem. It depends on the - binary file in the source directory, to make sure the software has - been compiled. It uses the install-strip target of the +

    Lines 36-38 define a target and associated rules + that install the software inside the target filesystem. They depend on the + binary file in the source directory to make sure the software has + been compiled. They use the install-strip target of the software Makefile by passing a DESTDIR - argument, so that the Makefile doesn't try to install - the software inside host /usr but inside target + argument so that the Makefile doesn't try to install + the software in the host /usr but rather in the target /usr. After the installation, the /usr/man directory inside the target filesystem is removed to save space.

    -

    Line 40 defines the main target of the software, +

    Line 40 defines the main target of the software — the one that will be eventually be used by the top level Makefile to download, compile, and then install - this package. This target should first of all depends on all - needed dependecies of the software (in our example, - uclibc and ncurses), and also depend on the + this package. This target should first of all depend on all + needed dependencies of the software (in our example, + uclibc and ncurses) and also depend on the final binary. This last dependency will call all previous dependencies in the correct order.

    @@ -1056,7 +1059,7 @@ source "package/procps/Config.in" if all package-sources are downloadable.

    Lines 44-46 define a simple target to clean the - software build by calling the Makefiles with the appropriate option. + software build by calling the Makefiles with the appropriate option. The -clean target should run make clean on $(BUILD_DIR)/package-version and MUST uninstall all files of the package from $(STAGING_DIR) and from $(TARGET_DIR).

    @@ -1066,11 +1069,11 @@ source "package/procps/Config.in" compiled. The -dirclean target MUST completely rm $(BUILD_DIR)/ package-version.

    -

    Lines 51-58 adds the target foo to +

    Lines 51-58 add the target foo to the list of targets to be compiled by Buildroot by first checking if the configuration option for this package has been enabled - using the configuration tool, and if so then "subscribes" - this package to be compiled by adding it to the TARGETS + using the configuration tool. If so, it then "subscribes" + this package to be compiled by adding the package to the TARGETS global variable. The name added to the TARGETS global variable is the name of this package's target, as defined on line 40, which is used by Buildroot to download, @@ -1079,13 +1082,13 @@ source "package/procps/Config.in"

    Conclusion

    -

    As you can see, adding a software to buildroot is simply a - matter of writing a Makefile using an already existing - example and to modify it according to the compilation process of - the software.

    +

    As you can see, adding a software package to Buildroot is simply a + matter of writing a Makefile using an existing + example and modifying it according to the compilation process required by + the package.

    -

    If you package software that might be useful for other persons, - don't forget to send a patch to Buildroot developers !

    +

    If you package software that might be useful for other people, + don't forget to send a patch to Buildroot developers!

    Resources