package/irqbalance: bump to version 1.9.0

Drop patch (not needed since
bc16d7d4d5)

https://github.com/Irqbalance/irqbalance/releases/tag/v1.9.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2022-06-23 20:02:53 +02:00 committed by Peter Korsgaard
parent df27a9daa6
commit 094b545270
3 changed files with 2 additions and 40 deletions

View File

@ -1,38 +0,0 @@
From 274cb8ea470a10ce46b783e77784b0eb08cf20d8 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 1 Aug 2021 23:26:01 +0200
Subject: [PATCH] configure.ac: use pkg-config to find numa
Use pkg-config to find numa and fallback to current mechanism.
Thanks to pkg-config, numa dependencies such as -latomic will be
retrieved.
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/Irqbalance/irqbalance/pull/188]
---
configure.ac | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index c45b9ce..50c62ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,14 @@ AC_CHECK_HEADERS([numa.h])
AC_CHECK_FUNCS(getopt_long)
-AC_CHECK_LIB(numa, numa_available)
+PKG_CHECK_MODULES([NUMA], [numa], [has_numa=yes], [AC_CHECK_LIB(numa, numa_available)])
+AS_IF([test "x$has_numa" = "xyes"], [
+ AC_SUBST([NUMA_CFLAGS])
+ AC_SUBST([NUMA_LIBS])
+ LIBS="$LIBS $NUMA_LIBS"
+ AC_SUBST([LIBS])
+])
+
AC_CHECK_LIB(m, floor)
PKG_CHECK_MODULES([GLIB2], [glib-2.0], [], [AC_MSG_ERROR([glib-2.0 is required])])
--
2.30.2

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 2e7ddb9687a6a5cc1f41626659eac2ad9d6b5875629156b92f693bd404d8ae63 irqbalance-1.8.0.tar.gz
sha256 883d3f6296f7e4a17e09dc2c91bd972e110fe574c119d9e45ec0c4e35c7317bb irqbalance-1.9.0.tar.gz
sha256 32b1062f7da84967e7019d01ab805935caa7ab7321a7ced0e30ebe75e5df1670 COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
IRQBALANCE_VERSION = 1.8.0
IRQBALANCE_VERSION = 1.9.0
IRQBALANCE_SITE = $(call github,irqbalance,irqbalance,v$(IRQBALANCE_VERSION))
IRQBALANCE_LICENSE = GPL-2.0
IRQBALANCE_LICENSE_FILES = COPYING