boot/at91dataflashboot: remove package
At91dataflashboot is an ancient (2006) fork of at91bootstrap1 specifically for the Atmel/Microchip AT45 series (dataflash) of serial flashes. The package hasn't seen any meaningful updates since, is not used by any defconfigs and at91bootstrap3 nowadays has AT45 support - So remove the package. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> [yann.morin.1998@free.fr: update .checkpackageignore] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
d9d4be3ca5
commit
08bd2bc482
@ -96,8 +96,6 @@ board/toradex/apalis-imx6/post-image.sh Shellcheck
|
||||
board/udoo/common/post-build.sh Shellcheck
|
||||
board/udoo/mx6qdl/patches/linux/0000-udoo-disable-usbh1.patch lib_patch.Upstream
|
||||
boot/afboot-stm32/0003-Makefile-disable-stack-protector.patch lib_patch.Upstream
|
||||
boot/at91dataflashboot/0001-do-not-install.patch lib_patch.Upstream
|
||||
boot/at91dataflashboot/0002-eabi-fixes.patch lib_patch.Upstream
|
||||
boot/optee-os/3.13.0/0001-core-zlib-fix-build-warning-when-_LFS64_LARGEFILE-is.patch lib_patch.Upstream
|
||||
boot/syslinux/0001-bios-Fix-alignment-change-with-gcc-5.patch lib_patch.Upstream
|
||||
boot/syslinux/0002-Disable-PIE-to-avoid-FTBFS-on-amd64.patch lib_patch.Upstream
|
||||
|
@ -153,6 +153,12 @@ config BR2_TARGET_AT91BOOTSTRAP
|
||||
Upstream for at91bootstrap 1.x is no longer available and
|
||||
has been replaced by at91bootstrap3.
|
||||
|
||||
config BR2_TARGET_AT91DATAFLASHBOOT
|
||||
bool "at91dataflashboot removed"
|
||||
select BR2_LEGACY
|
||||
help
|
||||
at91dataflashboot has been replaced by at91bootstrap3.
|
||||
|
||||
config BR2_PACKAGE_ON2_8170_MODULES
|
||||
bool "on2-8170-modules removed"
|
||||
select BR2_LEGACY
|
||||
|
@ -2,7 +2,6 @@ menu "Bootloaders"
|
||||
|
||||
source "boot/afboot-stm32/Config.in"
|
||||
source "boot/at91bootstrap3/Config.in"
|
||||
source "boot/at91dataflashboot/Config.in"
|
||||
source "boot/arm-trusted-firmware/Config.in"
|
||||
source "boot/barebox/Config.in"
|
||||
source "boot/beaglev-ddrinit/Config.in"
|
||||
|
@ -1,22 +0,0 @@
|
||||
Disable the automatic installation of at91dataflashboot since it tries
|
||||
to install things to /tftpboot, which is not possible when not
|
||||
building as root.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: at91dataflashboot-1.05/Makefile
|
||||
===================================================================
|
||||
--- at91dataflashboot-1.05.orig/Makefile
|
||||
+++ at91dataflashboot-1.05/Makefile
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
I=config.h com.h dataflash.h embedded_services.h main.h stdio.h include/AT91RM9200.h include/lib_AT91RM9200.h
|
||||
|
||||
-all: clean $(BINNAME) $(LSSNAME) install
|
||||
+all: clean $(BINNAME) $(LSSNAME)
|
||||
$(SIZE) $(OUTNAME)
|
||||
|
||||
# C objects here
|
@ -1,43 +0,0 @@
|
||||
Get at91dataflashboot to build with EABI toolchains, by providing the
|
||||
__aeabi_uidiv and __aeabi_uidivmod symbols. The code is based on
|
||||
U-Boot's code.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
_udivsi3.S | 14 ++++++++++++++
|
||||
1 file changed, 14 insertions(+)
|
||||
|
||||
Index: DataflashBoot-1.05/_udivsi3.S
|
||||
===================================================================
|
||||
--- DataflashBoot-1.05.orig/_udivsi3.S
|
||||
+++ DataflashBoot-1.05/_udivsi3.S
|
||||
@@ -12,8 +12,11 @@
|
||||
.text
|
||||
.globl __udivsi3
|
||||
.type __udivsi3 ,function
|
||||
+ .globl __aeabi_uidiv
|
||||
+ .type __aeabi_uidiv ,function
|
||||
.align 0
|
||||
__udivsi3 :
|
||||
+ __aeabi_uidiv:
|
||||
cmp divisor, #0
|
||||
beq Ldiv0
|
||||
mov curbit, #1
|
||||
@@ -68,6 +71,17 @@
|
||||
mov r0, #0 @ about as wrong as it could be
|
||||
ldmia sp!, {pc}
|
||||
.size __udivsi3 , . - __udivsi3
|
||||
+
|
||||
+.globl __aeabi_uidivmod
|
||||
+__aeabi_uidivmod:
|
||||
+
|
||||
+ stmfd sp!, {r0, r1, ip, lr}
|
||||
+ bl __aeabi_uidiv
|
||||
+ ldmfd sp!, {r1, r2, ip, lr}
|
||||
+ mul r3, r0, r2
|
||||
+ sub r1, r1, r3
|
||||
+ mov pc, lr
|
||||
+
|
||||
/* # 235 "libgcc1.S" */
|
||||
/* # 320 "libgcc1.S" */
|
||||
/* # 421 "libgcc1.S" */
|
@ -1,3 +0,0 @@
|
||||
config BR2_TARGET_AT91DATAFLASHBOOT
|
||||
bool "AT91 DataFlashBoot"
|
||||
depends on BR2_arm && BR2_arm926t
|
@ -1,2 +0,0 @@
|
||||
# locally computed
|
||||
sha256 2cfeb6a9236e1a743c8010f05e504dbc92169ef42d9a6cf7948954a577bfc386 DataflashBoot-1.05.tar.bz2
|
@ -1,28 +0,0 @@
|
||||
################################################################################
|
||||
#
|
||||
# at91dataflashboot
|
||||
#
|
||||
################################################################################
|
||||
|
||||
AT91DATAFLASHBOOT_VERSION = 1.05
|
||||
AT91DATAFLASHBOOT_SOURCE = DataflashBoot-$(AT91DATAFLASHBOOT_VERSION).tar.bz2
|
||||
AT91DATAFLASHBOOT_SITE = ftp://www.at91.com/pub/buildroot
|
||||
|
||||
AT91DATAFLASHBOOT_INSTALL_TARGET = NO
|
||||
AT91DATAFLASHBOOT_INSTALL_IMAGES = YES
|
||||
|
||||
AT91DATAFLASHBOOT_CFLAGS = $(TARGET_CFLAGS) -fno-stack-protector
|
||||
ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
|
||||
AT91DATAFLASHBOOT_CFLAGS += -marm
|
||||
endif
|
||||
|
||||
define AT91DATAFLASHBOOT_BUILD_CMDS
|
||||
make -C $(@D) CROSS_COMPILE=$(TARGET_CROSS) \
|
||||
CFLAGS="$(AT91DATAFLASHBOOT_CFLAGS)"
|
||||
endef
|
||||
|
||||
define AT91DATAFLASHBOOT_INSTALL_IMAGES_CMDS
|
||||
cp $(@D)/DataflashBoot-$(AT91DATAFLASHBOOT_VERSION).bin $(BINARIES_DIR)
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user