package/rtl8189es: bump to latest version to fix build failure with Linux >= 6.0

Drop local patch that has been upstreamed[0] and drop the endianness
handling too since from this commit[1] on it's handled by using Linux
macro __LITTLE_ENDIAN.

[0]: 4a555ffb77
[1]: b3da33576d

Fixes:
http://autobuild.buildroot.net/results/6178fbfbe9fe762645b1907c4ceb032a00e75a89/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Giulio Benetti 2022-11-16 01:40:55 +01:00 committed by Thomas Petazzoni
parent 124fc473dd
commit 08a013d25a
3 changed files with 3 additions and 49 deletions

View File

@ -1,40 +0,0 @@
From 4a555ffb77a5947814b6c7f330968318e265c496 Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Wed, 28 Sep 2022 21:17:17 +0200
Subject: [PATCH] Makefile: move 'EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)' at the
end of EXTRA_FLAGS assignment
At the moment USER_EXTRA_CFLAGS can't override local Makfile EXTRA_CFLAGS
since it's assigned at the beginning of the Makefile. For example it's not
possible to undefine the hardcoded CONFIG_LITTLE_ENDIAN and this doesn't
allow to build these modules for big endian architectures. So let's move
the assignment of USER_EXTRA_CFLAGS to EXTRA_CFLAGS after the last
EXTRA_CFLAGS assignment.
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
[Upstream status: https://github.com/jwrdegoede/rtl8189ES_linux/pull/83]
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 8fcb7bd..e4664e9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
EXTRA_CFLAGS += -O1
#EXTRA_CFLAGS += -O3
#EXTRA_CFLAGS += -Wall
@@ -2239,6 +2238,8 @@ ifneq ($(USER_MODULE_NAME),)
MODULE_NAME := $(USER_MODULE_NAME)
endif
+EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
+
ifneq ($(KERNELRELEASE),)
########### this part for *.mk ############################
--
2.34.1

View File

@ -1,2 +1,2 @@
# Locally calculated
sha256 74325014c1a8503b3a7e48ad06997baddad8c1dae86bb79f4368532cc3e75fb2 rtl8189es-39c17661136da48f8e9c644194dce6a7f5076896.tar.gz
sha256 96347dbfedd95a217fb89b7b295fe417b711dbad3db896ef0c2fa733c6d150fd rtl8189es-e58bd86c9d9408c648b1246a0dd76b16856ec172.tar.gz

View File

@ -4,20 +4,14 @@
#
################################################################################
RTL8189ES_VERSION = 39c17661136da48f8e9c644194dce6a7f5076896
RTL8189ES_VERSION = e58bd86c9d9408c648b1246a0dd76b16856ec172
RTL8189ES_SITE = $(call github,jwrdegoede,rtl8189ES_linux,$(RTL8189ES_VERSION))
RTL8189ES_LICENSE = GPL-2.0
# Undefine the hardcoded CONFIG_LITTLE_ENDIAN
RTL8189ES_USER_EXTRA_CLAGS = -UCONFIG_LITTLE_ENDIAN
# Set endianness
RTL8189ES_USER_EXTRA_CLAGS += -DCONFIG_$(call qstrip,$(BR2_ENDIAN))_ENDIAN
RTL8189ES_MODULE_MAKE_OPTS = \
CONFIG_RTL8189ES=m \
KVER=$(LINUX_VERSION_PROBED) \
KSRC=$(LINUX_DIR) \
USER_EXTRA_CFLAGS="$(RTL8189ES_USER_EXTRA_CLAGS)"
KSRC=$(LINUX_DIR)
define RTL8189ES_LINUX_CONFIG_FIXUPS
$(call KCONFIG_ENABLE_OPT,CONFIG_NET)