jasper: disable C++ compiler check
Add a patch to disable the default cmake C++ compiler check. Fixes: http://autobuild.buildroot.net/results/970/97001530e59062c36f27721877cb8b5c3ba8906a/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
7a0402d3a8
commit
0852552c69
28
package/jasper/0001-Disable-C-compiler-check.patch
Normal file
28
package/jasper/0001-Disable-C-compiler-check.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From e4ed3e2c3fd5a859567f510deeb49a915d96700f Mon Sep 17 00:00:00 2001
|
||||
From: Baruch Siach <baruch@tkos.co.il>
|
||||
Date: Sat, 14 Jan 2017 21:06:25 +0200
|
||||
Subject: [PATCH] Disable C++ compiler check
|
||||
|
||||
jasper does not use C++ code. Allow use of toolchains without C++ support.
|
||||
|
||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
||||
---
|
||||
Upstream status: https://github.com/mdadams/jasper/pull/110
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6c99b3e7df31..3ac166b060ad 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -1,6 +1,6 @@
|
||||
cmake_minimum_required (VERSION 2.8.11)
|
||||
|
||||
-project(JasPer)
|
||||
+project(JasPer C)
|
||||
|
||||
set(CMAKE_MODULE_PATH
|
||||
${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/build/cmake/modules/")
|
||||
--
|
||||
2.11.0
|
||||
|
Loading…
Reference in New Issue
Block a user