dash: bump to version 0.5.9.1
Use the maintainer's repository, update the package description, based on the official one, and drop an obsolete patch. Change-Id: I2170aa4c1cc57de2a25ef04e89a216b254f2a859 Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
f53c7c162f
commit
080344fb1e
@ -1,40 +0,0 @@
|
||||
tokens: fix parallel builds
|
||||
|
||||
Currently, tokens.h and token_vars.h are each generated by a call to
|
||||
mktokens, which means mktokens is called twice.
|
||||
|
||||
But mktokens generates both in a single run.
|
||||
|
||||
This means that, with a fast-enough machine, the call to mktokens that
|
||||
generates tokens.h may finish before the call that generates
|
||||
token_vars.h. Then tokens.h is transiently incomplete (it can even be
|
||||
empty). By the time it is fully generated in the second run, a compile
|
||||
job that ends up using token.h may have already started, and the source
|
||||
file would include an in complete token.h and would be missing some
|
||||
token definitions.
|
||||
|
||||
We fix that by making token.h a dependency of token_vars.h, with a
|
||||
dummy recipe (to force it not being PHONY). The actual recipe is for
|
||||
token_vars.h
|
||||
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
|
||||
diff -durN dash-0.5.8.orig/src/Makefile.am dash-0.5.8/src/Makefile.am
|
||||
--- dash-0.5.8.orig/src/Makefile.am 2014-09-28 10:19:32.000000000 +0200
|
||||
+++ dash-0.5.8/src/Makefile.am 2017-03-07 09:53:28.579811603 +0100
|
||||
@@ -45,7 +45,14 @@
|
||||
mktokens mkbuiltins builtins.def.in mkinit.c \
|
||||
mknodes.c nodetypes nodes.c.pat mksyntax.c mksignames.c
|
||||
|
||||
-token.h token_vars.h: mktokens
|
||||
+# Both token.h and token_vars.h are generated by a single call
|
||||
+# to mktokens. However, token.h is the only file that is used
|
||||
+# as a dependency, so we must ensure token_vars.h is generated
|
||||
+# first.
|
||||
+token.h: token_vars.h
|
||||
+ @:
|
||||
+
|
||||
+token_vars.h: mktokens
|
||||
sh $^
|
||||
|
||||
builtins.def: builtins.def.in $(top_builddir)/config.h
|
@ -3,7 +3,9 @@ config BR2_PACKAGE_DASH
|
||||
depends on BR2_USE_MMU # fork()
|
||||
depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
|
||||
help
|
||||
The Debian/Linux port of the NetBSD version of
|
||||
ash (the Almquist SHell).
|
||||
DASH is a POSIX-compliant implementation of /bin/sh that aims to be
|
||||
as small as possible. It does this without sacrificing speed where
|
||||
possible. In fact, it is significantly faster than bash (the GNU
|
||||
Bourne-Again SHell) for most tasks.
|
||||
|
||||
http://gondor.apana.org.au/~herbert/dash
|
||||
|
@ -1,3 +1,2 @@
|
||||
# From http://ftp.debian.org/debian/pool/main/d/dash/dash_0.5.8-1.dsc
|
||||
sha256 c6db3a237747b02d20382a761397563d813b306c020ae28ce25a1c3915fac60f dash_0.5.8.orig.tar.gz
|
||||
sha256 d751769cc1ef8b825a177e782f1cd3e35bde7c268107fa4febf8d235e12c64d9 dash_0.5.8-1.diff.gz
|
||||
# From http://gondor.apana.org.au/~herbert/dash/files/dash-0.5.9.1.tar.gz.sha256sum
|
||||
sha256 5ecd5bea72a93ed10eb15a1be9951dd51b52e5da1d4a7ae020efd9826b49e659 dash-0.5.9.1.tar.gz
|
||||
|
@ -4,16 +4,12 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
DASH_VERSION = 0.5.8
|
||||
DASH_SOURCE = dash_$(DASH_VERSION).orig.tar.gz
|
||||
DASH_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/d/dash
|
||||
DASH_PATCH = dash_$(DASH_VERSION)-1.diff.gz
|
||||
DASH_VERSION = 0.5.9.1
|
||||
DASH_SOURCE = dash-$(DASH_VERSION).tar.gz
|
||||
DASH_SITE = http://gondor.apana.org.au/~herbert/dash/files
|
||||
DASH_LICENSE = BSD-3-Clause, GPL-2.0+ (mksignames.c)
|
||||
DASH_LICENSE_FILES = COPYING
|
||||
|
||||
# 0002-fix-parallel-build.patch
|
||||
DASH_AUTORECONF = YES
|
||||
|
||||
define DASH_INSTALL_TARGET_CMDS
|
||||
$(INSTALL) -m 0755 $(@D)/src/dash $(TARGET_DIR)/bin/dash
|
||||
endef
|
||||
|
Loading…
Reference in New Issue
Block a user