mpg123: bump to version 1.23.5
Drop upstreamed patch and related autoreconf. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
c45c69409a
commit
0774798591
@ -1,46 +0,0 @@
|
||||
From 25c2e71c9ce762561eeacd35bf432c6692c0fb44 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Korsgaard <peter@korsgaard.com>
|
||||
Date: Tue, 24 May 2016 17:34:32 +0200
|
||||
Subject: [PATCH] Makefile.am: don't override LIBS
|
||||
|
||||
Patch status: posted upstream
|
||||
https://sourceforge.net/p/mpg123/mailman/message/35111696/
|
||||
|
||||
The recent build system change broke custom LIBS handling. As opposed to the
|
||||
other internal variables, LIBS can be provided by the user when running
|
||||
configure, E.G.:
|
||||
|
||||
LIBS="-lfoo -lbar" ./configure ..
|
||||
|
||||
This is correctly used by the configure checks, but doesn't end up in the
|
||||
Makefile any more because of this override - Breaking static builds where
|
||||
the configure script needs a bit of help to link with -lpthread when
|
||||
alsa/portaudio is used (as those use pthreads internally).
|
||||
|
||||
Fixes the following build issues from the Buildroot autobuilders:
|
||||
|
||||
http://autobuild.buildroot.net/?reason=mpg123-1.23.3
|
||||
|
||||
(see https://git.buildroot.net/buildroot/tree/package/mpg123/mpg123.mk for
|
||||
the build logic)
|
||||
|
||||
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
||||
---
|
||||
Makefile.am | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index d695a3b..863f59f 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -9,7 +9,6 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
bin_PROGRAMS =
|
||||
EXTRA_PROGRAMS =
|
||||
-LIBS =
|
||||
EXTRA_DIST =
|
||||
pkglib_LTLIBRARIES =
|
||||
lib_LTLIBRARIES =
|
||||
--
|
||||
2.7.0
|
||||
|
@ -1,2 +1,2 @@
|
||||
# Locally calculated after checking pgp signature
|
||||
sha256 3495e678dec9a60f29cbcd4fc698abc4c811ec60d1276e744f7a10ac35023b48 mpg123-1.23.4.tar.bz2
|
||||
sha256 b658df672813511ff9b68a1553917220b675067204cdb58dbb59a2b8179350b2 mpg123-1.23.5.tar.bz2
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
MPG123_VERSION = 1.23.4
|
||||
MPG123_VERSION = 1.23.5
|
||||
MPG123_SOURCE = mpg123-$(MPG123_VERSION).tar.bz2
|
||||
MPG123_SITE = http://downloads.sourceforge.net/project/mpg123/mpg123/$(MPG123_VERSION)
|
||||
MPG123_CONF_OPTS = --disable-lfs-alias
|
||||
@ -12,8 +12,6 @@ MPG123_INSTALL_STAGING = YES
|
||||
MPG123_LICENSE = LGPLv2.1
|
||||
MPG123_LICENSE_FILES = COPYING
|
||||
MPG123_DEPENDENCIES = host-pkgconf
|
||||
# 0001-Makefile.am-don-t-override-LIBS.patch patches Makefile.am
|
||||
MPG123_AUTORECONF = YES
|
||||
|
||||
MPG123_CPU = $(if $(BR2_SOFT_FLOAT),generic_nofpu,generic_fpu)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user