Update ltp to the latest version. Current results:
$ grep FAIL logfile fcntl18 2 FAIL : Test F_GETLK64: for errno EFAULT FAILED fcntl18 0 INFO : Block 2 FAILED fcntl18 2 FAIL : Test F_GETLK64: for errno EFAULT FAILED fcntl18 0 INFO : Block 2 FAILED flock03 2 FAIL : Child: Unable to relock file after unlocking, errno 37 flock03 2 FAIL : flock03 Failed nanosleep02 1 FAIL : Remaining sleep time 4010000 usec doesn't match with the expected 3992631 usec time nanosleep02 1 FAIL : child process exited abnormally INFO: pan reported some tests FAIL $ grep BROK logfile setgroups04 1 BROK : Unexpected signal 11 received. swapoff02 1 BROK : Failed to turn on the swap file. skipping the test iteration swapoff02 2 BROK : Remaining cases broken swapoff02 3 BROK : Remaining cases broken
This commit is contained in:
parent
63bcb19b20
commit
073534b925
@ -3,10 +3,10 @@
|
|||||||
# ltp-testsuite
|
# ltp-testsuite
|
||||||
#
|
#
|
||||||
#############################################################
|
#############################################################
|
||||||
LTP_TESTSUITE_SOURCE:=ltp-full-20031204.tgz
|
LTP_TESTSUITE_SOURCE:=ltp-full-20040108.tgz
|
||||||
LTP_TESTSUITE_SITE:=http://aleron.dl.sourceforge.net/sourceforge/ltp
|
LTP_TESTSUITE_SITE:=http://aleron.dl.sourceforge.net/sourceforge/ltp
|
||||||
LTP_TESTSUITE_CAT:=zcat
|
LTP_TESTSUITE_CAT:=zcat
|
||||||
LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20031204
|
LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20040108
|
||||||
LTP_TESTSUITE_PATCH:=$(SOURCE_DIR)/ltp-testsuite.patch
|
LTP_TESTSUITE_PATCH:=$(SOURCE_DIR)/ltp-testsuite.patch
|
||||||
|
|
||||||
|
|
||||||
|
@ -9,20 +9,6 @@
|
|||||||
|
|
||||||
all: $(TARGETS)
|
all: $(TARGETS)
|
||||||
|
|
||||||
--- ltp-full-20031204/testcases/kernel/syscalls/mallopt/mallopt01.orig.c
|
|
||||||
+++ ltp-full-20031204/testcases/kernel/syscalls/mallopt/mallopt01.c
|
|
||||||
@@ -85,11 +85,6 @@
|
|
||||||
flag = 1;
|
|
||||||
local_flag = FAILED;
|
|
||||||
};
|
|
||||||
- if (info.usmblks != 0) {
|
|
||||||
- fprintf(temp, "mallinfo failed: usmblks != 0\n");
|
|
||||||
- flag = 1;
|
|
||||||
- local_flag = FAILED;
|
|
||||||
- }
|
|
||||||
if (info.smblks != 0) {
|
|
||||||
fprintf(temp, "mallinfo failed: smblks != 0\n");
|
|
||||||
flag = 1;
|
|
||||||
--- ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile.orig 2003-10-02 19:27:53.000000000 -0600
|
--- ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile.orig 2003-10-02 19:27:53.000000000 -0600
|
||||||
+++ ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile 2003-10-02 19:28:02.000000000 -0600
|
+++ ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile 2003-10-02 19:28:02.000000000 -0600
|
||||||
@@ -23,7 +23,7 @@
|
@@ -23,7 +23,7 @@
|
||||||
@ -71,39 +57,6 @@
|
|||||||
@echo 'NPtcp has been built.'
|
@echo 'NPtcp has been built.'
|
||||||
|
|
||||||
NPtcp-ipv6: NPtcp.o TCP.o
|
NPtcp-ipv6: NPtcp.o TCP.o
|
||||||
--- ltp-full-20031204/testcases/kernel/syscalls/setresuid/setresuid03.orig.c 2004-01-01 20:27:14.000000000 -0700
|
|
||||||
+++ ltp-full-20031204/testcases/kernel/syscalls/setresuid/setresuid03.c 2004-01-01 20:27:21.000000000 -0700
|
|
||||||
@@ -76,7 +76,7 @@
|
|
||||||
extern int setresuid(uid_t, uid_t, uid_t);
|
|
||||||
|
|
||||||
int neg_one = -1;
|
|
||||||
-int inval_user = 999999;
|
|
||||||
+int inval_user = (USHRT_MAX-2);
|
|
||||||
|
|
||||||
/* flag to tell parent if child passed or failed. */
|
|
||||||
int flag = 0;
|
|
||||||
--- ltp-full-20031204/testcases/kernel/syscalls/setreuid/setreuid06.orig.c 2004-01-01 20:30:36.000000000 -0700
|
|
||||||
+++ ltp-full-20031204/testcases/kernel/syscalls/setreuid/setreuid06.c 2004-01-01 20:41:00.000000000 -0700
|
|
||||||
@@ -53,7 +53,7 @@
|
|
||||||
#include "test.h"
|
|
||||||
#include "usctest.h"
|
|
||||||
|
|
||||||
-#define INVAL_USER 999999
|
|
||||||
+#define INVAL_USER (USHRT_MAX-2)
|
|
||||||
|
|
||||||
char *TCID = "setreuid06";
|
|
||||||
int TST_TOTAL = 1;
|
|
||||||
--- ltp-full-20031204/testcases/kernel/syscalls/setregid/setregid02.orig.c 2004-01-01 20:44:47.000000000 -0700
|
|
||||||
+++ ltp-full-20031204/testcases/kernel/syscalls/setregid/setregid02.c 2004-01-01 20:44:18.000000000 -0700
|
|
||||||
@@ -79,7 +79,7 @@
|
|
||||||
gid_t users_gr_gid, root_gr_gid, bin_gr_gid;
|
|
||||||
int neg_one = -1;
|
|
||||||
int exp_enos[]={EPERM, 0};
|
|
||||||
-int inval_user = 999999;
|
|
||||||
+int inval_user = (USHRT_MAX-2);
|
|
||||||
char nobody_uid[] = "nobody";
|
|
||||||
struct passwd *ltpuser;
|
|
||||||
|
|
||||||
--- ltp-full-20031106/testcases/kernel/syscalls/string/string01.orig.c 2004-01-01 23:54:37.000000000 -0700
|
--- ltp-full-20031106/testcases/kernel/syscalls/string/string01.orig.c 2004-01-01 23:54:37.000000000 -0700
|
||||||
+++ ltp-full-20031106/testcases/kernel/syscalls/string/string01.c 2004-01-01 23:55:48.000000000 -0700
|
+++ ltp-full-20031106/testcases/kernel/syscalls/string/string01.c 2004-01-01 23:55:48.000000000 -0700
|
||||||
@@ -413,10 +413,10 @@
|
@@ -413,10 +413,10 @@
|
||||||
@ -120,36 +73,17 @@
|
|||||||
local_flag = FAILED;
|
local_flag = FAILED;
|
||||||
}
|
}
|
||||||
i++;
|
i++;
|
||||||
--- ltp-full-20031106/testcases/kernel/syscalls/ipc/msgctl/msgctl08.c.orig 2004-01-03 02:26:31.000000000 -0700
|
--- ltp-full-20040108/testcases/kernel/syscalls/pipe/pipe07.c.orig 2003-12-15 10:08:10.000000000 -0700
|
||||||
+++ ltp-full-20031106/testcases/kernel/syscalls/ipc/msgctl/msgctl08.c 2004-01-03 02:26:48.000000000 -0700
|
+++ ltp-full-20040108/testcases/kernel/syscalls/pipe/pipe07.c 2004-01-11 00:55:55.000000000 -0700
|
||||||
@@ -399,7 +399,7 @@
|
@@ -84,8 +84,9 @@
|
||||||
/* FIXME: Start at -4 because ipcs prints four lines of header */
|
setup();
|
||||||
for (used_queues = -4; fgets(buff, BUFSIZE, f); used_queues++)
|
/* Get the currently used number of file descriptors */
|
||||||
;
|
mypid=getpid();
|
||||||
- fclose(f);
|
- cmdstring=malloc(sizeof(cmdstring));
|
||||||
+ pclose(f);
|
- sprintf(cmdstring,"ls -A -1 /proc/%d/fd | wc -l | awk {'print $1'}> pipe07.tmp",mypid);
|
||||||
if (used_queues < 0) {
|
+ cmdstring=malloc(BUFSIZ);
|
||||||
tst_resm(TBROK,"Could not read output of 'ipcs' to calculate used message queues");
|
+ snprintf(cmdstring, BUFSIZ, "ls -A -1 /proc/%d/fd | "
|
||||||
tst_exit();
|
+ "wc -l | awk {'print $1'}> pipe07.tmp", mypid);
|
||||||
--- ltp-full-20031106/testcases/kernel/syscalls/ipc/msgctl/msgctl09.c.orig 2004-01-03 02:26:36.000000000 -0700
|
if (system(cmdstring) == 0)
|
||||||
+++ ltp-full-20031106/testcases/kernel/syscalls/ipc/msgctl/msgctl09.c 2004-01-03 02:26:53.000000000 -0700
|
{
|
||||||
@@ -563,7 +563,7 @@
|
f = fopen("pipe07.tmp", "r");
|
||||||
/* FIXME: Start at -4 because ipcs prints four lines of header */
|
|
||||||
for (used_queues = -4; fgets(buff, BUFSIZE, f); used_queues++)
|
|
||||||
;
|
|
||||||
- fclose(f);
|
|
||||||
+ pclose(f);
|
|
||||||
if (used_queues < 0) {
|
|
||||||
tst_resm(TBROK,"Could not read output of 'ipcs' to calculate used message queues");
|
|
||||||
tst_exit();
|
|
||||||
--- ltp-full-20031106/testcases/kernel/syscalls/getcwd/getcwd03.orig.c 2004-01-03 02:43:05.000000000 -0700
|
|
||||||
+++ ltp-full-20031106/testcases/kernel/syscalls/getcwd/getcwd03.c 2004-01-03 02:43:19.000000000 -0700
|
|
||||||
@@ -242,7 +242,7 @@
|
|
||||||
char *
|
|
||||||
getpwd()
|
|
||||||
{
|
|
||||||
- FILE *fin, *popen();
|
|
||||||
+ FILE *fin;
|
|
||||||
char *pwd = "/bin/pwd";
|
|
||||||
char *cp, *cp_cur;
|
|
||||||
char *buf;
|
|
||||||
|
Loading…
Reference in New Issue
Block a user