package/openocd: selects jimtcl
Selects jimtcl instead of using the bundled one and drop first patch as it is not needed anymore Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
1d2c4081f0
commit
06aa299535
@ -1,27 +0,0 @@
|
||||
From 3bef159779c8fd39a070ec5c8191e18ba2efa79d Mon Sep 17 00:00:00 2001
|
||||
From: Claudio Laurita <claudio.laurita@integrazionetotale.it>
|
||||
Date: Sun, 30 Nov 2014 18:21:58 +0100
|
||||
Subject: [PATCH 2/2] Fix jimtcl auto configuration to force static library
|
||||
only. jimtcl ignores a --disable-shared option if a previous --enable-shared
|
||||
option was given. This breaks openocd compilation if shared was the preferred
|
||||
option in buildroot project.
|
||||
|
||||
Signed-off-by: Claudio Laurita <claudio.laurita@integrazionetotale.it>
|
||||
|
||||
--- a/jimtcl/auto.def
|
||||
+++ b/jimtcl/auto.def
|
||||
@@ -194,12 +194,8 @@
|
||||
msg-result "Enabling references"
|
||||
define JIM_REFERENCES
|
||||
}
|
||||
-if {[opt-bool shared with-jim-shared]} {
|
||||
- msg-result "Building shared library"
|
||||
-} else {
|
||||
- msg-result "Building static library"
|
||||
- define JIM_STATICLIB
|
||||
-}
|
||||
+msg-result "Building static library"
|
||||
+define JIM_STATICLIB
|
||||
define LIBSOEXT [format [get-define SH_SOEXTVER] [format %.2f [expr {[get-define JIM_VERSION] / 100.0}]]]
|
||||
define JIM_INSTALL [opt-bool install-jim]
|
||||
define JIM_DOCS [opt-bool docs]
|
@ -1,5 +1,6 @@
|
||||
config BR2_PACKAGE_OPENOCD
|
||||
bool "openocd"
|
||||
select BR2_PACKAGE_JIMTCL
|
||||
help
|
||||
OpenOCD - Open On-Chip Debugger
|
||||
|
||||
|
@ -11,18 +11,13 @@ OPENOCD_LICENSE = GPL-2.0+
|
||||
OPENOCD_LICENSE_FILES = COPYING
|
||||
# 0002-configure-enable-build-on-uclinux.patch patches configure.ac
|
||||
OPENOCD_AUTORECONF = YES
|
||||
|
||||
# The bundled jimtcl really wants to find a existing $CXX, so feed it
|
||||
# false when we do not have one.
|
||||
OPENOCD_CONF_ENV = \
|
||||
$(if $(BR2_INSTALL_LIBSTDCPP),,CXX=false) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
|
||||
OPENOCD_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
|
||||
|
||||
OPENOCD_CONF_OPTS = \
|
||||
--oldincludedir=$(STAGING_DIR)/usr/include \
|
||||
--includedir=$(STAGING_DIR)/usr/include \
|
||||
--disable-doxygen-html \
|
||||
--with-jim-shared=no \
|
||||
--disable-internal-jimtcl \
|
||||
--disable-shared \
|
||||
--enable-dummy \
|
||||
--disable-werror
|
||||
@ -32,6 +27,7 @@ OPENOCD_CONF_OPTS = \
|
||||
|
||||
OPENOCD_DEPENDENCIES = \
|
||||
host-pkgconf \
|
||||
jimtcl \
|
||||
$(if $(BR2_PACKAGE_LIBFTDI1),libftdi1) \
|
||||
$(if $(BR2_PACKAGE_LIBUSB),libusb) \
|
||||
$(if $(BR2_PACKAGE_LIBUSB_COMPAT),libusb-compat) \
|
||||
|
Loading…
Reference in New Issue
Block a user