From 06a1a05b55aa64720d4ede9b07c385cc8f06625d Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Sat, 9 Jul 2022 09:07:08 +0200
Subject: [PATCH] package/libvpx: vp8 encoder needs c++

Encoding rate control interface for v8 is implemented in c++:
https://github.com/webmproject/libvpx/commit/65a1751e5b98bf7f1d21bcbfdef352af34fb205d
and was added to libvpx in v1.12.0 which was added to buildroot with
https://git.busybox.net/buildroot/commit/?id=e4ff284ba88ea0cb41c190165cb42a174c5faa23

Disable vp8 encoding when toolchain lacks c++.

Fixes:
http://autobuild.buildroot.net/results/a3524b954e53002973b423ce23b4c43ff5281ab5/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/libvpx/libvpx.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/package/libvpx/libvpx.mk b/package/libvpx/libvpx.mk
index 1845f2bc5e..c8a22b9ab2 100644
--- a/package/libvpx/libvpx.mk
+++ b/package/libvpx/libvpx.mk
@@ -21,11 +21,11 @@ LIBVPX_CONF_OPTS = \
 	--disable-docs \
 	--disable-unit-tests
 
-# vp9/ratectrl_rtc.cc
+# vp8/ratectrl_rtc.cc vp9/ratectrl_rtc.cc
 ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
-LIBVPX_CONF_OPTS += --enable-vp9-encoder
+LIBVPX_CONF_OPTS += --enable-vp8-encoder --enable-vp9-encoder
 else
-LIBVPX_CONF_OPTS += --disable-vp9-encoder
+LIBVPX_CONF_OPTS += --disable-vp8-encoder --disable-vp9-encoder
 endif
 
 # This is not a true autotools package.  It is based on the ffmpeg build system