package/network-manager: bump to version 1.44.2

Drop patches which are now upstream.

CONTRIBUTING.md hash changed due to text various text updates, most of
them outside of the section about licensing. The only change in that
section is:

@@ -39,26 +39,29 @@
 new contributions already must already agree to that.
 For more details see [RELICENSE.md](RELICENSE.md).

+Do not use "Signed-off-by:" lines in commits for NetworkManager. It has no meaning.
+

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
This commit is contained in:
James Hilliard 2023-10-14 23:15:44 -06:00 committed by Arnout Vandecappelle
parent 560f9dbc88
commit 0455f957a3
4 changed files with 5 additions and 103 deletions

View File

@ -1,60 +0,0 @@
From 03ba04d4784fa4fc7ec31455070fb5ecf25ade23 Mon Sep 17 00:00:00 2001
From: Heiko Thiery <heiko.thiery@gmail.com>
Date: Fri, 27 Jan 2023 22:38:42 +0100
Subject: [PATCH] build: meson: add option to set the
mobile-broadband-provider-info database
When building network-manager in cross-compile environment meson is not able
to detect the right location of the mobile-broadband-provider-info
database by using the pkg-config module.
By adding the option 'mobile_broadband_provider_info_database' to set the
correct path to the datafile this can be solved.
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/1519
---
meson.build | 6 +++++-
meson_options.txt | 1 +
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 0adc42f738..84ce52c736 100644
--- a/meson.build
+++ b/meson.build
@@ -584,7 +584,10 @@ enable_modem_manager = get_option('modem_manager')
if enable_modem_manager
mm_glib_dep = dependency('mm-glib', version: '>= 0.7.991')
- mobile_broadband_provider_info_database = dependency('mobile-broadband-provider-info').get_pkgconfig_variable('database')
+ mobile_broadband_provider_info_database = get_option('mobile_broadband_provider_info_database')
+ if mobile_broadband_provider_info_database == ''
+ mobile_broadband_provider_info_database = dependency('mobile-broadband-provider-info').get_pkgconfig_variable('database')
+ endif
config_h.set_quoted('MOBILE_BROADBAND_PROVIDER_INFO_DATABASE', mobile_broadband_provider_info_database)
endif
@@ -1054,6 +1057,7 @@ output += ' jansson: ' + jansson_msg + '\n'
output += ' iptables: ' + config_h.get('IPTABLES_PATH') + '\n'
output += ' nft: ' + config_h.get('NFT_PATH') + '\n'
output += ' modemmanager-1: ' + enable_modem_manager.to_string() + '\n'
+output += ' mobile-broadband-provider-info-database: ' + mobile_broadband_provider_info_database + '\n'
output += ' ofono: ' + enable_ofono.to_string() + '\n'
output += ' concheck: ' + enable_concheck.to_string() + '\n'
output += ' libteamdctl: ' + enable_teamdctl.to_string() + '\n'
diff --git a/meson_options.txt b/meson_options.txt
index 8b1d32e645..4e359f9e92 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -32,6 +32,7 @@ option('ppp', type: 'boolean', value: true, description: 'enable PPP/PPPoE suppo
option('pppd', type: 'string', value: '', description: 'path to pppd binary')
option('pppd_plugin_dir', type: 'string', value: '', description: 'path to the pppd plugins directory')
option('modem_manager', type: 'boolean', value: true, description: 'Enable new ModemManager1 interface support')
+option('mobile_broadband_provider_info_database', type: 'string', value: '', description: 'path to the mobile-broadband-provider-info database')
option('ofono', type: 'boolean', value: false, description: 'Enable oFono support (experimental)')
option('concheck', type: 'boolean', value: true, description: 'enable connectivity checking support')
option('teamdctl', type: 'boolean', value: false, description: 'enable Teamd control support')
--
2.20.1

View File

@ -1,38 +0,0 @@
From 736a2c356c1c4871e8c4e70be622c65c87d3bca8 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Tue, 21 Feb 2023 13:03:00 +0100
Subject: [PATCH] meson.build: fix build failure with -Dmodem_manager=false
Fix the following build failure with -Dmodem_manager=false raised since
https://gitlab.freedesktop.org/ffontaine/NetworkManager/-/commit/03ba04d4784fa4fc7ec31455070fb5ecf25ade23:
../output-1/build/network-manager-1.40.10/meson.build:1060:0: ERROR: Unknown variable "mobile_broadband_provider_info_database".
Fixes:
- http://autobuild.buildroot.org/results/896879c8e8ce022556ee834216ced2f962ff279c
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status:
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/1544]
---
meson.build | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 84ce52c736..b79240efc0 100644
--- a/meson.build
+++ b/meson.build
@@ -1057,7 +1057,9 @@ output += ' jansson: ' + jansson_msg + '\n'
output += ' iptables: ' + config_h.get('IPTABLES_PATH') + '\n'
output += ' nft: ' + config_h.get('NFT_PATH') + '\n'
output += ' modemmanager-1: ' + enable_modem_manager.to_string() + '\n'
-output += ' mobile-broadband-provider-info-database: ' + mobile_broadband_provider_info_database + '\n'
+if enable_modem_manager
+ output += ' mobile-broadband-provider-info-database: ' + mobile_broadband_provider_info_database + '\n'
+endif
output += ' ofono: ' + enable_ofono.to_string() + '\n'
output += ' concheck: ' + enable_concheck.to_string() + '\n'
output += ' libteamdctl: ' + enable_teamdctl.to_string() + '\n'
--
2.39.0

View File

@ -1,6 +1,6 @@
# From https://download.gnome.org/sources/NetworkManager/1.42/NetworkManager-1.42.0.sha256sum
sha256 2f6756d507bb6b46716594b67e6fe7491891e1b5b167bbafc5157dfa7753d5b4 NetworkManager-1.42.0.tar.xz
# From https://download.gnome.org/sources/NetworkManager/1.44/NetworkManager-1.44.2.sha256sum
sha256 4b58bf3ac57e2cefb5652efd0945eb0b4bc36a63d92a61ab471d8bb2c9a420e1 NetworkManager-1.44.2.tar.xz
# Locally computed
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING.LGPL
sha256 cfb6c71f6df5898e1724be3debe9adac48c115b903915406c1e7dfd362b57892 CONTRIBUTING.md
sha256 e7cf3d92bda8e5365eaf4514d572146a19e93336f7a966493778d0d0c4476fae CONTRIBUTING.md

View File

@ -4,8 +4,8 @@
#
################################################################################
NETWORK_MANAGER_VERSION_MAJOR = 1.42
NETWORK_MANAGER_VERSION = $(NETWORK_MANAGER_VERSION_MAJOR).0
NETWORK_MANAGER_VERSION_MAJOR = 1.44
NETWORK_MANAGER_VERSION = $(NETWORK_MANAGER_VERSION_MAJOR).2
NETWORK_MANAGER_SOURCE = NetworkManager-$(NETWORK_MANAGER_VERSION).tar.xz
NETWORK_MANAGER_SITE = https://download.gnome.org/sources/NetworkManager/$(NETWORK_MANAGER_VERSION_MAJOR)
NETWORK_MANAGER_INSTALL_STAGING = YES