package/acpica: bump to version 20230628

For change log since 20220331, see:
- https://github.com/acpica/acpica/blob/R06_28_23/documents/changes.txt

This commit also drop the patch removing -Werror in CFLAGS, as an
alternative is now available upstream, merged in [1]. This commit is
included in release 20221020. The build commands are updated
accordingly to set the new NOWERROR=TRUE option to achieve the same
behavior.

With the patch removal, .checkpackageignore is also updated
accordingly.

Upstream commit [2] also introduced a use of wcslen() and <wchar.h>.
This commit was first included in tag R10_20_22 (version 20221020).
Therefore, this new version need wchar. The new depedency is added.

The _SOURCE file is also changed from acpica-unix2 to acpica-unix,
as the current acpica download page at [3] shows:

"""
Note: The unix2 source package is deprecated since the dual license is
now included in all source modules (along with the Intel
license). This package will be removed from future ACPICA releases.
"""

The _SITE url is also updated to the new download link, since the
acpica website now redirects to Intel:

    curl -si https://www.acpica.org | grep Location:
    Location: https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html

The license file hash is also updated, due to the copyright year
update. It is also worth mentioning that the files in the new archive
have three alternative licenses in their headers: Intel, BSD-3-Clause
and GPL-2.0.

Finally, since a SHA1 hash is published on the download page, it is
added to the hash file.

This version bump is motivated by the introduction of RISC-V related
definitions.

[1] 3fd0f94040
[2] cd6a308975
[3] https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/download.html

Cc: Erico Nunes <nunes.erico@gmail.com>
Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Julien Olivain 2023-07-25 23:36:09 +02:00 committed by Thomas Petazzoni
parent 90cedc23be
commit 0403bdd929
5 changed files with 12 additions and 90 deletions

View File

@ -136,7 +136,6 @@ package/4th/0001-avoid-regen-during-install.patch Upstream
package/ace/0001-ACE-ace-SSL-SSL_Asynch_BIO.cpp-fix-build-with-libres.patch Upstream
package/ace/0002-ACE-ace-SSL-SSL_Asynch_BIO.cpp-fix-build-with-libres.patch Upstream
package/acl/0001-Build-with-old-GCC-versions.patch Upstream
package/acpica/0001-build-do-not-use-Werror.patch Upstream
package/acpid/0001-dont-use-isfdtype.patch Upstream
package/alchemy/0001-toolchains-remove-hash-style-management.patch Upstream
package/alsamixergui/0001-misc-fixes.patch Sob Upstream

View File

@ -1,82 +0,0 @@
From 9382ae2431d2962c430e7149302c8690f5bc159c Mon Sep 17 00:00:00 2001
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
Date: Sun, 10 Jul 2016 15:06:15 +0200
Subject: [PATCH] build: do not use -Werror
Warnings come and go with various compiler versions, so using -Werror is
prone to cause build failures with various compiler versions, especially
newer versions that introduce new warnings.
Remove use of -Werror.
[Vincent: tweak patch for 20170531 release]
[Bernd: tweak patch for 20191018 release]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: "Vicente Olivert Riera" <Vincent.Riera@imgtec.com>
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
generate/unix/Makefile.config | 1 -
generate/unix/iasl/Makefile | 16 ++++++++--------
2 files changed, 8 insertions(+), 9 deletions(-)
diff --git a/generate/unix/Makefile.config b/generate/unix/Makefile.config
index c28e8a9b1..7064bed97 100644
--- a/generate/unix/Makefile.config
+++ b/generate/unix/Makefile.config
@@ -204,7 +204,6 @@ CWARNINGFLAGS = \
-Wall\
-Wbad-function-cast\
-Wdeclaration-after-statement\
- -Werror\
-Wformat=2\
-Wmissing-declarations\
-Wmissing-prototypes\
diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile
index 47ea73cab..2c756af79 100644
--- a/generate/unix/iasl/Makefile
+++ b/generate/unix/iasl/Makefile
@@ -360,32 +360,32 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prparser.y.h : $(ASL_COMPILER)/prparse
#
$(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/dtcompilerparserlex.o : $(OBJDIR)/dtcompilerparserlex.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/dtcompilerparserparse.o : $(OBJDIR)/dtcompilerparserparse.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
$(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c
@echo "- " "Intermediate" $<
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
--
2.20.1

View File

@ -1,5 +1,6 @@
config BR2_PACKAGE_ACPICA
bool "acpica"
depends on BR2_USE_WCHAR
depends on BR2_TOOLCHAIN_HAS_THREADS
help
The ACPI Component Architecture (ACPICA) project provides an
@ -9,5 +10,5 @@ config BR2_PACKAGE_ACPICA
https://www.acpica.org
comment "acpica needs a toolchain w/ threads"
depends on !BR2_TOOLCHAIN_HAS_THREADS
comment "acpica needs a toolchain w/ threads, wchar"
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS

View File

@ -1,3 +1,5 @@
# From: https://www.intel.com/content/www/us/en/download/776303/acpi-component-architecture-downloads-unix-format-source-code-and-build-environment-with-an-intel-license.html
sha1 3b893fb771cf3fbd3531de3036e1a5bfc624c9d2 acpica-unix-20230628.tar.gz
# locally computed hash
sha256 1ccda5c6a08a90b145777df635eb09f995b3472b3128f375009c5a6b01a04c7a acpica-unix2-20220331.tar.gz
sha256 40d8e351f8dfdf5340ec76ac28f0c201b825077d7060bb3686ca1112cb26985d source/include/acpi.h
sha256 86876a745e3d224dcfd222ed3de465b47559e85811df2db9820ef09a9dff5cce acpica-unix-20230628.tar.gz
sha256 905d6f191f3c29aa673602d9c66eb8df00f7e1b35064a081e0de81284ff17ee6 source/include/acpi.h

View File

@ -4,9 +4,9 @@
#
################################################################################
ACPICA_VERSION = 20220331
ACPICA_SOURCE = acpica-unix2-$(ACPICA_VERSION).tar.gz
ACPICA_SITE = https://acpica.org/sites/acpica/files
ACPICA_VERSION = 20230628
ACPICA_SOURCE = acpica-unix-$(ACPICA_VERSION).tar.gz
ACPICA_SITE = https://downloadmirror.intel.com/783534
ACPICA_LICENSE = BSD-3-Clause or GPL-2.0
ACPICA_LICENSE_FILES = source/include/acpi.h
ACPICA_DEPENDENCIES = host-bison host-flex
@ -15,11 +15,13 @@ HOST_ACPICA_DEPENDENCIES = host-bison host-flex
define ACPICA_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
HARDWARE_NAME=$(BR2_ARCH) HOST=_LINUX CC="$(TARGET_CC)" \
NOWERROR=TRUE \
all
endef
define HOST_ACPICA_BUILD_CMDS
$(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
NOWERROR=TRUE \
all
endef