package/libfuse3: bump to version 3.16.1

Let's drop local patch that has been upstreamed:
b58a0014bf

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Giulio Benetti 2023-08-22 21:16:34 +02:00 committed by Thomas Petazzoni
parent 2b765178f4
commit 0389e298a6
3 changed files with 2 additions and 45 deletions

View File

@ -1,43 +0,0 @@
From b58a0014bff619f1810af49441d987d732c4244e Mon Sep 17 00:00:00 2001
From: Rudi Heitbaum <rudi@heitbaum.com>
Date: Tue, 13 Jun 2023 20:02:01 +1000
Subject: [PATCH] Wrapper around test applications for cross compiler
environment in meson.build (#804)
This enhances commit 7be56c57f93e3436b1fbd9ecc320de5c03a3e4b8 to allow build
fuse to be built using a cross compiler
Fixes:
../meson.build:180:12: ERROR: Can not run test applications in this cross environment.
Upstream: https://github.com/libfuse/libfuse/commit/b58a0014bff619f1810af49441d987d732c4244e
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
meson.build | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/meson.build b/meson.build
index 7aa4e0d..9707ea3 100644
--- a/meson.build
+++ b/meson.build
@@ -177,10 +177,12 @@ int main()
}
'''
-result = cc.run(detect_getmntent_needs_unescape)
-if result.compiled() and result.returncode() == 0 and result.stdout().strip() == 'needs escaping'
- message('getmntent does not unescape')
- add_project_arguments('-DGETMNTENT_NEEDS_UNESCAPING', language: 'c')
+if not meson.is_cross_build()
+ result = cc.run(detect_getmntent_needs_unescape)
+ if result.compiled() and result.returncode() == 0 and result.stdout().strip() == 'needs escaping'
+ message('getmntent does not unescape')
+ add_project_arguments('-DGETMNTENT_NEEDS_UNESCAPING', language: 'c')
+ endif
endif
# Write private test results into fuse_config.h (stored in build directory)
--
2.34.1

View File

@ -1,3 +1,3 @@
# Locally calculated sha256 checksums
sha256 cb93e170288804d2e83da9b69925d968655ed75883476773ba5268d08bb1d335 libfuse3-3.15.1.tar.gz
sha256 17c44c13f6a123c0c13d074fcf61c230a88531202a40c864187dee78f5851693 libfuse3-3.16.1.tar.gz
sha256 b8832d9caaa075bbbd2aef24efa09f8b7ab66a832812d88c602da0c7b4397fad LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBFUSE3_VERSION = 3.15.1
LIBFUSE3_VERSION = 3.16.1
LIBFUSE3_SITE = $(call github,libfuse,libfuse,fuse-$(LIBFUSE3_VERSION))
LIBFUSE3_LICENSE = LGPL-2.1
LIBFUSE3_LICENSE_FILES = LICENSE